Decisioneering.CB.CBCOMDevKit Namespace

CollapseAll image | DropDown image
C#

Visual Basic

Visual Basic Usage

CB Com Devkit
Decisioneering.CB.CBCOMDevKit Namespace
Crystal Ball COM and .NET Development Kit Namespace

Types

All Types | Classes
Name | Description
MRWrapper | MR Command wrapper. Use in using statements to ensure MR status tracked and set into command processor for all COM visible calls for DevKit integration.


MRWrapper Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
MRWrapper Class
MR Command wrapper. Use in using statements to ensure MR status tracked and set into command processor for all COM visible calls for DevKit integration.

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class MRWrapper : IDisposable
Public Class MRWrapper
    Implements IDisposable
Dim instance As MRWrapper

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
MRWrapper(String, Boolean) | Create an MRWrapper object to ensure Macro result status tracked.
MRWrapper(String, Boolean, MacroResult) | Create an MRWrapper object to ensure Macro result status tracked.
CommandName | The command name for this MacroResult
DialogResult | Any dialog result for this Macro
Dispose()()()() | Dispose this object
ElapsedTimeInMS | The elapsed time for this command call in milliseconds
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ErrorDetails | The error details
ErrorMessage | The error message
ErrorNumber | The error number, equates to New Value error numbers
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IsOk | Is an error present
LastResult | The last error result
SetError(Exception) | Set the MR error for all errors encountered by the host class
SetError(Exception, Boolean) | Sets the curent error
ThrowErrors | This macro result errors are thrown
Title | The error title
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit..::..MRWrapper

See Also

Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper Constructor

Visual Basic Usage

| See Also
CB Com Devkit
MRWrapper Constructor

Overload List

Name | Description
MRWrapper(String, Boolean) | Create an MRWrapper object to ensure Macro result status tracked.
MRWrapper(String, Boolean, MacroResult) | Create an MRWrapper object to ensure Macro result status tracked.

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper Constructor (String, Boolean)

Visual Basic Usage

CB Com Devkit
MRWrapper Constructor (String, Boolean)
Create an MRWrapper object to ensure Macro result status tracked.

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public MRWrapper(
    string commandName,
    bool throwErrors
)
Public Sub New (
    commandName As String,
    throwErrors As Boolean
)
Dim commandName As String
Dim throwErrors As Boolean

Dim instance As New MRWrapper(commandName,
    throwErrors)

Parameters

commandName
String
The name of the command
throwErrors
Boolean
True if errors are thrown

See Also

MRWrapper Class
MRWrapper Overload
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper Constructor (String, Boolean, )

Visual Basic Usage

CB Com Devkit
MRWrapper Constructor (String, Boolean, MacroResult)
Create an MRWrapper object to ensure Macro result status tracked.

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public MRWrapper(
    string commandName,
    bool throwErrors,
    MacroResult mr
)
Public Sub New (
    commandName As String,
    throwErrors As Boolean,
    mr As MacroResult
)
Dim commandName As String
Dim throwErrors As Boolean
Dim mr As MacroResult

Dim instance As New MRWrapper(commandName,
    throwErrors, mr)

Parameters

commandName
String
The name of the command
throwErrors
Boolean
True if errors are thrown
mr
MacroResult
Current Macro result

See Also

MRWrapper Class
MRWrapper Overload
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper Methods

Visual Basic Usage

CB Com Devkit
MRWrapper Methods

The MRWrapper type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dispose()()()() | Dispose this object
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SetError(Exception) | Set the MR error for all errors encountered by the host class
SetError(Exception, Boolean) | Sets the curent error
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.Dispose Method

Visual Basic Usage

CB Com Devkit
MRWrapper..::Dispose Method
Dispose this object

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Dispose()
Public Sub Dispose
Dim instance As MRWrapper

instance.Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.SetError Method

Visual Basic Usage

CB Com Devkit
MRWrapper..::SetError Method

Overload List

Name | Description
SetError(Exception) | Set the MR error for all errors encountered by the host class
SetError(Exception, Boolean) | Sets the curent error

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.SetError Method (Exception)

Visual Basic Usage

CB Com Devkit
MRWrapper..::SetError Method (Exception)
Set the MR error for all errors encountered by the host class

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SetError(
    Exception ex
)
Public Sub SetError (
    ex As Exception
)
Dim instance As MRWrapper
Dim ex As Exception

instance.SetError(ex)

Parameters

ex
Exception
The Exception to set to the MR

See Also

MRWrapper Class
SetError Overload
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.SetError Method (Exception, Boolean)

Visual Basic Usage

CB Com Devkit
MRWrapper..::SetError Method (Exception, Boolean)
Sets the curent error

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SetError(
    Exception ex,
    bool throwWarningsAsErrors
)
Public Sub SetError (
    ex As Exception,
    throwWarningsAsErrors As Boolean
)
Dim instance As MRWrapper
Dim ex As Exception
Dim throwWarningsAsErrors As Boolean

instance.SetError(ex, throwWarningsAsErrors)

Parameters

ex
Exception
Exception as error
throwWarningsAsErrors
Boolean
Throw warnings

See Also

MRWrapper Class
SetError Overload
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper Properties

Visual Basic Usage

CB Com Devkit
MRWrapper Properties

The MRWrapper type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CommandName | The command name for this MacroResult
DialogResult | Any dialog result for this Macro
ElapsedTimeInMS | The elapsed time for this command call in milliseconds
ErrorDetails | The error details
ErrorMessage | The error message
ErrorNumber | The error number, equates to New Value error numbers
IsOk | Is an error present
LastResult | The last error result
ThrowErrors | This macro result errors are thrown
Title | The error title

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.CommandName Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::CommandName Property
The command name for this MacroResult

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string CommandName { get; }
Public ReadOnly Property CommandName As String
    Get
Dim instance As MRWrapper
Dim value As String

value = instance.CommandName

Property Value

String

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.DialogResult Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::DialogResult Property
Any dialog result for this Macro

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public DialogResult DialogResult { get; internal set; }
Public Property DialogResult As DialogResult
    Get
    Friend Set
Dim instance As MRWrapper
Dim value As DialogResult

value = instance.DialogResult

Property Value

DialogResult

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.ElapsedTimeInMS Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::ElapsedTimeInMS Property
The elapsed time for this command call in milliseconds

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ElapsedTimeInMS { get; }
Public ReadOnly Property ElapsedTimeInMS As Integer
    Get
Dim instance As MRWrapper
Dim value As Integer

value = instance.ElapsedTimeInMS

Property Value

Int32

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.ErrorDetails Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::ErrorDetails Property
The error details

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string ErrorDetails { get; }
Public ReadOnly Property ErrorDetails As String
    Get
Dim instance As MRWrapper
Dim value As String

value = instance.ErrorDetails

Property Value

String

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.ErrorMessage Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::ErrorMessage Property
The error message

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get
Dim instance As MRWrapper
Dim value As String

value = instance.ErrorMessage

Property Value

String

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.ErrorNumber Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::ErrorNumber Property
The error number, equates to New Value error numbers

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ErrorNumber { get; }
Public ReadOnly Property ErrorNumber As Integer
    Get
Dim instance As MRWrapper
Dim value As Integer

value = instance.ErrorNumber

Property Value

Int32

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.IsOk Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::IsOk Property
Is an error present

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsOk { get; }
Public ReadOnly Property IsOk As Boolean
    Get
Dim instance As MRWrapper
Dim value As Boolean

value = instance.IsOk

Property Value

Boolean

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.LastResult Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::LastResult Property
The last error result

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public static MRWrapper LastResult { get; internal set; }
Public Shared Property LastResult As MRWrapper
    Get
    Friend Set
Dim value As MRWrapper

value = MRWrapper.LastResult

Property Value

MRWrapper

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.ThrowErrors Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::ThrowErrors Property
This macro result errors are thrown

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowErrors { get; set; }
Public Property ThrowErrors As Boolean
    Get
    Set
Dim instance As MRWrapper
Dim value As Boolean

value = instance.ThrowErrors

instance.ThrowErrors = value

Property Value

Boolean

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper.Title Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::Title Property
The error title

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Title { get; }
Public ReadOnly Property Title As String
    Get
Dim instance As MRWrapper
Dim value As String

value = instance.Title

Property Value

String

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


Decisioneering.CB.CBCOMDevKit.DataSelector Namespace

Visual Basic Usage

CB Com Devkit
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace
DataSelector namespace provides autodetection of block of data

Types

All Types | Classes | Enumerations
Name | Description
DataSelector | DataSelector class provides COM interface for testing of autodetection of block of data.
OptDataOrientation | OptDataOrientation enum is used to define the orientation of the detected block


DataSelector Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
DataSelector Class
DataSelector class provides COM interface for testing of autodetection of block of data.

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class DataSelector
Public Class DataSelector
Dim instance As DataSelector

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DataSelector()()()() | Default constructor
AutoDetect(Range, Boolean) | AutoDetect will start the autodetection process
DataOrientation | Orientation of the detected range
DetectedRange | Acces to detected range
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
HasLeftHeader | HasLeftHeader is true if a detected range has left header
HasTopHeader | HasTopHeader is true if a detected range has top header
NumberOfDataPoints | Return the number of data points in detected range (series with no data are ignored)
NumberOfDataSeries | Return the number of data series in detected range
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.DataSelector..::..DataSelector

See Also

Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector Constructor

Visual Basic Usage

CB Com Devkit
DataSelector Constructor
Default constructor

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public DataSelector()
Public Sub New
Dim instance As New DataSelector()

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector Methods

Visual Basic Usage

CB Com Devkit
DataSelector Methods

The DataSelector type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AutoDetect(Range, Boolean) | AutoDetect will start the autodetection process
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector.AutoDetect Method

Visual Basic Usage

CB Com Devkit
DataSelector..::AutoDetect Method
AutoDetect will start the autodetection process

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void AutoDetect(
    Range initialRange = null,
    bool allowDiscontiguousRanges = false
)
Public Sub AutoDetect (
    Optional initialRange As Range = Nothing,
    Optional allowDiscontiguousRanges As Boolean = false
)
Dim instance As DataSelector
Dim initialRange As Range
Dim allowDiscontiguousRanges As Boolean

instance.AutoDetect(initialRange, allowDiscontiguousRanges)

Parameters

initialRange (Optional)
Range
initial range from which auto detection starts
allowDiscontiguousRanges (Optional)
Boolean
allow discontiguous ranges (a set of ranges) in initialRange

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector Properties

Visual Basic Usage

CB Com Devkit
DataSelector Properties

The DataSelector type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DataOrientation | Orientation of the detected range
DetectedRange | Acces to detected range
HasLeftHeader | HasLeftHeader is true if a detected range has left header
HasTopHeader | HasTopHeader is true if a detected range has top header
NumberOfDataPoints | Return the number of data points in detected range (series with no data are ignored)
NumberOfDataSeries | Return the number of data series in detected range

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector.DataOrientation Property

Visual Basic Usage

CB Com Devkit
DataSelector..::DataOrientation Property
Orientation of the detected range

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptDataOrientation DataOrientation { get; }
Public ReadOnly Property DataOrientation As OptDataOrientation
    Get
Dim instance As DataSelector
Dim value As OptDataOrientation

value = instance.DataOrientation

Property Value

OptDataOrientation

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector.DetectedRange Property

Visual Basic Usage

CB Com Devkit
DataSelector..::DetectedRange Property
Acces to detected range

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range DetectedRange { get; }
Public ReadOnly Property DetectedRange As Range
    Get
Dim instance As DataSelector
Dim value As Range

value = instance.DetectedRange

Property Value

Range

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector.HasLeftHeader Property

Visual Basic Usage

CB Com Devkit
DataSelector..::HasLeftHeader Property
HasLeftHeader is true if a detected range has left header

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HasLeftHeader { get; }
Public ReadOnly Property HasLeftHeader As Boolean
    Get
Dim instance As DataSelector
Dim value As Boolean

value = instance.HasLeftHeader

Property Value

Boolean

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector.HasTopHeader Property

Visual Basic Usage

CB Com Devkit
DataSelector..::HasTopHeader Property
HasTopHeader is true if a detected range has top header

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HasTopHeader { get; }
Public ReadOnly Property HasTopHeader As Boolean
    Get
Dim instance As DataSelector
Dim value As Boolean

value = instance.HasTopHeader

Property Value

Boolean

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector.NumberOfDataPoints Property

Visual Basic Usage

CB Com Devkit
DataSelector..::NumberOfDataPoints Property
Return the number of data points in detected range (series with no data are ignored)

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfDataPoints { get; }
Public ReadOnly Property NumberOfDataPoints As Integer
    Get
Dim instance As DataSelector
Dim value As Integer

value = instance.NumberOfDataPoints

Property Value

Int32

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector.NumberOfDataSeries Property

Visual Basic Usage

CB Com Devkit
DataSelector..::NumberOfDataSeries Property
Return the number of data series in detected range

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfDataSeries { get; }
Public ReadOnly Property NumberOfDataSeries As Integer
    Get
Dim instance As DataSelector
Dim value As Integer

value = instance.NumberOfDataSeries

Property Value

Int32

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


OptDataOrientation Enumeration

Visual Basic Usage

CB Com Devkit
OptDataOrientation Enumeration
OptDataOrientation enum is used to define the orientation of the detected block

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptDataOrientation
Public Enumeration OptDataOrientation
Dim instance As OptDataOrientation

Members

Member | Value | Description
OptDataOrientationUnknown | 0 | Orientation is unknown
OptDataInRows | 1 | Detected data block is oriented in rows
OptDataInColumns | 2 | Detected data block is in columns

See Also

Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


Decisioneering.CB.CBCOMDevKit.Optimization Namespace

Visual Basic Usage

CB Com Devkit
Decisioneering.CB.CBCOMDevKit.Optimization Namespace
OptQuest COM and .NET Development Kit Namespace

Types

All Types | Classes | Interfaces | Enumerations | Delegates
Name | Description
OptRuntime..::..AfterSimulationEventHandler | After simulation event handler.
ResultsWindow..::..BestSolutionChartType | Chart type within the Best Solution view enum
BooleanOption | Optimization Option boolean
ConEnumerator | Constraint var enumerator class
Constraint | Constraint object. Access constraint properties.
DecEnumerator | Decision var enumerator class
Decision | Decision variable wrapper
DecVarValueType | Optimization values types
OptRuntime..::..EfficientFrontierEventHandler | Efficient Frontier Event handler.
ResultsWindow..::..GridType | The Grid type enum
IVarEnumerator | Base var enumerator interface
Objective | Objective class is responsible for handling all objective related operations.
ObjEnumerator | Objective var enumerator class
ObjReqBase | Base class for objectives and requirements
OptConditionType | Condition type
OptConstraintType | Constraint types
OptCounters | The set of Optimization counters.
OptDecisionType | Enumeration of possible decision variable types
OptEFFBoundType | Efficient Frontier testing type
OptEfficientFrontier | Efficient Frontier DevKit access
OptEFFSelectionType | Efficient Frontier testing type
OptEFFTestType | Efficient Frontier testing type
OptRuntime..::..OptEventHandler | Optimization Event handler.
OptimizationEvents | Optimization Events raised during an Optimization execution.
OptimizationState | The run state of the Optimization.
OptRuntime..::..OptItersEventHandler | Optimization Iterations Event handler.
OptMoreLessCondition | More/less condition type.
OptObjectiveType | Objective type
OptOptimizationType | Optimization type enum
OptOptions | COM wrapper for optimization options
OptRunForType | Run for type enum
OptRuntime | An OptRuntime object is used to start, stop and monitor optimizations. After an optimization is complete results may be obtained by calling methods such as OptRuntime.GetBestSolution. Additionally OptRuntime.GetSolutionList may be used to determine the solutions used in the course of the optimization. For Efficient Frontier optimizations, use the OptRuntime.EfficientFrontier property to access the results for specific test points.
OptSetDecVars | Set decision variable cell values type enum
OptSetup | Optimization Setup / Definition Access optimization variables, add, modify and delete variables and options for running optimizations
OptShowChartType | Show chart type enum
OptSolution | Represents a single solution in an Optimization. A solution is a set of values for Decision Variables and their associated result values. Result values may be obtained for: Objectives, Requirements, Constraints.
OptSolutionEnumerator | OptSolution enumerator class. This class is used to enumerate a list of solutions generated by an Optimization.
OptSupportedStatistics | Supported Statistics
OptVar | Base class for Optimization variable objects
OptVarSolutionFilter | The Optimization variable statistics filter. The statistics filter limits the set of solutions that affect the Optimization variable statistics.
OptVarStatistics | Optimization variable statistics. These summarize the statistics for a single optimization variable in the current Optimization. They are based upon the selected statistics filter.
ReqEnumerator | Requirement var enumerator class
Requirement | Requirement class is responsible for handling all requirement related operations.
ResultsWindow | The OptQuest Results Window
ResultsWindow..::..ResultsWindowViewType | Window view enum
RuntimeEfficientFrontier | Optimization runtime information for Efficient Frontier. Efficient Frontier allows users to create a variable list of constraint and requirement RHS (right hand side) values using a list of test points.
SolutionListSort | Possible sort orders for solution lists
SolutionStatus | The status of the solution, including the state of the simulation if run.
SolutionValueType | Type of value for a solution equation variable
TerminationReason | Optimization Termination reasons
TestPointInfo | Optimization Test Point Information for an Efficient frontier. This information summarizes the results for a single test point.
VarEnumerator | Base var enumerator class


BooleanOption Enumeration

Visual Basic Usage

CB Com Devkit
BooleanOption Enumeration
Optimization Option boolean

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum BooleanOption
Public Enumeration BooleanOption
Dim instance As BooleanOption

Members

Member | Value | Description
Default | 0 | Set option to default
True | 1 | Set option to True
False | 2 | Set option to False

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
ConEnumerator Class
Constraint var enumerator class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class ConEnumerator : VarEnumerator
Public Class ConEnumerator
    Inherits VarEnumerator
Dim instance As ConEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdvancedView | Get / Set the current Constraint view preference
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumeration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Delete(Int32) | Delete the object at specified index
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
ValidateView()()()() | Check if all constraints are simple and if the constraint editor can be rendered in simple view mode

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..ConEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConEnumerator Methods

Visual Basic Usage

CB Com Devkit
ConEnumerator Methods

The ConEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Delete(Int32) | Delete the object at specified index
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
ValidateView()()()() | Check if all constraints are simple and if the constraint editor can be rendered in simple view mode

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConEnumerator.Delete Method

Visual Basic Usage

CB Com Devkit
ConEnumerator..::Delete Method
Delete the object at specified index

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Delete(
    int index
)
Public Function Delete (
    index As Integer
) As Boolean
Dim instance As ConEnumerator
Dim index As Integer
Dim returnValue As Boolean

returnValue = instance.Delete(index)

Parameters

index
Int32
index to use

Return Value

Boolean
Was object deleted

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
ConEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As ConEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
Was enumeration successfully reloaded

Implements

IVarEnumerator..::..Reload()()()()

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConEnumerator.ValidateView Method

Visual Basic Usage

CB Com Devkit
ConEnumerator..::ValidateView Method
Check if all constraints are simple and if the constraint editor can be rendered in simple view mode

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ValidateView()
Public Function ValidateView As Boolean
Dim instance As ConEnumerator
Dim returnValue As Boolean

returnValue = instance.ValidateView()

Return Value

Boolean
Whether constraints are simple

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConEnumerator Properties

Visual Basic Usage

CB Com Devkit
ConEnumerator Properties

The ConEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdvancedView | Get / Set the current Constraint view preference
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumeration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConEnumerator.AdvancedView Property

Visual Basic Usage

CB Com Devkit
ConEnumerator..::AdvancedView Property
Get / Set the current Constraint view preference

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool AdvancedView { get; set; }
Public Property AdvancedView As Boolean
    Get
    Set
Dim instance As ConEnumerator
Dim value As Boolean

value = instance.AdvancedView

instance.AdvancedView = value

Property Value

Boolean

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
ConEnumerator..::Current Property
Returns the current variable in the enumeration (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As ConEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
ConEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Constraint this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Constraint
    Get
Dim instance As ConEnumerator
Dim index As Integer
Dim value As Constraint

value = instance(index)

Parameters

index
Int32

Property Value

Constraint

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Constraint Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
Constraint Class
Constraint object. Access constraint properties.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class Constraint : OptVar
Public Class Constraint
    Inherits OptVar
Dim instance As Constraint

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Comment | Var comment (Inherited from OptVar.)
ConstraintType | Is constraint linear
DisplayName | Var display name (Inherited from OptVar.)
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier) (Inherited from OptVar.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equation | Constraint equation
Exclude | Is var excluded (Inherited from OptVar.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter. (Inherited from OptVar.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVar
Decisioneering.CB.CBCOMDevKit.Optimization..::..Constraint

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Constraint Methods

Visual Basic Usage

CB Com Devkit
Constraint Methods

The Constraint type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

Constraint Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Constraint Properties

Visual Basic Usage

CB Com Devkit
Constraint Properties

The Constraint type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Comment | Var comment (Inherited from OptVar.)
ConstraintType | Is constraint linear
DisplayName | Var display name (Inherited from OptVar.)
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier) (Inherited from OptVar.)
Equation | Constraint equation
Exclude | Is var excluded (Inherited from OptVar.)
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter. (Inherited from OptVar.)

See Also

Constraint Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Constraint.ConstraintType Property

Visual Basic Usage

CB Com Devkit
Constraint..::ConstraintType Property
Is constraint linear

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptConstraintType ConstraintType { get; }
Public ReadOnly Property ConstraintType As OptConstraintType
    Get
Dim instance As Constraint
Dim value As OptConstraintType

value = instance.ConstraintType

Property Value

OptConstraintType

See Also

Constraint Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Constraint.Equation Property

Visual Basic Usage

CB Com Devkit
Constraint..::Equation Property
Constraint equation

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Equation { get; set; }
Public Property Equation As String
    Get
    Set
Dim instance As Constraint
Dim value As String

value = instance.Equation

instance.Equation = value

Property Value

String

See Also

Constraint Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DecEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
DecEnumerator Class
Decision var enumerator class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class DecEnumerator : VarEnumerator
Public Class DecEnumerator
    Inherits VarEnumerator
Dim instance As DecEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumeration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..DecEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DecEnumerator Methods

Visual Basic Usage

CB Com Devkit
DecEnumerator Methods

The DecEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

DecEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DecEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
DecEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As DecEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
Was enumeration successfully reloaded

Implements

IVarEnumerator..::..Reload()()()()

See Also

DecEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DecEnumerator Properties

Visual Basic Usage

CB Com Devkit
DecEnumerator Properties

The DecEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumeration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

DecEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DecEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
DecEnumerator..::Current Property
Returns the current variable in the enumeration (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As DecEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

DecEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DecEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
DecEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Decision this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Decision
    Get
Dim instance As DecEnumerator
Dim index As Integer
Dim value As Decision

value = instance(index)

Parameters

index
Int32

Property Value

Decision

See Also

DecEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
Decision Class
Decision variable wrapper

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class Decision : CBVar
Public Class Decision
    Inherits CBVar
Dim instance As Decision

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Decision()()()() | Default Decision variable constructor
Decision(String, String) | Decision variable constructor using cell address
BaseCase | Decision variable base case value (the value in the decision variable cell.)
CustomValues | A set of possible values for this Decision Variable.
DecisionType | Decision variable type
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Frozen | Decision variable frozen state
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
LowerBound | Decision variable lower bound
ObjectiveSensitivity | Obsolete. Sensitivity of the Objective to this Decision Variable. This method is no longer supported in this release,
OptimizationStatistics | Get the statistics for this Decision Variable. Statistics are based upon the current OptRuntime solution filter.
SetCustomValues(Object) | Update custom values array
SetDecisionType(OptDecisionType, Double, Object) | Set to new type
Step | Decision variable step
ToString()()()() | Get variable as string (Overrides CBVarToString()()()().)
UpperBound | Decision variable upper bound

Inheritance Hierarchy

System..::..Object
CBVar
Decisioneering.CB.CBCOMDevKit.Optimization..::..Decision

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision Constructor

Visual Basic Usage

CB Com Devkit
Decision Constructor

Overload List

Name | Description
Decision()()()() | Default Decision variable constructor
Decision(String, String) | Decision variable constructor using cell address

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision Constructor

Visual Basic Usage

CB Com Devkit
Decision Constructor
Default Decision variable constructor

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Decision()
Public Sub New
Dim instance As New Decision()

See Also

Decision Class
Decision Overload
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision Constructor (String, String)

Visual Basic Usage

CB Com Devkit
Decision Constructor (String, String)
Decision variable constructor using cell address

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Decision(
    string aCellAddress,
    string aName
)
Public Sub New (
    aCellAddress As String,
    aName As String
)
Dim aCellAddress As String
Dim aName As String

Dim instance As New Decision(aCellAddress,
    aName)

Parameters

aCellAddress
String
cell address
aName
String
Decision variable name

See Also

Decision Class
Decision Overload
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision Methods

Visual Basic Usage

CB Com Devkit
Decision Methods

The Decision type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SetCustomValues(Object) | Update custom values array
SetDecisionType(OptDecisionType, Double, Object) | Set to new type
ToString()()()() | Get variable as string (Overrides CBVarToString()()()().)

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision.SetCustomValues Method

Visual Basic Usage

CB Com Devkit
Decision..::SetCustomValues Method
Update custom values array

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SetCustomValues(
    Object CustomValues
)
Public Function SetCustomValues (
    CustomValues As Object
) As Boolean
Dim instance As Decision
Dim CustomValues As Object
Dim returnValue As Boolean

returnValue = instance.SetCustomValues(CustomValues)

Parameters

CustomValues
Object
Double array of custom values

Return Value

Boolean
true if successful

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision.SetDecisionType Method

Visual Basic Usage

CB Com Devkit
Decision..::SetDecisionType Method
Set to new type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SetDecisionType(
    OptDecisionType DecisionType,
    [OptionalAttribute] double Step,
    [OptionalAttribute] Object CustomValues
)
Public Function SetDecisionType (
    DecisionType As OptDecisionType,
    <OptionalAttribute> Step As Double,
    <OptionalAttribute> CustomValues As Object
) As Boolean
Dim instance As Decision
Dim DecisionType As OptDecisionType
Dim Step As Double
Dim CustomValues As Object
Dim returnValue As Boolean

returnValue = instance.SetDecisionType(DecisionType,
    Step, CustomValues)

Parameters

DecisionType
OptDecisionType
The type of decision variable
Step (Optional)
Double
the step value
CustomValues (Optional)
Object
any custom values

Return Value

Boolean
true if successful

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision.ToString Method

Visual Basic Usage

CB Com Devkit
Decision..::ToString Method
Get variable as string

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override string ToString()
Public Overrides Function ToString As String
Dim instance As Decision
Dim returnValue As String

returnValue = instance.ToString()

Return Value

String
string description

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision Properties

Visual Basic Usage

CB Com Devkit
Decision Properties

The Decision type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BaseCase | Decision variable base case value (the value in the decision variable cell.)
CustomValues | A set of possible values for this Decision Variable.
DecisionType | Decision variable type
Frozen | Decision variable frozen state
LowerBound | Decision variable lower bound
ObjectiveSensitivity | Obsolete. Sensitivity of the Objective to this Decision Variable. This method is no longer supported in this release,
OptimizationStatistics | Get the statistics for this Decision Variable. Statistics are based upon the current OptRuntime solution filter.
Step | Decision variable step
UpperBound | Decision variable upper bound

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision.BaseCase Property

Visual Basic Usage

CB Com Devkit
Decision..::BaseCase Property
Decision variable base case value (the value in the decision variable cell.)

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double BaseCase { get; set; }
Public Property BaseCase As Double
    Get
    Set
Dim instance As Decision
Dim value As Double

value = instance.BaseCase

instance.BaseCase = value

Property Value

Double

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision.CustomValues Property

Visual Basic Usage

CB Com Devkit
Decision..::CustomValues Property
A set of possible values for this Decision Variable.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double[] CustomValues { get; }
Public ReadOnly Property CustomValues As Double()
    Get
Dim instance As Decision
Dim value As Double()

value = instance.CustomValues

Property Value

array< Double >[]()[][]

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision.DecisionType Property

Visual Basic Usage

CB Com Devkit
Decision..::DecisionType Property
Decision variable type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptDecisionType DecisionType { get; }
Public ReadOnly Property DecisionType As OptDecisionType
    Get
Dim instance As Decision
Dim value As OptDecisionType

value = instance.DecisionType

Property Value

OptDecisionType

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision.Frozen Property

Visual Basic Usage

CB Com Devkit
Decision..::Frozen Property
Decision variable frozen state

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Frozen { get; set; }
Public Property Frozen As Boolean
    Get
    Set
Dim instance As Decision
Dim value As Boolean

value = instance.Frozen

instance.Frozen = value

Property Value

Boolean

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision.LowerBound Property

Visual Basic Usage

CB Com Devkit
Decision..::LowerBound Property
Decision variable lower bound

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double LowerBound { get; set; }
Public Property LowerBound As Double
    Get
    Set
Dim instance As Decision
Dim value As Double

value = instance.LowerBound

instance.LowerBound = value

Property Value

Double

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision.ObjectiveSensitivity Property

Visual Basic Usage

CB Com Devkit
Decision..::ObjectiveSensitivity Property
Sensitivity of the Objective to this Decision Variable. This method is no longer supported in this release,

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
[ObsoleteAttribute("The ObjectiveSensitivity method in not supported.")]
public double ObjectiveSensitivity { get; }
<ObsoleteAttribute("The ObjectiveSensitivity method in not supported.")>
Public ReadOnly Property ObjectiveSensitivity As Double
    Get
Dim instance As Decision
Dim value As Double

value = instance.ObjectiveSensitivity

Property Value

Double

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision.OptimizationStatistics Property

Visual Basic Usage

CB Com Devkit
Decision..::OptimizationStatistics Property
Get the statistics for this Decision Variable. Statistics are based upon the current OptRuntime solution filter.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptVarStatistics OptimizationStatistics { get; }
Public ReadOnly Property OptimizationStatistics As OptVarStatistics
    Get
Dim instance As Decision
Dim value As OptVarStatistics

value = instance.OptimizationStatistics

Return Value

OptVarStatistics
Decision Variable statistics for this Optimization.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision.Step Property

Visual Basic Usage

CB Com Devkit
Decision..::Step Property
Decision variable step

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Step { get; set; }
Public Property Step As Double
    Get
    Set
Dim instance As Decision
Dim value As Double

value = instance.Step

instance.Step = value

Property Value

Double

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision.UpperBound Property

Visual Basic Usage

CB Com Devkit
Decision..::UpperBound Property
Decision variable upper bound

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double UpperBound { get; set; }
Public Property UpperBound As Double
    Get
    Set
Dim instance As Decision
Dim value As Double

value = instance.UpperBound

instance.UpperBound = value

Property Value

Double

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DecVarValueType Enumeration

Visual Basic Usage

CB Com Devkit
DecVarValueType Enumeration
Optimization values types

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum DecVarValueType
Public Enumeration DecVarValueType
Dim instance As DecVarValueType

Members

Member | Value | Description
OriginalValue | 0 | Pre-optimization value
CurrentValue | 1 | Current solution value
BestValue | 2 | Best solution value

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IVarEnumerator Interface

Visual Basic Usage

| Members | See Also
CB Com Devkit
IVarEnumerator Interface
Base var enumerator interface

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public interface IVarEnumerator : IEnumerable,
    IEnumerator
Public Interface IVarEnumerator
    Inherits IEnumerable, IEnumerator
Dim instance As IVarEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of this type.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IVarEnumerator Methods

Visual Basic Usage

CB Com Devkit
IVarEnumerator Methods

The IVarEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

IVarEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IVarEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
IVarEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
bool Reload()
Function Reload As Boolean
Dim instance As IVarEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
Was enumeration successfully reloaded

See Also

IVarEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IVarEnumerator Properties

Visual Basic Usage

CB Com Devkit
IVarEnumerator Properties

The IVarEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of this type.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)

See Also

IVarEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IVarEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
IVarEnumerator..::Count Property
Returns the count of variables of this type.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
int Count { get; }
ReadOnly Property Count As Integer
    Get
Dim instance As IVarEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

See Also

IVarEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
Objective Class
Objective class is responsible for handling all objective related operations.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class Objective : ObjReqBase
Public Class Objective
    Inherits ObjReqBase
Dim instance As Objective

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AbbreviatedName | Objective abbreviated name in a string form (note it doesn't include the forecast)
Comment | Var comment (Inherited from OptVar.)
Condition | Objective condition, one of the values defined in OptConditionType enumeration For objectives, Condition is used only for Probability statistic and it represents the numeric representation of the current objective condition. For example, the objective "Maximize the Probability that Forecast1 is between 100.00 and 200.00" has a Condition equal to OptConditionType.Between.
DisplayName | Var display name (Inherited from OptVar.)
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier) (Inherited from OptVar.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equation | The Objective equation as a read-only value.
Exclude | Is var excluded (Inherited from OptVar.)
Forecast | Get / Set the Objective forecast range. This value is an Excel range that refers to the Forecast used in the objective equation.
FullAbbreviatedName | Objective full abbreviated name in a string form, this includes the forecast
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ObjectiveType | Objective type defined with one of the values defined in OptObjectiveType enumeration.
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter. (Inherited from OptVar.)
Statistic | Access to objective Statistic. This is a statistic from the Forecast value used in the Objective equation.
StatisticValue1 | StatisticValue1 provides access to the first statistic value for the objective. It is used only for Percentile, Probability and Certainty statistics. For Percentile statistic, it represents the numeric percentile value in range [0, 100]. For example, the objective "Maximize the 95% Percentile of Forecast1" has StatisticValue1 equal to 95. For Probability it represents the lower boundary of the probability range. Note that if objective Condition is set to LessThan, the StatisticValue1 will return back value of -Infinity (-1.11E+307) which is effectively the lower probability boundary. For example, the objective "Maximize the Probability that Forecast1 is less than 100.00" has StatisticValue1 equal to 100 (and StatisticValue2 is +Infinity). For Certainty it also represents the lower boundary of the specified probability range. For example, the objective "Maximize the Certainty of Forecast1 being 10.00 to 50.00" has StatisticValue1 equal to 10 and StatisticValue2 equal to 50.
StatisticValue2 | StatisticValue2 provides access to the second statistic value for the objective. It is used only for Probability and Certainty statistics. For Probability it represents the upper boundary of the specified probability range. Note that if objective Condition is set to GreaterThan, the StatisticValue2 will return back value of +Infinity (1.11E+307). For example, the objective "Set Target for Probability that Forecast1 is between 1.00 and 2.00 to 95%" has StatisticValue2 equal to 2. For Certainty it also represents the upper boundary of the specified probability range. For example, the objective "Set Target for Certainty of Forecast1 being 1000.00 to 2000.00 to 91%" has StatisticValue2 of 2000.
TargetValue | Objective Target value is available through the TargetValue property. It is used only when objective type is OptObjectiveType.SetTarget. For example the objective "Set Target for Mode of Forecast1 to 100.00" has TargetValue equal to 100.00.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate the objective, sets the error code if not valid

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVar
Decisioneering.CB.CBCOMDevKit.Optimization..::..ObjReqBase
Decisioneering.CB.CBCOMDevKit.Optimization..::..Objective

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective Methods

Visual Basic Usage

CB Com Devkit
Objective Methods

The Objective type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate the objective, sets the error code if not valid

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective.Validate Method

Visual Basic Usage

CB Com Devkit
Objective..::Validate Method
Validate the objective, sets the error code if not valid

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As Objective
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

Boolean
True if OK, false if requirent is not valid

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective Properties

Visual Basic Usage

CB Com Devkit
Objective Properties

The Objective type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AbbreviatedName | Objective abbreviated name in a string form (note it doesn't include the forecast)
Comment | Var comment (Inherited from OptVar.)
Condition | Objective condition, one of the values defined in OptConditionType enumeration For objectives, Condition is used only for Probability statistic and it represents the numeric representation of the current objective condition. For example, the objective "Maximize the Probability that Forecast1 is between 100.00 and 200.00" has a Condition equal to OptConditionType.Between.
DisplayName | Var display name (Inherited from OptVar.)
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier) (Inherited from OptVar.)
Equation | The Objective equation as a read-only value.
Exclude | Is var excluded (Inherited from OptVar.)
Forecast | Get / Set the Objective forecast range. This value is an Excel range that refers to the Forecast used in the objective equation.
FullAbbreviatedName | Objective full abbreviated name in a string form, this includes the forecast
ObjectiveType | Objective type defined with one of the values defined in OptObjectiveType enumeration.
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter. (Inherited from OptVar.)
Statistic | Access to objective Statistic. This is a statistic from the Forecast value used in the Objective equation.
StatisticValue1 | StatisticValue1 provides access to the first statistic value for the objective. It is used only for Percentile, Probability and Certainty statistics. For Percentile statistic, it represents the numeric percentile value in range [0, 100]. For example, the objective "Maximize the 95% Percentile of Forecast1" has StatisticValue1 equal to 95. For Probability it represents the lower boundary of the probability range. Note that if objective Condition is set to LessThan, the StatisticValue1 will return back value of -Infinity (-1.11E+307) which is effectively the lower probability boundary. For example, the objective "Maximize the Probability that Forecast1 is less than 100.00" has StatisticValue1 equal to 100 (and StatisticValue2 is +Infinity). For Certainty it also represents the lower boundary of the specified probability range. For example, the objective "Maximize the Certainty of Forecast1 being 10.00 to 50.00" has StatisticValue1 equal to 10 and StatisticValue2 equal to 50.
StatisticValue2 | StatisticValue2 provides access to the second statistic value for the objective. It is used only for Probability and Certainty statistics. For Probability it represents the upper boundary of the specified probability range. Note that if objective Condition is set to GreaterThan, the StatisticValue2 will return back value of +Infinity (1.11E+307). For example, the objective "Set Target for Probability that Forecast1 is between 1.00 and 2.00 to 95%" has StatisticValue2 equal to 2. For Certainty it also represents the upper boundary of the specified probability range. For example, the objective "Set Target for Certainty of Forecast1 being 1000.00 to 2000.00 to 91%" has StatisticValue2 of 2000.
TargetValue | Objective Target value is available through the TargetValue property. It is used only when objective type is OptObjectiveType.SetTarget. For example the objective "Set Target for Mode of Forecast1 to 100.00" has TargetValue equal to 100.00.

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective.AbbreviatedName Property

Visual Basic Usage

CB Com Devkit
Objective..::AbbreviatedName Property
Objective abbreviated name in a string form (note it doesn't include the forecast)

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string AbbreviatedName { get; }
Public ReadOnly Property AbbreviatedName As String
    Get
Dim instance As Objective
Dim value As String

value = instance.AbbreviatedName

Property Value

String

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective.Condition Property

Visual Basic Usage

CB Com Devkit
Objective..::Condition Property
Objective condition, one of the values defined in OptConditionType enumeration For objectives, Condition is used only for Probability statistic and it represents the numeric representation of the current objective condition. For example, the objective "Maximize the Probability that Forecast1 is between 100.00 and 200.00" has a Condition equal to OptConditionType.Between.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptConditionType Condition { get; set; }
Public Property Condition As OptConditionType
    Get
    Set
Dim instance As Objective
Dim value As OptConditionType

value = instance.Condition

instance.Condition = value

Property Value

OptConditionType

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective.Equation Property

Visual Basic Usage

CB Com Devkit
Objective..::Equation Property
The Objective equation as a read-only value.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Equation { get; protected set; }
Public Property Equation As String
    Get
    Protected Set
Dim instance As Objective
Dim value As String

value = instance.Equation

instance.Equation = value

Property Value

String

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective.Forecast Property

Visual Basic Usage

CB Com Devkit
Objective..::Forecast Property
Get / Set the Objective forecast range. This value is an Excel range that refers to the Forecast used in the objective equation.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range Forecast { get; set; }
Public Property Forecast As Range
    Get
    Set
Dim instance As Objective
Dim value As Range

value = instance.Forecast

instance.Forecast = value

Property Value

Range

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective.FullAbbreviatedName Property

Visual Basic Usage

CB Com Devkit
Objective..::FullAbbreviatedName Property
Objective full abbreviated name in a string form, this includes the forecast

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string FullAbbreviatedName { get; }
Public ReadOnly Property FullAbbreviatedName As String
    Get
Dim instance As Objective
Dim value As String

value = instance.FullAbbreviatedName

Property Value

String

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective.ObjectiveType Property

Visual Basic Usage

CB Com Devkit
Objective..::ObjectiveType Property
Objective type defined with one of the values defined in OptObjectiveType enumeration.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptObjectiveType ObjectiveType { get; set; }
Public Property ObjectiveType As OptObjectiveType
    Get
    Set
Dim instance As Objective
Dim value As OptObjectiveType

value = instance.ObjectiveType

instance.ObjectiveType = value

Property Value

OptObjectiveType

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective.Statistic Property

Visual Basic Usage

CB Com Devkit
Objective..::Statistic Property
Access to objective Statistic. This is a statistic from the Forecast value used in the Objective equation.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSupportedStatistics Statistic { get; set; }
Public Property Statistic As OptSupportedStatistics
    Get
    Set
Dim instance As Objective
Dim value As OptSupportedStatistics

value = instance.Statistic

instance.Statistic = value

Property Value

OptSupportedStatistics

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective.StatisticValue1 Property

Visual Basic Usage

CB Com Devkit
Objective..::StatisticValue1 Property
StatisticValue1 provides access to the first statistic value for the objective. It is used only for Percentile, Probability and Certainty statistics. For Percentile statistic, it represents the numeric percentile value in range [0, 100]. For example, the objective "Maximize the 95% Percentile of Forecast1" has StatisticValue1 equal to 95. For Probability it represents the lower boundary of the probability range. Note that if objective Condition is set to LessThan, the StatisticValue1 will return back value of -Infinity (-1.11E+307) which is effectively the lower probability boundary. For example, the objective "Maximize the Probability that Forecast1 is less than 100.00" has StatisticValue1 equal to 100 (and StatisticValue2 is +Infinity). For Certainty it also represents the lower boundary of the specified probability range. For example, the objective "Maximize the Certainty of Forecast1 being 10.00 to 50.00" has StatisticValue1 equal to 10 and StatisticValue2 equal to 50.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StatisticValue1 { get; set; }
Public Property StatisticValue1 As Double
    Get
    Set
Dim instance As Objective
Dim value As Double

value = instance.StatisticValue1

instance.StatisticValue1 = value

Property Value

Double

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective.StatisticValue2 Property

Visual Basic Usage

CB Com Devkit
Objective..::StatisticValue2 Property
StatisticValue2 provides access to the second statistic value for the objective. It is used only for Probability and Certainty statistics. For Probability it represents the upper boundary of the specified probability range. Note that if objective Condition is set to GreaterThan, the StatisticValue2 will return back value of +Infinity (1.11E+307). For example, the objective "Set Target for Probability that Forecast1 is between 1.00 and 2.00 to 95%" has StatisticValue2 equal to 2. For Certainty it also represents the upper boundary of the specified probability range. For example, the objective "Set Target for Certainty of Forecast1 being 1000.00 to 2000.00 to 91%" has StatisticValue2 of 2000.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StatisticValue2 { get; set; }
Public Property StatisticValue2 As Double
    Get
    Set
Dim instance As Objective
Dim value As Double

value = instance.StatisticValue2

instance.StatisticValue2 = value

Property Value

Double

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective.TargetValue Property

Visual Basic Usage

CB Com Devkit
Objective..::TargetValue Property
Objective Target value is available through the TargetValue property. It is used only when objective type is OptObjectiveType.SetTarget. For example the objective "Set Target for Mode of Forecast1 to 100.00" has TargetValue equal to 100.00.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TargetValue { get; set; }
Public Property TargetValue As Double
    Get
    Set
Dim instance As Objective
Dim value As Double

value = instance.TargetValue

instance.TargetValue = value

Property Value

Double

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
ObjEnumerator Class
Objective var enumerator class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class ObjEnumerator : VarEnumerator
Public Class ObjEnumerator
    Inherits VarEnumerator
Dim instance As ObjEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumeration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Delete(Int32) | Delete the object at specified index
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..ObjEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjEnumerator Methods

Visual Basic Usage

CB Com Devkit
ObjEnumerator Methods

The ObjEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Delete(Int32) | Delete the object at specified index
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

ObjEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjEnumerator.Delete Method

Visual Basic Usage

CB Com Devkit
ObjEnumerator..::Delete Method
Delete the object at specified index

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Delete(
    int index
)
Public Function Delete (
    index As Integer
) As Boolean
Dim instance As ObjEnumerator
Dim index As Integer
Dim returnValue As Boolean

returnValue = instance.Delete(index)

Parameters

index
Int32
index to use

Return Value

Boolean
Was object deleted

See Also

ObjEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
ObjEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As ObjEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
Was enumeration successfully reloaded

Implements

IVarEnumerator..::..Reload()()()()

See Also

ObjEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjEnumerator Properties

Visual Basic Usage

CB Com Devkit
ObjEnumerator Properties

The ObjEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumeration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

ObjEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
ObjEnumerator..::Current Property
Returns the current variable in the enumeration (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As ObjEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

ObjEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
ObjEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Objective this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Objective
    Get
Dim instance As ObjEnumerator
Dim index As Integer
Dim value As Objective

value = instance(index)

Parameters

index
Int32

Property Value

Objective

See Also

ObjEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjReqBase Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
ObjReqBase Class
Base class for objectives and requirements

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class ObjReqBase : OptVar
Public Class ObjReqBase
    Inherits OptVar
Dim instance As ObjReqBase

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ObjReqBase(IOptVar) | Create a base Objective or Requirement object.
Comment | Var comment (Inherited from OptVar.)
ConvertToStatistic(OptSupportedStatistics, Double, Double, ConditionType, String%) | Converts from OptSupportedStatistics statistic to the Statistic class. Uses specified parameters when creating the Statistic object.
DisplayName | Var display name (Inherited from OptVar.)
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier) (Inherited from OptVar.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exclude | Is var excluded (Inherited from OptVar.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter. (Inherited from OptVar.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVar
Decisioneering.CB.CBCOMDevKit.Optimization..::..ObjReqBase
Decisioneering.CB.CBCOMDevKit.Optimization..::..Objective
Decisioneering.CB.CBCOMDevKit.Optimization..::..Requirement

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjReqBase Constructor

Visual Basic Usage

CB Com Devkit
ObjReqBase Constructor
Create a base Objective or Requirement object.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ObjReqBase(
    IOptVar optvar
)
Public Sub New (
    optvar As IOptVar
)
Dim optvar As IOptVar

Dim instance As New ObjReqBase(optvar)

Parameters

optvar
IOptVar
the interface to an object store optimization variable

See Also

ObjReqBase Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjReqBase Methods

Visual Basic Usage

CB Com Devkit
ObjReqBase Methods

The ObjReqBase type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ConvertToStatistic(OptSupportedStatistics, Double, Double, ConditionType, String%) | Converts from OptSupportedStatistics statistic to the Statistic class. Uses specified parameters when creating the Statistic object.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

ObjReqBase Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjReqBase.ConvertToStatistic Method

Visual Basic Usage

CB Com Devkit
ObjReqBase..::ConvertToStatistic Method
Converts from OptSupportedStatistics statistic to the Statistic class. Uses specified parameters when creating the Statistic object.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public static Statistic ConvertToStatistic(
    OptSupportedStatistics stats,
    double value1,
    double value2,
    ConditionType condition,
    out string advancedStat
)
Public Shared Function ConvertToStatistic (
    stats As OptSupportedStatistics,
    value1 As Double,
    value2 As Double,
    condition As ConditionType,
    <OutAttribute> ByRef advancedStat As String
) As Statistic
Dim stats As OptSupportedStatistics
Dim value1 As Double
Dim value2 As Double
Dim condition As ConditionType
Dim advancedStat As String
Dim returnValue As Statistic

returnValue = ObjReqBase.ConvertToStatistic(stats,
    value1, value2, condition, advancedStat)

Parameters

stats
OptSupportedStatistics
OptSupportedStatistics statistic
value1
Double
First statistic value
value2
Double
Second statistic value
condition
ConditionType
Objectiv/requirement condition
advancedStat
String %
returned AdvancedStat indicator

Return Value

Statistic
Newly created Statistic object

See Also

ObjReqBase Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjReqBase Properties

Visual Basic Usage

CB Com Devkit
ObjReqBase Properties

The ObjReqBase type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Comment | Var comment (Inherited from OptVar.)
DisplayName | Var display name (Inherited from OptVar.)
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier) (Inherited from OptVar.)
Exclude | Is var excluded (Inherited from OptVar.)
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter. (Inherited from OptVar.)

See Also

ObjReqBase Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptConditionType Enumeration

Visual Basic Usage

CB Com Devkit
OptConditionType Enumeration
Condition type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptConditionType
Public Enumeration OptConditionType
Dim instance As OptConditionType

Members

Member | Value | Description
None | 0 | No condition type specified.
LessThan | 1 | Less than condition.
GreaterThan | 2 | Greater than condition.
Between | 3 | Between condition.

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptConstraintType Enumeration

Visual Basic Usage

CB Com Devkit
OptConstraintType Enumeration
Constraint types

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptConstraintType
Public Enumeration OptConstraintType
Dim instance As OptConstraintType

Members

Member | Value | Description
None | 0 | uknown type due to invalid equation
Linear | 1 | linear constraint
NonLinear | 2 | non-linear constraint
Constant | 3 | constant constraint

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptCounters Class
The set of Optimization counters.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptCounters
Public Class OptCounters
Dim instance As OptCounters

Members

All Members | Fields | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AverageSimulationSecs | Average seconds per Simulation
EfficientFrontierCompletedCount | Efficient Frontier Test Points completion count
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FeasibleSolutionCount | Optimization feasible solution count
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfeasibleNonLinearCount | Optimization infeasible due to non-linear constraint solution count
InfeasibleRequirementCount | Optimization infeasible due to requirement solution count
InfeasibleSolutionCount | Optimization infeasible solution count
IterationCount | Optimization iteration count (also number of solutions count)
IterationsSinceNewBestSolution | Iterations since last new best solution, kept if optimization is iteration limited
NewBestSolutionFeasibleCount | Count of new best solutions that are feasible
NewBestSolutionInfeasibleCount | Count of new best solutions that are infeasible
OptimizationStartTime | Start Date/Time of the optimization
SimulationCount | Simulations executed count
StoppedOnCompleteCount | Simulations stopped on completion count
StoppedOnErrorCount | Simulations stopped on error count
StoppedOnInfeasibleConstraintCount | Simulations not run due to infeasible constraints (non-linear) count
StoppedOnObjectiveLowConfidenceCount | Simulations stopped on objective low-confidence count
StoppedOnPrecisionCount | Simulations stopped on precision control count
TimeSinceNewBestSolutionSecs | Time since last new best solution, kept if optimization is time limited
ToString()()()() | Gets the counter statistics as string. (Overrides Object..::..ToString()()()().)
TotalOptimizationSecs | Total Optimization secs
TotalSimulationSecs | Total Simulation seconds

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptCounters

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters Fields

Visual Basic Usage

CB Com Devkit
OptCounters Fields

The OptCounters type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AverageSimulationSecs | Average seconds per Simulation
EfficientFrontierCompletedCount | Efficient Frontier Test Points completion count
FeasibleSolutionCount | Optimization feasible solution count
InfeasibleNonLinearCount | Optimization infeasible due to non-linear constraint solution count
InfeasibleRequirementCount | Optimization infeasible due to requirement solution count
InfeasibleSolutionCount | Optimization infeasible solution count
IterationCount | Optimization iteration count (also number of solutions count)
IterationsSinceNewBestSolution | Iterations since last new best solution, kept if optimization is iteration limited
NewBestSolutionFeasibleCount | Count of new best solutions that are feasible
NewBestSolutionInfeasibleCount | Count of new best solutions that are infeasible
OptimizationStartTime | Start Date/Time of the optimization
SimulationCount | Simulations executed count
StoppedOnCompleteCount | Simulations stopped on completion count
StoppedOnErrorCount | Simulations stopped on error count
StoppedOnInfeasibleConstraintCount | Simulations not run due to infeasible constraints (non-linear) count
StoppedOnObjectiveLowConfidenceCount | Simulations stopped on objective low-confidence count
StoppedOnPrecisionCount | Simulations stopped on precision control count
TimeSinceNewBestSolutionSecs | Time since last new best solution, kept if optimization is time limited
TotalOptimizationSecs | Total Optimization secs
TotalSimulationSecs | Total Simulation seconds

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.AverageSimulationSecs Field

Visual Basic Usage

CB Com Devkit
OptCounters..::AverageSimulationSecs Field
Average seconds per Simulation

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double AverageSimulationSecs
Public AverageSimulationSecs As Double
Dim instance As OptCounters
Dim value As Double

value = instance.AverageSimulationSecs

instance.AverageSimulationSecs = value

Field Value

Double

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.EfficientFrontierCompletedCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::EfficientFrontierCompletedCount Field
Efficient Frontier Test Points completion count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int EfficientFrontierCompletedCount
Public EfficientFrontierCompletedCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.EfficientFrontierCompletedCount

instance.EfficientFrontierCompletedCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.FeasibleSolutionCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::FeasibleSolutionCount Field
Optimization feasible solution count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int FeasibleSolutionCount
Public FeasibleSolutionCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.FeasibleSolutionCount

instance.FeasibleSolutionCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.InfeasibleNonLinearCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::InfeasibleNonLinearCount Field
Optimization infeasible due to non-linear constraint solution count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int InfeasibleNonLinearCount
Public InfeasibleNonLinearCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.InfeasibleNonLinearCount

instance.InfeasibleNonLinearCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.InfeasibleRequirementCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::InfeasibleRequirementCount Field
Optimization infeasible due to requirement solution count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int InfeasibleRequirementCount
Public InfeasibleRequirementCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.InfeasibleRequirementCount

instance.InfeasibleRequirementCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.InfeasibleSolutionCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::InfeasibleSolutionCount Field
Optimization infeasible solution count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int InfeasibleSolutionCount
Public InfeasibleSolutionCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.InfeasibleSolutionCount

instance.InfeasibleSolutionCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.IterationCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::IterationCount Field
Optimization iteration count (also number of solutions count)

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int IterationCount
Public IterationCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.IterationCount

instance.IterationCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.IterationsSinceNewBestSolution Field

Visual Basic Usage

CB Com Devkit
OptCounters..::IterationsSinceNewBestSolution Field
Iterations since last new best solution, kept if optimization is iteration limited

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double IterationsSinceNewBestSolution
Public IterationsSinceNewBestSolution As Double
Dim instance As OptCounters
Dim value As Double

value = instance.IterationsSinceNewBestSolution

instance.IterationsSinceNewBestSolution = value

Field Value

Double

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.NewBestSolutionFeasibleCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::NewBestSolutionFeasibleCount Field
Count of new best solutions that are feasible

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NewBestSolutionFeasibleCount
Public NewBestSolutionFeasibleCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.NewBestSolutionFeasibleCount

instance.NewBestSolutionFeasibleCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.NewBestSolutionInfeasibleCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::NewBestSolutionInfeasibleCount Field
Count of new best solutions that are infeasible

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NewBestSolutionInfeasibleCount
Public NewBestSolutionInfeasibleCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.NewBestSolutionInfeasibleCount

instance.NewBestSolutionInfeasibleCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.OptimizationStartTime Field

Visual Basic Usage

CB Com Devkit
OptCounters..::OptimizationStartTime Field
Start Date/Time of the optimization

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public DateTime OptimizationStartTime
Public OptimizationStartTime As DateTime
Dim instance As OptCounters
Dim value As DateTime

value = instance.OptimizationStartTime

instance.OptimizationStartTime = value

Field Value

DateTime

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.SimulationCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::SimulationCount Field
Simulations executed count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SimulationCount
Public SimulationCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.SimulationCount

instance.SimulationCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.StoppedOnCompleteCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::StoppedOnCompleteCount Field
Simulations stopped on completion count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int StoppedOnCompleteCount
Public StoppedOnCompleteCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.StoppedOnCompleteCount

instance.StoppedOnCompleteCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.StoppedOnErrorCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::StoppedOnErrorCount Field
Simulations stopped on error count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int StoppedOnErrorCount
Public StoppedOnErrorCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.StoppedOnErrorCount

instance.StoppedOnErrorCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.StoppedOnInfeasibleConstraintCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::StoppedOnInfeasibleConstraintCount Field
Simulations not run due to infeasible constraints (non-linear) count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int StoppedOnInfeasibleConstraintCount
Public StoppedOnInfeasibleConstraintCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.StoppedOnInfeasibleConstraintCount

instance.StoppedOnInfeasibleConstraintCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.StoppedOnObjectiveLowConfidenceCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::StoppedOnObjectiveLowConfidenceCount Field
Simulations stopped on objective low-confidence count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int StoppedOnObjectiveLowConfidenceCount
Public StoppedOnObjectiveLowConfidenceCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.StoppedOnObjectiveLowConfidenceCount

instance.StoppedOnObjectiveLowConfidenceCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.StoppedOnPrecisionCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::StoppedOnPrecisionCount Field
Simulations stopped on precision control count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int StoppedOnPrecisionCount
Public StoppedOnPrecisionCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.StoppedOnPrecisionCount

instance.StoppedOnPrecisionCount = value

Field Value

Int32

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.TimeSinceNewBestSolutionSecs Field

Visual Basic Usage

CB Com Devkit
OptCounters..::TimeSinceNewBestSolutionSecs Field
Time since last new best solution, kept if optimization is time limited

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TimeSinceNewBestSolutionSecs
Public TimeSinceNewBestSolutionSecs As Double
Dim instance As OptCounters
Dim value As Double

value = instance.TimeSinceNewBestSolutionSecs

instance.TimeSinceNewBestSolutionSecs = value

Field Value

Double

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.TotalOptimizationSecs Field

Visual Basic Usage

CB Com Devkit
OptCounters..::TotalOptimizationSecs Field
Total Optimization secs

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TotalOptimizationSecs
Public TotalOptimizationSecs As Double
Dim instance As OptCounters
Dim value As Double

value = instance.TotalOptimizationSecs

instance.TotalOptimizationSecs = value

Field Value

Double

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.TotalSimulationSecs Field

Visual Basic Usage

CB Com Devkit
OptCounters..::TotalSimulationSecs Field
Total Simulation seconds

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TotalSimulationSecs
Public TotalSimulationSecs As Double
Dim instance As OptCounters
Dim value As Double

value = instance.TotalSimulationSecs

instance.TotalSimulationSecs = value

Field Value

Double

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters Methods

Visual Basic Usage

CB Com Devkit
OptCounters Methods

The OptCounters type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Gets the counter statistics as string. (Overrides Object..::..ToString()()()().)

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters.ToString Method

Visual Basic Usage

CB Com Devkit
OptCounters..::ToString Method
Gets the counter statistics as string.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override string ToString()
Public Overrides Function ToString As String
Dim instance As OptCounters
Dim returnValue As String

returnValue = instance.ToString()

Return Value

String
Returns the counter statistics as string

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptDecisionType Enumeration

Visual Basic Usage

CB Com Devkit
OptDecisionType Enumeration
Enumeration of possible decision variable types

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptDecisionType
Public Enumeration OptDecisionType
Dim instance As OptDecisionType

Members

Member | Value | Description
Continuous | 0 | a continuous range of values
Discrete | 1 | A range of values with a step
Binary | 2 | a 0 or 1 value
Category | 3 | a set unordered values
Custom | 4 | a list of values

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEFFBoundType Enumeration

Visual Basic Usage

CB Com Devkit
OptEFFBoundType Enumeration
Efficient Frontier testing type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptEFFBoundType
Public Enumeration OptEFFBoundType
Dim instance As OptEFFBoundType

Members

Member | Value | Description
None | 0 | No Bound
Lower | 1 | Lower Bound
Upper | 2 | Upper Bound

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptEfficientFrontier Class
Efficient Frontier DevKit access

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptEfficientFrontier
Public Class OptEfficientFrontier
Dim instance As OptEfficientFrontier

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
OptEfficientFrontier()()()() | Initializes a new instance of the OptEfficientFrontier class
ClearSelection()()()() | Clear the requirement or constraint selected for efficient frontier
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SelectedVar | Get the selected EF var
SelectionType | Get selected variable type
SetCustomValues(Object) | Set custom value array for efficient frontier - clears existing From, To, Step values.
SetTestValues(Double, Double, Double) | Set test values for efficient frontier. Set the lower and upper bounds of to vary the test points and the step increment - clears existing custom list
TestBound | Set the test bound to vary for between requirements
TestConstraint | Get / Set the constraint selected for efficent frontier
TestCustomValues | Get the current custom value list
TestRequirement | Get / Set the requirement selected for efficent frontier
TestSteps | Get the current test point steps value
TestValueFrom | Get the current test from value
TestValueStep | Get the current test from value
TestValuesType | Get the current test type
TestValueTo | Get the current test to value
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptEfficientFrontier

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier Constructor

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier Constructor
Initializes a new instance of the OptEfficientFrontier class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptEfficientFrontier()
Public Sub New
Dim instance As New OptEfficientFrontier()

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier Methods

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier Methods

The OptEfficientFrontier type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ClearSelection()()()() | Clear the requirement or constraint selected for efficient frontier
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SetCustomValues(Object) | Set custom value array for efficient frontier - clears existing From, To, Step values.
SetTestValues(Double, Double, Double) | Set test values for efficient frontier. Set the lower and upper bounds of to vary the test points and the step increment - clears existing custom list
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.ClearSelection Method

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::ClearSelection Method
Clear the requirement or constraint selected for efficient frontier

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ClearSelection()
Public Function ClearSelection As Boolean
Dim instance As OptEfficientFrontier
Dim returnValue As Boolean

returnValue = instance.ClearSelection()

Return Value

Boolean
was this command was successful

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.SetCustomValues Method

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::SetCustomValues Method
Set custom value array for efficient frontier - clears existing From, To, Step values.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SetCustomValues(
    Object CustomValues
)
Public Function SetCustomValues (
    CustomValues As Object
) As Boolean
Dim instance As OptEfficientFrontier
Dim CustomValues As Object
Dim returnValue As Boolean

returnValue = instance.SetCustomValues(CustomValues)

Parameters

CustomValues
Object
Double array of efficient frontier test point values.

Return Value

Boolean
was this command was successful

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.SetTestValues Method

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::SetTestValues Method
Set test values for efficient frontier. Set the lower and upper bounds of to vary the test points and the step increment - clears existing custom list

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SetTestValues(
    double From,
    double To,
    double Step
)
Public Function SetTestValues (
    From As Double,
    To As Double,
    Step As Double
) As Boolean
Dim instance As OptEfficientFrontier
Dim From As Double
Dim To As Double
Dim Step As Double
Dim returnValue As Boolean

returnValue = instance.SetTestValues(From,
    To, Step)

Parameters

From
Double
Efficient frontier lower bound
To
Double
Efficient frontier upper bound
Step
Double
Efficient frontier step increment

Return Value

Boolean
was this command was successful

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier Properties

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier Properties

The OptEfficientFrontier type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SelectedVar | Get the selected EF var
SelectionType | Get selected variable type
TestBound | Set the test bound to vary for between requirements
TestConstraint | Get / Set the constraint selected for efficent frontier
TestCustomValues | Get the current custom value list
TestRequirement | Get / Set the requirement selected for efficent frontier
TestSteps | Get the current test point steps value
TestValueFrom | Get the current test from value
TestValueStep | Get the current test from value
TestValuesType | Get the current test type
TestValueTo | Get the current test to value

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.SelectedVar Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::SelectedVar Property
Get the selected EF var

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public IOptVar SelectedVar { get; }
Public ReadOnly Property SelectedVar As IOptVar
    Get
Dim instance As OptEfficientFrontier
Dim value As IOptVar

value = instance.SelectedVar

Property Value

IOptVar

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.SelectionType Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::SelectionType Property
Get selected variable type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptEFFSelectionType SelectionType { get; }
Public ReadOnly Property SelectionType As OptEFFSelectionType
    Get
Dim instance As OptEfficientFrontier
Dim value As OptEFFSelectionType

value = instance.SelectionType

Property Value

OptEFFSelectionType

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.TestBound Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestBound Property
Set the test bound to vary for between requirements

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptEFFBoundType TestBound { get; set; }
Public Property TestBound As OptEFFBoundType
    Get
    Set
Dim instance As OptEfficientFrontier
Dim value As OptEFFBoundType

value = instance.TestBound

instance.TestBound = value

Property Value

OptEFFBoundType

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.TestConstraint Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestConstraint Property
Get / Set the constraint selected for efficent frontier

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Constraint TestConstraint { get; set; }
Public Property TestConstraint As Constraint
    Get
    Set
Dim instance As OptEfficientFrontier
Dim value As Constraint

value = instance.TestConstraint

instance.TestConstraint = value

Property Value

Constraint

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.TestCustomValues Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestCustomValues Property
Get the current custom value list

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double[] TestCustomValues { get; }
Public ReadOnly Property TestCustomValues As Double()
    Get
Dim instance As OptEfficientFrontier
Dim value As Double()

value = instance.TestCustomValues

Property Value

array< Double >[]()[][]

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.TestRequirement Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestRequirement Property
Get / Set the requirement selected for efficent frontier

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Requirement TestRequirement { get; set; }
Public Property TestRequirement As Requirement
    Get
    Set
Dim instance As OptEfficientFrontier
Dim value As Requirement

value = instance.TestRequirement

instance.TestRequirement = value

Property Value

Requirement

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.TestSteps Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestSteps Property
Get the current test point steps value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int TestSteps { get; }
Public ReadOnly Property TestSteps As Integer
    Get
Dim instance As OptEfficientFrontier
Dim value As Integer

value = instance.TestSteps

Property Value

Int32

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.TestValueFrom Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestValueFrom Property
Get the current test from value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TestValueFrom { get; }
Public ReadOnly Property TestValueFrom As Double
    Get
Dim instance As OptEfficientFrontier
Dim value As Double

value = instance.TestValueFrom

Property Value

Double

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.TestValueStep Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestValueStep Property
Get the current test from value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TestValueStep { get; }
Public ReadOnly Property TestValueStep As Double
    Get
Dim instance As OptEfficientFrontier
Dim value As Double

value = instance.TestValueStep

Property Value

Double

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.TestValuesType Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestValuesType Property
Get the current test type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptEFFTestType TestValuesType { get; }
Public ReadOnly Property TestValuesType As OptEFFTestType
    Get
Dim instance As OptEfficientFrontier
Dim value As OptEFFTestType

value = instance.TestValuesType

Property Value

OptEFFTestType

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier.TestValueTo Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestValueTo Property
Get the current test to value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TestValueTo { get; }
Public ReadOnly Property TestValueTo As Double
    Get
Dim instance As OptEfficientFrontier
Dim value As Double

value = instance.TestValueTo

Property Value

Double

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEFFSelectionType Enumeration

Visual Basic Usage

CB Com Devkit
OptEFFSelectionType Enumeration
Efficient Frontier testing type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptEFFSelectionType
Public Enumeration OptEFFSelectionType
Dim instance As OptEFFSelectionType

Members

Member | Value | Description
None | 0 | No variable selected for EFF
Requirement | 1 | Requirement selected for EFF
Constraint | 2 | Constraint selected for EFF

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEFFTestType Enumeration

Visual Basic Usage

CB Com Devkit
OptEFFTestType Enumeration
Efficient Frontier testing type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptEFFTestType
Public Enumeration OptEFFTestType
Dim instance As OptEFFTestType

Members

Member | Value | Description
TestValues | 0 | Test From - To Values
Custom | 1 | Test custom list of values

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents Interface

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptimizationEvents Interface
Optimization Events raised during an Optimization execution.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public interface OptimizationEvents
Public Interface OptimizationEvents
Dim instance As OptimizationEvents

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AfterIterationEvent(Int32%) | Event raised after an optimization's iteration completes. At this point the simulation is complete, any extract data has been written to the workbook and objective / requirement values have been updated to OptQuest. At this point the solution for this iteration is valid.
AfterOptimizationEvent(Int32%) | Event raised after an optimization run completes.
AfterOptimizationResetEvent()()()() | After an optimization reset event.
AfterSimulationEvent(Int32%, Int32%, Int32%, Double%, Boolean%, Boolean%, Boolean%, Boolean%) | Event raised just after an optimization's simulation (or iteration evaluation) completes. The simulation is complete and any simulation results are valid. Any extracted data values will also have been written to the workbook as part of the simulation processing. Forecast objective and requirement values have not yet been updated to OptQuest. at this point the solution for this iteration is NOT valid.
BeforeIterationEvent()()()() | Event raised prior to an optimization's iteration being run. This event occurs after any Decision Variables are placed into the workbook but before any constraints are evaluated or simulations are run. At this point the solution for this iteration is NOT valid.
BeforeOptimizationEvent()()()() | Event raised just prior to an optimization running.
BeforeOptimizationResetEvent(Int32%) | Before an optimization reset event.
BeforeSimulationEvent()()()() | Event raised just prior to an optimization's simulation (or iteration evaluation) being run. This event occurs after OptQuest evaluates any constraints but before any simulations are run. At this point the solution for this iteration is NOT valid.
EfficientFrontierEvent(Double%) | Event raised after each Efficient Frontier Test Point completes.

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents Methods

Visual Basic Usage

CB Com Devkit
OptimizationEvents Methods

The OptimizationEvents type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AfterIterationEvent(Int32%) | Event raised after an optimization's iteration completes. At this point the simulation is complete, any extract data has been written to the workbook and objective / requirement values have been updated to OptQuest. At this point the solution for this iteration is valid.
AfterOptimizationEvent(Int32%) | Event raised after an optimization run completes.
AfterOptimizationResetEvent()()()() | After an optimization reset event.
AfterSimulationEvent(Int32%, Int32%, Int32%, Double%, Boolean%, Boolean%, Boolean%, Boolean%) | Event raised just after an optimization's simulation (or iteration evaluation) completes. The simulation is complete and any simulation results are valid. Any extracted data values will also have been written to the workbook as part of the simulation processing. Forecast objective and requirement values have not yet been updated to OptQuest. at this point the solution for this iteration is NOT valid.
BeforeIterationEvent()()()() | Event raised prior to an optimization's iteration being run. This event occurs after any Decision Variables are placed into the workbook but before any constraints are evaluated or simulations are run. At this point the solution for this iteration is NOT valid.
BeforeOptimizationEvent()()()() | Event raised just prior to an optimization running.
BeforeOptimizationResetEvent(Int32%) | Before an optimization reset event.
BeforeSimulationEvent()()()() | Event raised just prior to an optimization's simulation (or iteration evaluation) being run. This event occurs after OptQuest evaluates any constraints but before any simulations are run. At this point the solution for this iteration is NOT valid.
EfficientFrontierEvent(Double%) | Event raised after each Efficient Frontier Test Point completes.

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents.AfterIterationEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::AfterIterationEvent Method
Event raised after an optimization's iteration completes. At this point the simulation is complete, any extract data has been written to the workbook and objective / requirement values have been updated to OptQuest. At this point the solution for this iteration is valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
void AfterIterationEvent(
    ref int IterationsCompleted
)
Sub AfterIterationEvent (
    ByRef IterationsCompleted As Integer
)
Dim instance As OptimizationEvents
Dim IterationsCompleted As Integer

instance.AfterIterationEvent(IterationsCompleted)

Parameters

IterationsCompleted
Int32 %
The total iterations (or simulations) completed.

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents.AfterOptimizationEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::AfterOptimizationEvent Method
Event raised after an optimization run completes.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
void AfterOptimizationEvent(
    ref int IterationsCompleted
)
Sub AfterOptimizationEvent (
    ByRef IterationsCompleted As Integer
)
Dim instance As OptimizationEvents
Dim IterationsCompleted As Integer

instance.AfterOptimizationEvent(IterationsCompleted)

Parameters

IterationsCompleted
Int32 %
The total iterations (or simulations) completed.

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents.AfterOptimizationResetEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::AfterOptimizationResetEvent Method
After an optimization reset event.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
void AfterOptimizationResetEvent()
Sub AfterOptimizationResetEvent
Dim instance As OptimizationEvents

instance.AfterOptimizationResetEvent()

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents.AfterSimulationEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::AfterSimulationEvent Method
Event raised just after an optimization's simulation (or iteration evaluation) completes. The simulation is complete and any simulation results are valid. Any extracted data values will also have been written to the workbook as part of the simulation processing. Forecast objective and requirement values have not yet been updated to OptQuest. at this point the solution for this iteration is NOT valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
void AfterSimulationEvent(
    ref int IterationsCompleted,
    ref int Trials,
    ref int MaxTrials,
    ref double Progress,
    ref bool WasAborted,
    ref bool WasStopOnError,
    ref bool WasStoppedOnPrecision,
    ref bool HasNewBestSolution
)
Sub AfterSimulationEvent (
    ByRef IterationsCompleted As Integer,
    ByRef Trials As Integer,
    ByRef MaxTrials As Integer,
    ByRef Progress As Double,
    ByRef WasAborted As Boolean,
    ByRef WasStopOnError As Boolean,
    ByRef WasStoppedOnPrecision As Boolean,
    ByRef HasNewBestSolution As Boolean
)
Dim instance As OptimizationEvents
Dim IterationsCompleted As Integer
Dim Trials As Integer
Dim MaxTrials As Integer
Dim Progress As Double
Dim WasAborted As Boolean
Dim WasStopOnError As Boolean
Dim WasStoppedOnPrecision As Boolean
Dim HasNewBestSolution As Boolean

instance.AfterSimulationEvent(IterationsCompleted,
    Trials, MaxTrials, Progress, WasAborted,
    WasStopOnError, WasStoppedOnPrecision,
    HasNewBestSolution)

Parameters

IterationsCompleted
Int32 %
Number of iterations (or simulations) completed
Trials
Int32 %
Number of trials completed for this simulation
MaxTrials
Int32 %
Total trials per simulation
Progress
Double %
Progress as a percent, from 0 to 1.0
WasAborted
Boolean %
True if the simulation was aborted
WasStopOnError
Boolean %
True if the simulation stopped due to an error
WasStoppedOnPrecision
Boolean %
True if the simulation was stopped when precision control criteria was met.
HasNewBestSolution
Boolean %
For optimizations, true indicates this is new best solution.

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents.BeforeIterationEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::BeforeIterationEvent Method
Event raised prior to an optimization's iteration being run. This event occurs after any Decision Variables are placed into the workbook but before any constraints are evaluated or simulations are run. At this point the solution for this iteration is NOT valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
void BeforeIterationEvent()
Sub BeforeIterationEvent
Dim instance As OptimizationEvents

instance.BeforeIterationEvent()

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents.BeforeOptimizationEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::BeforeOptimizationEvent Method
Event raised just prior to an optimization running.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
void BeforeOptimizationEvent()
Sub BeforeOptimizationEvent
Dim instance As OptimizationEvents

instance.BeforeOptimizationEvent()

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents.BeforeOptimizationResetEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::BeforeOptimizationResetEvent Method
Before an optimization reset event.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
void BeforeOptimizationResetEvent(
    ref int IterationsCompleted
)
Sub BeforeOptimizationResetEvent (
    ByRef IterationsCompleted As Integer
)
Dim instance As OptimizationEvents
Dim IterationsCompleted As Integer

instance.BeforeOptimizationResetEvent(IterationsCompleted)

Parameters

IterationsCompleted
Int32 %
Total iterations completed.

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents.BeforeSimulationEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::BeforeSimulationEvent Method
Event raised just prior to an optimization's simulation (or iteration evaluation) being run. This event occurs after OptQuest evaluates any constraints but before any simulations are run. At this point the solution for this iteration is NOT valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
void BeforeSimulationEvent()
Sub BeforeSimulationEvent
Dim instance As OptimizationEvents

instance.BeforeSimulationEvent()

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents.EfficientFrontierEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::EfficientFrontierEvent Method
Event raised after each Efficient Frontier Test Point completes.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
void EfficientFrontierEvent(
    ref double TestValue
)
Sub EfficientFrontierEvent (
    ByRef TestValue As Double
)
Dim instance As OptimizationEvents
Dim TestValue As Double

instance.EfficientFrontierEvent(TestValue)

Parameters

TestValue
Double %
The value for the completed test point.

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationState Enumeration

Visual Basic Usage

CB Com Devkit
OptimizationState Enumeration
The run state of the Optimization.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptimizationState
Public Enumeration OptimizationState
Dim instance As OptimizationState

Members

Member | Value | Description
NotRunning | 0 | The Optimization is has bot been run or has been reset.
Running | 1 | The Optimization is running.
Stopped | 2 | The Optimization is stopped.

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptMoreLessCondition Enumeration

Visual Basic Usage

CB Com Devkit
OptMoreLessCondition Enumeration
More/less condition type.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptMoreLessCondition
Public Enumeration OptMoreLessCondition
Dim instance As OptMoreLessCondition

Members

Member | Value | Description
None | 0 | More/less condition type not specified.
OrMore | 1 | 'or more' condition type specified.
OrLess | 2 | 'or less' condition type specified.

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptObjectiveType Enumeration

Visual Basic Usage

CB Com Devkit
OptObjectiveType Enumeration
Objective type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptObjectiveType
Public Enumeration OptObjectiveType
Dim instance As OptObjectiveType

Members

Member | Value | Description
None | 0 | No objective type specified.
Maximize | 1 | Maximize objective type.
Minimize | 2 | Minimize objective type.
SetTarget | 3 | SetTarget objective type.

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptimizationType Enumeration

Visual Basic Usage

CB Com Devkit
OptOptimizationType Enumeration
Optimization type enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptOptimizationType
Public Enumeration OptOptimizationType
Dim instance As OptOptimizationType

Members

Member | Value | Description
Stochastic | 0 | Run stochastic optimization
Deterministic | 1 | Run deterministic optimization

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptOptions Class
COM wrapper for optimization options

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptOptions
Public Class OptOptions
Dim instance As OptOptions

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
OptOptions()()()() | Initializes a new instance of the OptOptions class
AutoStop | Get / Set whether to automatically stop after x non-improving solutions
AutoStopSolutions | Get / Set the number of non-imporoving solutions to stop after
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
LowConfidenceTesting | Perform low-confidence testing on the objective value while a simulation is running. If the Objective value cannot improve a previous best solution, the simulation is stopped.
OptType | Set / Get OptOptimizationType value
RunFor | Set / Get RunFor option
RunForMinutes | Set / Get RunForMinutes value
RunForSimulations | Set / Get RunForSimulations value
SetDecVars | Set / Get whether to update to best solutions values or leave original values
ShowChart | Set / Get Show charts type option
SolutionDatabaseSizeMax | The maximum solution database size. This is the maximum number of solutions (1 per simulation) that can be run for an Optimization. Limits the maximum number of optimiztion iterations that can be run. The default is 100,000.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
UpdateOnlyNewBest | Set / Get whether to update only new best solutions

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptOptions

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions Constructor

Visual Basic Usage

CB Com Devkit
OptOptions Constructor
Initializes a new instance of the OptOptions class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptOptions()
Public Sub New
Dim instance As New OptOptions()

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions Methods

Visual Basic Usage

CB Com Devkit
OptOptions Methods

The OptOptions type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions Properties

Visual Basic Usage

CB Com Devkit
OptOptions Properties

The OptOptions type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AutoStop | Get / Set whether to automatically stop after x non-improving solutions
AutoStopSolutions | Get / Set the number of non-imporoving solutions to stop after
LowConfidenceTesting | Perform low-confidence testing on the objective value while a simulation is running. If the Objective value cannot improve a previous best solution, the simulation is stopped.
OptType | Set / Get OptOptimizationType value
RunFor | Set / Get RunFor option
RunForMinutes | Set / Get RunForMinutes value
RunForSimulations | Set / Get RunForSimulations value
SetDecVars | Set / Get whether to update to best solutions values or leave original values
ShowChart | Set / Get Show charts type option
SolutionDatabaseSizeMax | The maximum solution database size. This is the maximum number of solutions (1 per simulation) that can be run for an Optimization. Limits the maximum number of optimiztion iterations that can be run. The default is 100,000.
UpdateOnlyNewBest | Set / Get whether to update only new best solutions

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions.AutoStop Property

Visual Basic Usage

CB Com Devkit
OptOptions..::AutoStop Property
Get / Set whether to automatically stop after x non-improving solutions

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool AutoStop { get; set; }
Public Property AutoStop As Boolean
    Get
    Set
Dim instance As OptOptions
Dim value As Boolean

value = instance.AutoStop

instance.AutoStop = value

Property Value

Boolean

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions.AutoStopSolutions Property

Visual Basic Usage

CB Com Devkit
OptOptions..::AutoStopSolutions Property
Get / Set the number of non-imporoving solutions to stop after

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int AutoStopSolutions { get; set; }
Public Property AutoStopSolutions As Integer
    Get
    Set
Dim instance As OptOptions
Dim value As Integer

value = instance.AutoStopSolutions

instance.AutoStopSolutions = value

Property Value

Int32

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions.LowConfidenceTesting Property

Visual Basic Usage

CB Com Devkit
OptOptions..::LowConfidenceTesting Property
Perform low-confidence testing on the objective value while a simulation is running. If the Objective value cannot improve a previous best solution, the simulation is stopped.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool LowConfidenceTesting { get; set; }
Public Property LowConfidenceTesting As Boolean
    Get
    Set
Dim instance As OptOptions
Dim value As Boolean

value = instance.LowConfidenceTesting

instance.LowConfidenceTesting = value

Property Value

Boolean

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions.OptType Property

Visual Basic Usage

CB Com Devkit
OptOptions..::OptType Property
Set / Get OptOptimizationType value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptOptimizationType OptType { get; set; }
Public Property OptType As OptOptimizationType
    Get
    Set
Dim instance As OptOptions
Dim value As OptOptimizationType

value = instance.OptType

instance.OptType = value

Property Value

OptOptimizationType

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions.RunFor Property

Visual Basic Usage

CB Com Devkit
OptOptions..::RunFor Property
Set / Get RunFor option

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptRunForType RunFor { get; set; }
Public Property RunFor As OptRunForType
    Get
    Set
Dim instance As OptOptions
Dim value As OptRunForType

value = instance.RunFor

instance.RunFor = value

Property Value

OptRunForType

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions.RunForMinutes Property

Visual Basic Usage

CB Com Devkit
OptOptions..::RunForMinutes Property
Set / Get RunForMinutes value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int RunForMinutes { get; set; }
Public Property RunForMinutes As Integer
    Get
    Set
Dim instance As OptOptions
Dim value As Integer

value = instance.RunForMinutes

instance.RunForMinutes = value

Property Value

Int32

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions.RunForSimulations Property

Visual Basic Usage

CB Com Devkit
OptOptions..::RunForSimulations Property
Set / Get RunForSimulations value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int RunForSimulations { get; set; }
Public Property RunForSimulations As Integer
    Get
    Set
Dim instance As OptOptions
Dim value As Integer

value = instance.RunForSimulations

instance.RunForSimulations = value

Property Value

Int32

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions.SetDecVars Property

Visual Basic Usage

CB Com Devkit
OptOptions..::SetDecVars Property
Set / Get whether to update to best solutions values or leave original values

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSetDecVars SetDecVars { get; set; }
Public Property SetDecVars As OptSetDecVars
    Get
    Set
Dim instance As OptOptions
Dim value As OptSetDecVars

value = instance.SetDecVars

instance.SetDecVars = value

Property Value

OptSetDecVars

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions.ShowChart Property

Visual Basic Usage

CB Com Devkit
OptOptions..::ShowChart Property
Set / Get Show charts type option

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptShowChartType ShowChart { get; set; }
Public Property ShowChart As OptShowChartType
    Get
    Set
Dim instance As OptOptions
Dim value As OptShowChartType

value = instance.ShowChart

instance.ShowChart = value

Property Value

OptShowChartType

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions.SolutionDatabaseSizeMax Property

Visual Basic Usage

CB Com Devkit
OptOptions..::SolutionDatabaseSizeMax Property
The maximum solution database size. This is the maximum number of solutions (1 per simulation) that can be run for an Optimization. Limits the maximum number of optimiztion iterations that can be run. The default is 100,000.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SolutionDatabaseSizeMax { get; set; }
Public Property SolutionDatabaseSizeMax As Integer
    Get
    Set
Dim instance As OptOptions
Dim value As Integer

value = instance.SolutionDatabaseSizeMax

instance.SolutionDatabaseSizeMax = value

Property Value

Int32

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions.UpdateOnlyNewBest Property

Visual Basic Usage

CB Com Devkit
OptOptions..::UpdateOnlyNewBest Property
Set / Get whether to update only new best solutions

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool UpdateOnlyNewBest { get; set; }
Public Property UpdateOnlyNewBest As Boolean
    Get
    Set
Dim instance As OptOptions
Dim value As Boolean

value = instance.UpdateOnlyNewBest

instance.UpdateOnlyNewBest = value

Property Value

Boolean

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRunForType Enumeration

Visual Basic Usage

CB Com Devkit
OptRunForType Enumeration
Run for type enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptRunForType
Public Enumeration OptRunForType
Dim instance As OptRunForType

Members

Member | Value | Description
Minutes | 0 | Run for minutes
Simulations | 1 | Run for simulations

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptRuntime Class
An OptRuntime object is used to start, stop and monitor optimizations. After an optimization is complete results may be obtained by calling methods such as OptRuntime.GetBestSolution. Additionally OptRuntime.GetSolutionList may be used to determine the solutions used in the course of the optimization.
For Efficient Frontier optimizations, use the OptRuntime.EfficientFrontier property to access the results for specific test points.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptRuntime : IDisposable
Public Class OptRuntime
    Implements IDisposable
Dim instance As OptRuntime

Members

All Members | Constructors | Properties | Methods | Events
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
OptRuntime()()()() | Create an Optimization runtime object.
AfterIterationEvent | Event raised after an optimization's iteration completes. At this point the simulation is complete, any extract data has been written to the workbook and objective / requirement values have been updated to OptQuest. At this point the solution for this iteration is valid.
AfterOptimizationEvent | Event raised just after an optimization completes.
AfterOptimizationResetEvent | Event raised just after an Optimization Reset completes.
AfterSimulationEvent | Event raised just after an optimization's simulation (or iteration evaluation) completes. The simulation is complete and any simulation results are valid. Any extracted data values will also have been written to the workbook as part of the simulation processing. Forecast objective and requirement values have not yet been updated to OptQuest. at this point the solution for this iteration is NOT valid.
BeforeIterationEvent | Event raised prior to an optimization's iteration being run. This event occurs after any Decision Variables are placed into the workbook but before any constraints are evaluated or simulations are run. At this point the solution for this iteration is NOT valid.
BeforeOptimizationEvent | Event raised just prior to an optimization running.
BeforeOptimizationResetEvent | Event raised just prior to an optimization running.
BeforeSimulationEvent | Before Simulation Event. This event occurs after OptQuest evaluates any constraints but before any simulations are run. At this point the solution for this iteration is NOT valid.
BestSolution | The best solution as determind by the optimization.
ClearSolutionFilter()()()() | Clear the Optimization solution filter filter. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity.
Dispose()()()() | Dispose this object
EfficientFrontier | Return optimization runtime Efficient Frontier information.
EfficientFrontierEvent | Event for Efficient Frontier. This event is generated when each Efficient Frontier Test Value evaluation completes.
ElapsedSeconds | The elapsed seconds for the current optimization run. This is seconds of run time and not wall clock.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EventHandled()()()() | Call to indicate the current event has been handled. This allows event handlers to access DecVar data, modify Excel values that affect Constraints and to update Final Values in Objectives and Forecasts.
EventsAreDisabled | Are events from this OptRuntime object disabled. Allows the user to temporarialy turn off firing of events. Not persisted after Crystal Ball is closed. The default is false.
GetCurrentSolutionList()()()() | Get the current solutions list. This list is based upon the current solutions filter.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetSolutionFilter()()()() | Get the Optimization solution filter. Null if none configured. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity.
GetSolutionList(SolutionListSort, Single, Boolean, Boolean, Boolean) | Get a list of Optimization solutions using a filter and a sort.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IterationCount | The number of Optimization iterations that have been run. This number may be greater than the simulation count if the optimization contains non-linear constraints.
LastErrorNumber | The last error number returned by a Devkit method call. This is the NewValue error number from the Macro result. This returns the last Error Number from running any Devkit method. Note: calling this does not update any Macro Result information.
LastResult | The last macro result from a CBCOMDevKit method
OptCounters | Optimization state counters.
OptimizerMode | OptimizerMode - determine if CB is in optimizer mode, in other words if optimization has been or is being executed.
OptState | The current state of the Optimization.
OptTerminationReason | Optimization termination reason. This returns the last Termination Reason. Note: Calling this does not update any Macro Result information.
Reset()()()() | Resets the optimization. Memory for all solutions the best solution simulation results are cleared.
ResultsWindow | Returns the OptQuest Results Window.
Run()()()() | Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options.
Run(Int32, BooleanOption, BooleanOption, BooleanOption, BooleanOption) | Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options. Note that options set with the provided arguments are only in effect for the duration of the Optimization and do not affect the stored user preferences. Validation errors: The ShowWizardOnError property determines if the OptQuest Wizard will be shown if pre-run validation errors occur, allowing the user a chance to fix the error. The wizard will not be shown
SetEFBestSolutionFilter(Boolean) | Set the Efficient Frontier show best test point solutions filter. Converts this to a list of EF best solutions, one for each test point.
SetSolutionFilter(Boolean, Single, Boolean, Boolean, Boolean) | Set the Optimization solution list filter. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity calculations. This list can be retrieved using GetCurrentSolutionList(). Statistics are kept for each variable based upon the the set of solution values. Statistics values are maintained for: Objectives, Requirements, Constraints and Decision variables. If no filter is set the Optimization variable statistics and sensitivity are be updated for all solutions.
ShowDownshiftDialog | The ShowDownshiftDialog property indicates whether to show the Extreme Speed downshift dialog if the model cannot run in Extreme Speed mode. If a model cannot run in Extreme Speed, this property determines whether a dialog will be displayed giving the user the option to "downshift" to normal speed mode. Note that this property only has effect if CB.AutoDownshift has been set to true. If CB.AutoDownshift is set to false, an error Macro result will always be returned if the model cannot run in Extreme Speed. The default for this property is false.
ShowWizardOnError | Display the OptQuest Wizard on validation error when run optimization is executed. The default is false.
Stop()()()() | Stops the optimization.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
UpdateDecVarValues(DecVarValueType) | Update the way decision variable values are set to the workbook after optimization.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptRuntime

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime Constructor

Visual Basic Usage

CB Com Devkit
OptRuntime Constructor
Create an Optimization runtime object.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptRuntime()
Public Sub New
Dim instance As New OptRuntime()

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime Methods

Visual Basic Usage

CB Com Devkit
OptRuntime Methods

The OptRuntime type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ClearSolutionFilter()()()() | Clear the Optimization solution filter filter. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity.
Dispose()()()() | Dispose this object
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EventHandled()()()() | Call to indicate the current event has been handled. This allows event handlers to access DecVar data, modify Excel values that affect Constraints and to update Final Values in Objectives and Forecasts.
GetCurrentSolutionList()()()() | Get the current solutions list. This list is based upon the current solutions filter.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetSolutionFilter()()()() | Get the Optimization solution filter. Null if none configured. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity.
GetSolutionList(SolutionListSort, Single, Boolean, Boolean, Boolean) | Get a list of Optimization solutions using a filter and a sort.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Reset()()()() | Resets the optimization. Memory for all solutions the best solution simulation results are cleared.
Run()()()() | Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options.
Run(Int32, BooleanOption, BooleanOption, BooleanOption, BooleanOption) | Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options. Note that options set with the provided arguments are only in effect for the duration of the Optimization and do not affect the stored user preferences. Validation errors: The ShowWizardOnError property determines if the OptQuest Wizard will be shown if pre-run validation errors occur, allowing the user a chance to fix the error. The wizard will not be shown
SetEFBestSolutionFilter(Boolean) | Set the Efficient Frontier show best test point solutions filter. Converts this to a list of EF best solutions, one for each test point.
SetSolutionFilter(Boolean, Single, Boolean, Boolean, Boolean) | Set the Optimization solution list filter. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity calculations. This list can be retrieved using GetCurrentSolutionList(). Statistics are kept for each variable based upon the the set of solution values. Statistics values are maintained for: Objectives, Requirements, Constraints and Decision variables. If no filter is set the Optimization variable statistics and sensitivity are be updated for all solutions.
Stop()()()() | Stops the optimization.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
UpdateDecVarValues(DecVarValueType) | Update the way decision variable values are set to the workbook after optimization.

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.ClearSolutionFilter Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::ClearSolutionFilter Method
Clear the Optimization solution filter filter. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ClearSolutionFilter()
Public Sub ClearSolutionFilter
Dim instance As OptRuntime

instance.ClearSolutionFilter()

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.Dispose Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::Dispose Method
Dispose this object

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Dispose()
Public Sub Dispose
Dim instance As OptRuntime

instance.Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.EventHandled Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::EventHandled Method
Call to indicate the current event has been handled. This allows event handlers to access DecVar data, modify Excel values that affect Constraints and to update Final Values in Objectives and Forecasts.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void EventHandled()
Public Sub EventHandled
Dim instance As OptRuntime

instance.EventHandled()

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.GetCurrentSolutionList Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::GetCurrentSolutionList Method
Get the current solutions list. This list is based upon the current solutions filter.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSolutionEnumerator GetCurrentSolutionList()
Public Function GetCurrentSolutionList As OptSolutionEnumerator
Dim instance As OptRuntime
Dim returnValue As OptSolutionEnumerator

returnValue = instance.GetCurrentSolutionList()

Return Value

OptSolutionEnumerator
The enumerator for the current solution list

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.GetSolutionFilter Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::GetSolutionFilter Method
Get the Optimization solution filter. Null if none configured. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptVarSolutionFilter GetSolutionFilter()
Public Function GetSolutionFilter As OptVarSolutionFilter
Dim instance As OptRuntime
Dim returnValue As OptVarSolutionFilter

returnValue = instance.GetSolutionFilter()

Return Value

OptVarSolutionFilter
The active optimization variable statistics filter.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data
CBExceptionIDNoSolutionFilterAvailable | No solution filter has been configured

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.GetSolutionList Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::GetSolutionList Method
Get a list of Optimization solutions using a filter and a sort.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSolutionEnumerator GetSolutionList(
    SolutionListSort sort,
    float countLimit,
    bool includeFeasible,
    bool includeInFeasible,
    bool includeLowConfidence
)
Public Function GetSolutionList (
    sort As SolutionListSort,
    countLimit As Single,
    includeFeasible As Boolean,
    includeInFeasible As Boolean,
    includeLowConfidence As Boolean
) As OptSolutionEnumerator
Dim instance As OptRuntime
Dim sort As SolutionListSort
Dim countLimit As Single
Dim includeFeasible As Boolean
Dim includeInFeasible As Boolean
Dim includeLowConfidence As Boolean
Dim returnValue As OptSolutionEnumerator

returnValue = instance.GetSolutionList(sort,
    countLimit, includeFeasible, includeInFeasible,
    includeLowConfidence)

Parameters

sort
SolutionListSort
The solution list sort order
countLimit
Single
Limit to count solutions, values: 0.0 all, greater than 0.0 and less than 1.0 percentage, greater than 1.0 Count
includeFeasible
Boolean
Include feasible solutions
includeInFeasible
Boolean
Include infeasible solutions
includeLowConfidence
Boolean
Include low-confidence solutions

Return Value

OptSolutionEnumerator
A list of solution objects as an enumerator

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptSolution


OptRuntime.Reset Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::Reset Method
Resets the optimization. Memory for all solutions the best solution simulation results are cleared.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As OptRuntime

instance.Reset()

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.Run Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::Run Method

Overload List

Name | Description
Run()()()() | Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options.
Run(Int32, BooleanOption, BooleanOption, BooleanOption, BooleanOption) | Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options. Note that options set with the provided arguments are only in effect for the duration of the Optimization and do not affect the stored user preferences. Validation errors: The ShowWizardOnError property determines if the OptQuest Wizard will be shown if pre-run validation errors occur, allowing the user a chance to fix the error. The wizard will not be shown

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.Run Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::Run Method
Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TerminationReason Run()
Public Function Run As TerminationReason
Dim instance As OptRuntime
Dim returnValue As TerminationReason

returnValue = instance.Run()

Return Value

TerminationReason
The reason for optimization termination.

See Also

OptRuntime Class
Run Overload
Decisioneering.CB.CBCOMDevKit.Optimization Namespace
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptOptions


OptRuntime.Run Method (Int32, BooleanOption, BooleanOption, BooleanOption, BooleanOption)

Visual Basic Usage

CB Com Devkit
OptRuntime..::Run Method (Int32, BooleanOption, BooleanOption, BooleanOption, BooleanOption)
Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options.
Note that options set with the provided arguments are only in effect for the duration of the Optimization and do not affect the stored user preferences. Validation errors: The ShowWizardOnError property determines if the OptQuest Wizard will be shown if pre-run validation errors occur, allowing the user a chance to fix the error. The wizard will not be shown

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TerminationReason Run(
    [OptionalAttribute] int iterations,
    [OptionalAttribute] BooleanOption hideForecasts,
    [OptionalAttribute] BooleanOption minimizeHost,
    [OptionalAttribute] BooleanOption showControlPanel,
    [OptionalAttribute] BooleanOption showDownshiftDialog
)
Public Function Run (
    <OptionalAttribute> iterations As Integer,
    <OptionalAttribute> hideForecasts As BooleanOption,
    <OptionalAttribute> minimizeHost As BooleanOption,
    <OptionalAttribute> showControlPanel As BooleanOption,
    <OptionalAttribute> showDownshiftDialog As BooleanOption
) As TerminationReason
Dim instance As OptRuntime
Dim iterations As Integer
Dim hideForecasts As BooleanOption
Dim minimizeHost As BooleanOption
Dim showControlPanel As BooleanOption
Dim showDownshiftDialog As BooleanOption
Dim returnValue As TerminationReason

returnValue = instance.Run(iterations,
    hideForecasts, minimizeHost, showControlPanel,
    showDownshiftDialog)

Parameters

iterations (Optional)
Int32
The number of iterations (simulations if not deterministic) that will be run, zero will invoke the default. The default is to use the current OptSetup.Options.RunFor configuration. Note: When continuing an Optimization, this value indicates the total number of iterations to run, including those already executed. Therefore this value must be greater than the number of iterations run to this point.
hideForecasts (Optional)
BooleanOption
Hide all windows while running, overrides any other forecast runtime options, the default is to show forecast windows per Optimization options.
minimizeHost (Optional)
BooleanOption
Minimize Excel while running, the default is to not minimize Excel.
showControlPanel (Optional)
BooleanOption
Show the CB control panel, the default is to show the CB control panel.
showDownshiftDialog (Optional)
BooleanOption
Show the Extreme Speed downshift dialog, indicates whether to show the Extreme Speed downshift dialog if the model cannot run in Extreme Speed mode. The default is to use the setting for the OptRuntime.ShowDownshiftDialog property.

Return Value

TerminationReason
The reason for optimization termination.

See Also

OptRuntime Class
Run Overload
Decisioneering.CB.CBCOMDevKit.Optimization Namespace
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptOptions


OptRuntime.SetEFBestSolutionFilter Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::SetEFBestSolutionFilter Method
Set the Efficient Frontier show best test point solutions filter. Converts this to a list of EF best solutions, one for each test point.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SetEFBestSolutionFilter(
    bool efBestSolutionsOnly
)
Public Sub SetEFBestSolutionFilter (
    efBestSolutionsOnly As Boolean
)
Dim instance As OptRuntime
Dim efBestSolutionsOnly As Boolean

instance.SetEFBestSolutionFilter(efBestSolutionsOnly)

Parameters

efBestSolutionsOnly
Boolean
Show only EF best solutions, otherwise show solutions (or test point solutions) based upon the current filter settings

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.SetSolutionFilter Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::SetSolutionFilter Method
Set the Optimization solution list filter. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity calculations. This list can be retrieved using GetCurrentSolutionList(). Statistics are kept for each variable based upon the the set of solution values. Statistics values are maintained for: Objectives, Requirements, Constraints and Decision variables. If no filter is set the Optimization variable statistics and sensitivity are be updated for all solutions.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SetSolutionFilter(
    bool sortBestOrder,
    float countLimit,
    bool includeFeasible,
    bool includeInFeasible,
    bool includeLowConfidence
)
Public Sub SetSolutionFilter (
    sortBestOrder As Boolean,
    countLimit As Single,
    includeFeasible As Boolean,
    includeInFeasible As Boolean,
    includeLowConfidence As Boolean
)
Dim instance As OptRuntime
Dim sortBestOrder As Boolean
Dim countLimit As Single
Dim includeFeasible As Boolean
Dim includeInFeasible As Boolean
Dim includeLowConfidence As Boolean

instance.SetSolutionFilter(sortBestOrder,
    countLimit, includeFeasible, includeInFeasible,
    includeLowConfidence)

Parameters

sortBestOrder
Boolean
Use best solution order, otherwise iteration order
countLimit
Single
Limit to count solutions, values: 0.0 all, greater than 0.0 and less than 1.0 percentage, greater than 1.0 Count
includeFeasible
Boolean
Include feasible solutions
includeInFeasible
Boolean
Include infeasible solutions
includeLowConfidence
Boolean
Include low-confidence solutions

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.Stop Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::Stop Method
Stops the optimization.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Stop()
Public Sub Stop
Dim instance As OptRuntime

instance.Stop()

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.UpdateDecVarValues Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::UpdateDecVarValues Method
Update the way decision variable values are set to the workbook after optimization.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void UpdateDecVarValues(
    DecVarValueType decVarValueType
)
Public Sub UpdateDecVarValues (
    decVarValueType As DecVarValueType
)
Dim instance As OptRuntime
Dim decVarValueType As DecVarValueType

instance.UpdateDecVarValues(decVarValueType)

Parameters

decVarValueType
DecVarValueType
Which DecVarValueType is used to update decision variable values

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime Properties

Visual Basic Usage

CB Com Devkit
OptRuntime Properties

The OptRuntime type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BestSolution | The best solution as determind by the optimization.
EfficientFrontier | Return optimization runtime Efficient Frontier information.
ElapsedSeconds | The elapsed seconds for the current optimization run. This is seconds of run time and not wall clock.
EventsAreDisabled | Are events from this OptRuntime object disabled. Allows the user to temporarialy turn off firing of events. Not persisted after Crystal Ball is closed. The default is false.
IterationCount | The number of Optimization iterations that have been run. This number may be greater than the simulation count if the optimization contains non-linear constraints.
LastErrorNumber | The last error number returned by a Devkit method call. This is the NewValue error number from the Macro result. This returns the last Error Number from running any Devkit method. Note: calling this does not update any Macro Result information.
LastResult | The last macro result from a CBCOMDevKit method
OptCounters | Optimization state counters.
OptimizerMode | OptimizerMode - determine if CB is in optimizer mode, in other words if optimization has been or is being executed.
OptState | The current state of the Optimization.
OptTerminationReason | Optimization termination reason. This returns the last Termination Reason. Note: Calling this does not update any Macro Result information.
ResultsWindow | Returns the OptQuest Results Window.
ShowDownshiftDialog | The ShowDownshiftDialog property indicates whether to show the Extreme Speed downshift dialog if the model cannot run in Extreme Speed mode. If a model cannot run in Extreme Speed, this property determines whether a dialog will be displayed giving the user the option to "downshift" to normal speed mode. Note that this property only has effect if CB.AutoDownshift has been set to true. If CB.AutoDownshift is set to false, an error Macro result will always be returned if the model cannot run in Extreme Speed. The default for this property is false.
ShowWizardOnError | Display the OptQuest Wizard on validation error when run optimization is executed. The default is false.

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.BestSolution Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::BestSolution Property
The best solution as determind by the optimization.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSolution BestSolution { get; }
Public ReadOnly Property BestSolution As OptSolution
    Get
Dim instance As OptRuntime
Dim value As OptSolution

value = instance.BestSolution

Property Value

OptSolution

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.EfficientFrontier Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::EfficientFrontier Property
Return optimization runtime Efficient Frontier information.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public RuntimeEfficientFrontier EfficientFrontier { get; }
Public ReadOnly Property EfficientFrontier As RuntimeEfficientFrontier
    Get
Dim instance As OptRuntime
Dim value As RuntimeEfficientFrontier

value = instance.EfficientFrontier

Property Value

RuntimeEfficientFrontier

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.ElapsedSeconds Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::ElapsedSeconds Property
The elapsed seconds for the current optimization run. This is seconds of run time and not wall clock.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ElapsedSeconds { get; }
Public ReadOnly Property ElapsedSeconds As Double
    Get
Dim instance As OptRuntime
Dim value As Double

value = instance.ElapsedSeconds

Property Value

Double

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.EventsAreDisabled Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::EventsAreDisabled Property
Are events from this OptRuntime object disabled. Allows the user to temporarialy turn off firing of events. Not persisted after Crystal Ball is closed. The default is false.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool EventsAreDisabled { get; set; }
Public Property EventsAreDisabled As Boolean
    Get
    Set
Dim instance As OptRuntime
Dim value As Boolean

value = instance.EventsAreDisabled

instance.EventsAreDisabled = value

Property Value

Boolean

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.IterationCount Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::IterationCount Property
The number of Optimization iterations that have been run. This number may be greater than the simulation count if the optimization contains non-linear constraints.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int IterationCount { get; }
Public ReadOnly Property IterationCount As Integer
    Get
Dim instance As OptRuntime
Dim value As Integer

value = instance.IterationCount

Property Value

Int32

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.LastErrorNumber Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::LastErrorNumber Property
The last error number returned by a Devkit method call. This is the NewValue error number from the Macro result. This returns the last Error Number from running any Devkit method. Note: calling this does not update any Macro Result information.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int LastErrorNumber { get; }
Public ReadOnly Property LastErrorNumber As Integer
    Get
Dim instance As OptRuntime
Dim value As Integer

value = instance.LastErrorNumber

Property Value

Int32

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.LastResult Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::LastResult Property
The last macro result from a CBCOMDevKit method

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public MRWrapper LastResult { get; }
Public ReadOnly Property LastResult As MRWrapper
    Get
Dim instance As OptRuntime
Dim value As MRWrapper

value = instance.LastResult

Property Value

MRWrapper

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.OptCounters Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::OptCounters Property
Optimization state counters.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptCounters OptCounters { get; }
Public ReadOnly Property OptCounters As OptCounters
    Get
Dim instance As OptRuntime
Dim value As OptCounters

value = instance.OptCounters

Property Value

OptCounters

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.OptimizerMode Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::OptimizerMode Property
OptimizerMode - determine if CB is in optimizer mode, in other words if optimization has been or is being executed.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool OptimizerMode { get; }
Public ReadOnly Property OptimizerMode As Boolean
    Get
Dim instance As OptRuntime
Dim value As Boolean

value = instance.OptimizerMode

Property Value

Boolean

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.OptState Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::OptState Property
The current state of the Optimization.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptimizationState OptState { get; }
Public ReadOnly Property OptState As OptimizationState
    Get
Dim instance As OptRuntime
Dim value As OptimizationState

value = instance.OptState

Property Value

OptimizationState

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.OptTerminationReason Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::OptTerminationReason Property
Optimization termination reason. This returns the last Termination Reason. Note: Calling this does not update any Macro Result information.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TerminationReason OptTerminationReason { get; }
Public ReadOnly Property OptTerminationReason As TerminationReason
    Get
Dim instance As OptRuntime
Dim value As TerminationReason

value = instance.OptTerminationReason

Property Value

TerminationReason

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.ResultsWindow Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::ResultsWindow Property
Returns the OptQuest Results Window.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ResultsWindow ResultsWindow { get; }
Public ReadOnly Property ResultsWindow As ResultsWindow
    Get
Dim instance As OptRuntime
Dim value As ResultsWindow

value = instance.ResultsWindow

Property Value

ResultsWindow

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access the window

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.ShowDownshiftDialog Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::ShowDownshiftDialog Property
The ShowDownshiftDialog property indicates whether to show the Extreme Speed downshift dialog if the model cannot run in Extreme Speed mode. If a model cannot run in Extreme Speed, this property determines whether a dialog will be displayed giving the user the option to "downshift" to normal speed mode.
Note that this property only has effect if CB.AutoDownshift has been set to true. If CB.AutoDownshift is set to false, an error Macro result will always be returned if the model cannot run in Extreme Speed.
The default for this property is false.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowDownshiftDialog { get; set; }
Public Property ShowDownshiftDialog As Boolean
    Get
    Set
Dim instance As OptRuntime
Dim value As Boolean

value = instance.ShowDownshiftDialog

instance.ShowDownshiftDialog = value

Property Value

Boolean

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.ShowWizardOnError Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::ShowWizardOnError Property
Display the OptQuest Wizard on validation error when run optimization is executed. The default is false.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowWizardOnError { get; set; }
Public Property ShowWizardOnError As Boolean
    Get
    Set
Dim instance As OptRuntime
Dim value As Boolean

value = instance.ShowWizardOnError

instance.ShowWizardOnError = value

Property Value

Boolean

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime Events

Visual Basic Usage

CB Com Devkit
OptRuntime Events

The OptRuntime type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AfterIterationEvent | Event raised after an optimization's iteration completes. At this point the simulation is complete, any extract data has been written to the workbook and objective / requirement values have been updated to OptQuest. At this point the solution for this iteration is valid.
AfterOptimizationEvent | Event raised just after an optimization completes.
AfterOptimizationResetEvent | Event raised just after an Optimization Reset completes.
AfterSimulationEvent | Event raised just after an optimization's simulation (or iteration evaluation) completes. The simulation is complete and any simulation results are valid. Any extracted data values will also have been written to the workbook as part of the simulation processing. Forecast objective and requirement values have not yet been updated to OptQuest. at this point the solution for this iteration is NOT valid.
BeforeIterationEvent | Event raised prior to an optimization's iteration being run. This event occurs after any Decision Variables are placed into the workbook but before any constraints are evaluated or simulations are run. At this point the solution for this iteration is NOT valid.
BeforeOptimizationEvent | Event raised just prior to an optimization running.
BeforeOptimizationResetEvent | Event raised just prior to an optimization running.
BeforeSimulationEvent | Before Simulation Event. This event occurs after OptQuest evaluates any constraints but before any simulations are run. At this point the solution for this iteration is NOT valid.
EfficientFrontierEvent | Event for Efficient Frontier. This event is generated when each Efficient Frontier Test Value evaluation completes.

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.AfterIterationEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::AfterIterationEvent Event
Event raised after an optimization's iteration completes. At this point the simulation is complete, any extract data has been written to the workbook and objective / requirement values have been updated to OptQuest. At this point the solution for this iteration is valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptItersEventHandler AfterIterationEvent
Public Event AfterIterationEvent As OptRuntime..::..OptItersEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptItersEventHandler

AddHandler instance.AfterIterationEvent, handler

Value

OptRuntime..::..OptItersEventHandler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.AfterOptimizationEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::AfterOptimizationEvent Event
Event raised just after an optimization completes.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptItersEventHandler AfterOptimizationEvent
Public Event AfterOptimizationEvent As OptRuntime..::..OptItersEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptItersEventHandler

AddHandler instance.AfterOptimizationEvent, handler

Value

OptRuntime..::..OptItersEventHandler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.AfterOptimizationResetEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::AfterOptimizationResetEvent Event
Event raised just after an Optimization Reset completes.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptEventHandler AfterOptimizationResetEvent
Public Event AfterOptimizationResetEvent As OptRuntime..::..OptEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptEventHandler

AddHandler instance.AfterOptimizationResetEvent, handler

Value

OptRuntime..::..OptEventHandler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.AfterSimulationEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::AfterSimulationEvent Event
Event raised just after an optimization's simulation (or iteration evaluation) completes. The simulation is complete and any simulation results are valid. Any extracted data values will also have been written to the workbook as part of the simulation processing. Forecast objective and requirement values have not yet been updated to OptQuest. at this point the solution for this iteration is NOT valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..AfterSimulationEventHandler AfterSimulationEvent
Public Event AfterSimulationEvent As OptRuntime..::..AfterSimulationEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..AfterSimulationEventHandler

AddHandler instance.AfterSimulationEvent, handler

Value

OptRuntime..::..AfterSimulationEventHandler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.BeforeIterationEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::BeforeIterationEvent Event
Event raised prior to an optimization's iteration being run. This event occurs after any Decision Variables are placed into the workbook but before any constraints are evaluated or simulations are run. At this point the solution for this iteration is NOT valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptEventHandler BeforeIterationEvent
Public Event BeforeIterationEvent As OptRuntime..::..OptEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptEventHandler

AddHandler instance.BeforeIterationEvent, handler

Value

OptRuntime..::..OptEventHandler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.BeforeOptimizationEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::BeforeOptimizationEvent Event
Event raised just prior to an optimization running.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptEventHandler BeforeOptimizationEvent
Public Event BeforeOptimizationEvent As OptRuntime..::..OptEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptEventHandler

AddHandler instance.BeforeOptimizationEvent, handler

Value

OptRuntime..::..OptEventHandler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.BeforeOptimizationResetEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::BeforeOptimizationResetEvent Event
Event raised just prior to an optimization running.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptItersEventHandler BeforeOptimizationResetEvent
Public Event BeforeOptimizationResetEvent As OptRuntime..::..OptItersEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptItersEventHandler

AddHandler instance.BeforeOptimizationResetEvent, handler

Value

OptRuntime..::..OptItersEventHandler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.BeforeSimulationEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::BeforeSimulationEvent Event
Before Simulation Event. This event occurs after OptQuest evaluates any constraints but before any simulations are run. At this point the solution for this iteration is NOT valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptEventHandler BeforeSimulationEvent
Public Event BeforeSimulationEvent As OptRuntime..::..OptEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptEventHandler

AddHandler instance.BeforeSimulationEvent, handler

Value

OptRuntime..::..OptEventHandler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.EfficientFrontierEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::EfficientFrontierEvent Event
Event for Efficient Frontier. This event is generated when each Efficient Frontier Test Value evaluation completes.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..EfficientFrontierEventHandler EfficientFrontierEvent
Public Event EfficientFrontierEvent As OptRuntime..::..EfficientFrontierEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..EfficientFrontierEventHandler

AddHandler instance.EfficientFrontierEvent, handler

Value

OptRuntime..::..EfficientFrontierEventHandler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.AfterSimulationEventHandler Delegate

Visual Basic Usage

CB Com Devkit
OptRuntime..::..AfterSimulationEventHandler Delegate
After simulation event handler.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public delegate void AfterSimulationEventHandler(
    ref int IterationsCompleted,
    ref int Trials,
    ref int MaxTrials,
    ref double Progress,
    ref bool WasAborted,
    ref bool WasStopOnError,
    ref bool WasStoppedOnPrecision,
    ref bool HasNewBestSolution
)
Public Delegate Sub AfterSimulationEventHandler (
    ByRef IterationsCompleted As Integer,
    ByRef Trials As Integer,
    ByRef MaxTrials As Integer,
    ByRef Progress As Double,
    ByRef WasAborted As Boolean,
    ByRef WasStopOnError As Boolean,
    ByRef WasStoppedOnPrecision As Boolean,
    ByRef HasNewBestSolution As Boolean
)
Dim instance As New AfterSimulationEventHandler(AddressOf HandlerMethod)

Parameters

IterationsCompleted
Int32 %
Number of Optimization iterations completed
Trials
Int32 %
Number of trials run in the last simulation
MaxTrials
Int32 %
The maximuk number of trials configured for a simulation
Progress
Double %
The progress of the completed simulation
WasAborted
Boolean %
True if the simulation was aborted
WasStopOnError
Boolean %
True if the simulation was stopped due to an error
WasStoppedOnPrecision
Boolean %
True if the simulation was stopped due to precision controls
HasNewBestSolution
Boolean %
True if the simulation represents a new best solution

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.EfficientFrontierEventHandler Delegate

Visual Basic Usage

CB Com Devkit
OptRuntime..::..EfficientFrontierEventHandler Delegate
Efficient Frontier Event handler.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public delegate void EfficientFrontierEventHandler(
    ref double TestValue
)
Public Delegate Sub EfficientFrontierEventHandler (
    ByRef TestValue As Double
)
Dim instance As New EfficientFrontierEventHandler(AddressOf HandlerMethod)

Parameters

TestValue
Double %
The test value that has just completed processing

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.OptEventHandler Delegate

Visual Basic Usage

CB Com Devkit
OptRuntime..::..OptEventHandler Delegate
Optimization Event handler.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public delegate void OptEventHandler()
Public Delegate Sub OptEventHandler
Dim instance As New OptEventHandler(AddressOf HandlerMethod)

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.OptItersEventHandler Delegate

Visual Basic Usage

CB Com Devkit
OptRuntime..::..OptItersEventHandler Delegate
Optimization Iterations Event handler.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public delegate void OptItersEventHandler(
    ref int IterationsCompleted
)
Public Delegate Sub OptItersEventHandler (
    ByRef IterationsCompleted As Integer
)
Dim instance As New OptItersEventHandler(AddressOf HandlerMethod)

Parameters

IterationsCompleted
Int32 %
The number of iterations completed.

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetDecVars Enumeration

Visual Basic Usage

CB Com Devkit
OptSetDecVars Enumeration
Set decision variable cell values type enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptSetDecVars
Public Enumeration OptSetDecVars
Dim instance As OptSetDecVars

Members

Member | Value | Description
SetToBest | 0 | Automatically set decision variable cells to best solution
LeaveOriginal | 1 | Leave decision variable cells set to original values

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptSetup Class
Optimization Setup / Definition Access optimization variables, add, modify and delete variables and options for running optimizations

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptSetup
Public Class OptSetup
Dim instance As OptSetup

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
OptSetup()()()() | Optimization Setup / Definition Access optimization variables, add, modify and delete variables and options for running optimizations
AddConstraint(String) | Add a new constraint to the constraints collection
AddObjective(OptObjectiveType, Range, OptSupportedStatistics, Double, Double, Double, OptConditionType) | Add a new Objective to the objectives collection
AddRequirement(Range, OptSupportedStatistics, OptConditionType, Double, Double, Double, Double, OptMoreLessCondition) | AddRequirement adds a new Requirement to the requirement collection
ClearAll()()()() | Clear all Optimization variables for all open workbooks
Constraints | Get a Constraints enumerator, no updates to DecVars will be reflected until enumeration recreated
Decisions | Get a Decisions enumerator, no updates to DecVars will be reflected until enumeration recreated
EfficientFrontier | Access to Efficient Frontier options singleton
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
LastResult | The last macro result from a CBCOMDevKit method
Objectives | Get a Objective enumerator, no updates to DecVars will be reflected until enumeration recreated
Options | Access to optimization options singleton
PrimaryWorkbook | Workbook that is the target for Optimization variable storage and access
Requirements | Get a Requirement enumerator, no updates to DecVars will be reflected until enumeration recreated
Show()()()() | Show the Optimization Wizard GUI
ThrowErrors | Setting to determine whether to throw errors to the client app
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate(Boolean) | Validate all optimization settings for current storage workbook and determine if optimization can be run.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptSetup

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup Constructor

Visual Basic Usage

CB Com Devkit
OptSetup Constructor
Optimization Setup / Definition Access optimization variables, add, modify and delete variables and options for running optimizations

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSetup()
Public Sub New
Dim instance As New OptSetup()

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup Methods

Visual Basic Usage

CB Com Devkit
OptSetup Methods

The OptSetup type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddConstraint(String) | Add a new constraint to the constraints collection
AddObjective(OptObjectiveType, Range, OptSupportedStatistics, Double, Double, Double, OptConditionType) | Add a new Objective to the objectives collection
AddRequirement(Range, OptSupportedStatistics, OptConditionType, Double, Double, Double, Double, OptMoreLessCondition) | AddRequirement adds a new Requirement to the requirement collection
ClearAll()()()() | Clear all Optimization variables for all open workbooks
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Show()()()() | Show the Optimization Wizard GUI
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate(Boolean) | Validate all optimization settings for current storage workbook and determine if optimization can be run.

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.AddConstraint Method

Visual Basic Usage

CB Com Devkit
OptSetup..::AddConstraint Method
Add a new constraint to the constraints collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Constraint AddConstraint(
    string equation
)
Public Function AddConstraint (
    equation As String
) As Constraint
Dim instance As OptSetup
Dim equation As String
Dim returnValue As Constraint

returnValue = instance.AddConstraint(equation)

Parameters

equation
String
Constraint equation. This can contain decision variable names or cell addresses.

Return Value

Constraint
new Constraint or null

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.AddObjective Method

Visual Basic Usage

CB Com Devkit
OptSetup..::AddObjective Method
Add a new Objective to the objectives collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Objective AddObjective(
    OptObjectiveType type,
    Range forecastRange,
    OptSupportedStatistics stats,
    double targetValue = NaN,
    double statisticValue1 = NaN,
    double statisticValue2 = NaN,
    [OptionalAttribute] OptConditionType condition
)
Public Function AddObjective (
    type As OptObjectiveType,
    forecastRange As Range,
    stats As OptSupportedStatistics,
    Optional targetValue As Double = NaN,
    Optional statisticValue1 As Double = NaN,
    Optional statisticValue2 As Double = NaN,
    <OptionalAttribute> condition As OptConditionType
) As Objective
Dim instance As OptSetup
Dim type As OptObjectiveType
Dim forecastRange As Range
Dim stats As OptSupportedStatistics
Dim targetValue As Double
Dim statisticValue1 As Double
Dim statisticValue2 As Double
Dim condition As OptConditionType
Dim returnValue As Objective

returnValue = instance.AddObjective(type,
    forecastRange, stats, targetValue,
    statisticValue1, statisticValue2,
    condition)

Parameters

type
OptObjectiveType
Objective type, one of the OptObjectiveType enumeration values
forecastRange
Range
Excel range referencing a Forecast to be used in the objective, this must be an Excel.Range type object.
stats
OptSupportedStatistics
Objective statistic, one of OptSupportedStatistics enumeration values
targetValue (Optional)
Double
Objective target value, used only for SetTarget objective (optional)
statisticValue1 (Optional)
Double
double first statistic value (optional)
statisticValue2 (Optional)
Double
double second statistic value (optional)
condition (Optional)
OptConditionType
Objective condition, coud be one of the values defined in OptConditionType enumeration (optional)

Return Value

Objective
new Objective or null

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.AddRequirement Method

Visual Basic Usage

CB Com Devkit
OptSetup..::AddRequirement Method
AddRequirement adds a new Requirement to the requirement collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Requirement AddRequirement(
    Range forecastRange,
    OptSupportedStatistics stats,
    OptConditionType condition,
    double conditionValue1,
    double conditionValue2 = NaN,
    double statisticValue1 = NaN,
    double statisticValue2 = NaN,
    [OptionalAttribute] OptMoreLessCondition moreLessCondition
)
Public Function AddRequirement (
    forecastRange As Range,
    stats As OptSupportedStatistics,
    condition As OptConditionType,
    conditionValue1 As Double,
    Optional conditionValue2 As Double = NaN,
    Optional statisticValue1 As Double = NaN,
    Optional statisticValue2 As Double = NaN,
    <OptionalAttribute> moreLessCondition As OptMoreLessCondition
) As Requirement
Dim instance As OptSetup
Dim forecastRange As Range
Dim stats As OptSupportedStatistics
Dim condition As OptConditionType
Dim conditionValue1 As Double
Dim conditionValue2 As Double
Dim statisticValue1 As Double
Dim statisticValue2 As Double
Dim moreLessCondition As OptMoreLessCondition
Dim returnValue As Requirement

returnValue = instance.AddRequirement(forecastRange,
    stats, condition, conditionValue1,
    conditionValue2, statisticValue1,
    statisticValue2, moreLessCondition)

Parameters

forecastRange
Range
Excel range referencing a Forecast to be used in this requirement, this must be an Excel.Range type object.
stats
OptSupportedStatistics
Defines one of OptSupportedStatistics as Requirement statistic
condition
OptConditionType
OptConditionType condition
conditionValue1
Double
double first condition value
conditionValue2 (Optional)
Double
double second condition value(optional)
statisticValue1 (Optional)
Double
double first statistic value (optional)
statisticValue2 (Optional)
Double
double second statistic value (optional)
moreLessCondition (Optional)
OptMoreLessCondition
one of the OptMoreLessCondition values (optional)

Return Value

Requirement
The requirement object added or null

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.ClearAll Method

Visual Basic Usage

CB Com Devkit
OptSetup..::ClearAll Method
Clear all Optimization variables for all open workbooks

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ClearAll()
Public Function ClearAll As Boolean
Dim instance As OptSetup
Dim returnValue As Boolean

returnValue = instance.ClearAll()

Return Value

Boolean
Whether all variables were successfully cleared.

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.Show Method

Visual Basic Usage

CB Com Devkit
OptSetup..::Show Method
Show the Optimization Wizard GUI

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Show()
Public Function Show As Boolean
Dim instance As OptSetup
Dim returnValue As Boolean

returnValue = instance.Show()

Return Value

Boolean
Whether wizard was shown.

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.Validate Method

Visual Basic Usage

CB Com Devkit
OptSetup..::Validate Method
Validate all optimization settings for current storage workbook and determine if optimization can be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate(
    bool ShowWizard
)
Public Function Validate (
    ShowWizard As Boolean
) As Boolean
Dim instance As OptSetup
Dim ShowWizard As Boolean
Dim returnValue As Boolean

returnValue = instance.Validate(ShowWizard)

Parameters

ShowWizard
Boolean
Show the wizard on validation error?

Return Value

Boolean
Whether optimization can be run.

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup Properties

Visual Basic Usage

CB Com Devkit
OptSetup Properties

The OptSetup type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Constraints | Get a Constraints enumerator, no updates to DecVars will be reflected until enumeration recreated
Decisions | Get a Decisions enumerator, no updates to DecVars will be reflected until enumeration recreated
EfficientFrontier | Access to Efficient Frontier options singleton
LastResult | The last macro result from a CBCOMDevKit method
Objectives | Get a Objective enumerator, no updates to DecVars will be reflected until enumeration recreated
Options | Access to optimization options singleton
PrimaryWorkbook | Workbook that is the target for Optimization variable storage and access
Requirements | Get a Requirement enumerator, no updates to DecVars will be reflected until enumeration recreated
ThrowErrors | Setting to determine whether to throw errors to the client app

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.Constraints Property

Visual Basic Usage

CB Com Devkit
OptSetup..::Constraints Property
Get a Constraints enumerator, no updates to DecVars will be reflected until enumeration recreated

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ConEnumerator Constraints { get; }
Public ReadOnly Property Constraints As ConEnumerator
    Get
Dim instance As OptSetup
Dim value As ConEnumerator

value = instance.Constraints

Property Value

ConEnumerator

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.Decisions Property

Visual Basic Usage

CB Com Devkit
OptSetup..::Decisions Property
Get a Decisions enumerator, no updates to DecVars will be reflected until enumeration recreated

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public DecEnumerator Decisions { get; }
Public ReadOnly Property Decisions As DecEnumerator
    Get
Dim instance As OptSetup
Dim value As DecEnumerator

value = instance.Decisions

Property Value

DecEnumerator

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.EfficientFrontier Property

Visual Basic Usage

CB Com Devkit
OptSetup..::EfficientFrontier Property
Access to Efficient Frontier options singleton

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptEfficientFrontier EfficientFrontier { get; }
Public ReadOnly Property EfficientFrontier As OptEfficientFrontier
    Get
Dim instance As OptSetup
Dim value As OptEfficientFrontier

value = instance.EfficientFrontier

Property Value

OptEfficientFrontier

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.LastResult Property

Visual Basic Usage

CB Com Devkit
OptSetup..::LastResult Property
The last macro result from a CBCOMDevKit method

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public MRWrapper LastResult { get; }
Public ReadOnly Property LastResult As MRWrapper
    Get
Dim instance As OptSetup
Dim value As MRWrapper

value = instance.LastResult

Property Value

MRWrapper

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.Objectives Property

Visual Basic Usage

CB Com Devkit
OptSetup..::Objectives Property
Get a Objective enumerator, no updates to DecVars will be reflected until enumeration recreated

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ObjEnumerator Objectives { get; }
Public ReadOnly Property Objectives As ObjEnumerator
    Get
Dim instance As OptSetup
Dim value As ObjEnumerator

value = instance.Objectives

Property Value

ObjEnumerator

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.Options Property

Visual Basic Usage

CB Com Devkit
OptSetup..::Options Property
Access to optimization options singleton

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptOptions Options { get; }
Public ReadOnly Property Options As OptOptions
    Get
Dim instance As OptSetup
Dim value As OptOptions

value = instance.Options

Property Value

OptOptions

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.PrimaryWorkbook Property

Visual Basic Usage

CB Com Devkit
OptSetup..::PrimaryWorkbook Property
Workbook that is the target for Optimization variable storage and access

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string PrimaryWorkbook { get; set; }
Public Property PrimaryWorkbook As String
    Get
    Set
Dim instance As OptSetup
Dim value As String

value = instance.PrimaryWorkbook

instance.PrimaryWorkbook = value

Property Value

String

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.Requirements Property

Visual Basic Usage

CB Com Devkit
OptSetup..::Requirements Property
Get a Requirement enumerator, no updates to DecVars will be reflected until enumeration recreated

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ReqEnumerator Requirements { get; }
Public ReadOnly Property Requirements As ReqEnumerator
    Get
Dim instance As OptSetup
Dim value As ReqEnumerator

value = instance.Requirements

Property Value

ReqEnumerator

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup.ThrowErrors Property

Visual Basic Usage

CB Com Devkit
OptSetup..::ThrowErrors Property
Setting to determine whether to throw errors to the client app

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowErrors { get; set; }
Public Property ThrowErrors As Boolean
    Get
    Set
Dim instance As OptSetup
Dim value As Boolean

value = instance.ThrowErrors

instance.ThrowErrors = value

Property Value

Boolean

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptShowChartType Enumeration

Visual Basic Usage

CB Com Devkit
OptShowChartType Enumeration
Show chart type enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptShowChartType
Public Enumeration OptShowChartType
Dim instance As OptShowChartType

Members

Member | Value | Description
AsDefined | 0 | Show chart windows as defined
Targets | 1 | Show only target forecast windows

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptSolution Class
Represents a single solution in an Optimization. A solution is a set of values for Decision Variables and their associated result values. Result values may be obtained for: Objectives, Requirements, Constraints.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptSolution
Public Class OptSolution
Dim instance As OptSolution

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ErrorDescription | The error description if an error occurred. If used the SolutionStatus should be OptSolution.OptSolutionStatus.StoppedOnError.
ErrorNumber | The CB error number if an error occurred, 0 for no error, -1010 for unexpected error. If used the SolutionStatus should be OptSolution.OptSolutionStatus.StoppedOnError.
GetDecVarValue(Decision) | Get the value for a Decision Variable in this solution.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetPrimaryObjectiveValue()()()() | Get the value for primary objective variable in this solution.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
GetValue(OptVar, SolutionValueType) | Get the value for an optimization variable in this solution. Values may be obtained for: Decision Variables, Objectives, Requirements and Constraints. The value type argument applies only for constraints. For Constraints you can select the value from either the left hand side or right hand side of the equation. The Default is left hand side.
IsFeasible(OptVar) | Determins whether a specific optimization variable in this solution is feasible. This may be obtained for: Objectives, Requirements and Constraints.
IsSolutionFeasible | Is this solution feasible.
NewBestSolution | A new best solution. This solution was the Best solution at the time it was evaluated. This property does not have meaning for Efficient Frontier optimizations because of solution reuse across test cases.
SimTrialCount | The count of trials if a simulation was run, otherwise 1.
SolutionIndex | The zero based index for this solution. This is the index based upon the order that solutions were generated (not best order).
SolutionStatus | The solution status, including the state of the simulation if run.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptSolution

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution Methods

Visual Basic Usage

CB Com Devkit
OptSolution Methods

The OptSolution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDecVarValue(Decision) | Get the value for a Decision Variable in this solution.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetPrimaryObjectiveValue()()()() | Get the value for primary objective variable in this solution.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
GetValue(OptVar, SolutionValueType) | Get the value for an optimization variable in this solution. Values may be obtained for: Decision Variables, Objectives, Requirements and Constraints. The value type argument applies only for constraints. For Constraints you can select the value from either the left hand side or right hand side of the equation. The Default is left hand side.
IsFeasible(OptVar) | Determins whether a specific optimization variable in this solution is feasible. This may be obtained for: Objectives, Requirements and Constraints.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution.GetDecVarValue Method

Visual Basic Usage

CB Com Devkit
OptSolution..::GetDecVarValue Method
Get the value for a Decision Variable in this solution.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double GetDecVarValue(
    Decision decisionVariable
)
Public Function GetDecVarValue (
    decisionVariable As Decision
) As Double
Dim instance As OptSolution
Dim decisionVariable As Decision
Dim returnValue As Double

returnValue = instance.GetDecVarValue(decisionVariable)

Parameters

decisionVariable
Decision
Decision Variable.

Return Value

Double
Decision Variable value for this solution.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution.GetPrimaryObjectiveValue Method

Visual Basic Usage

CB Com Devkit
OptSolution..::GetPrimaryObjectiveValue Method
Get the value for primary objective variable in this solution.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double GetPrimaryObjectiveValue()
Public Function GetPrimaryObjectiveValue As Double
Dim instance As OptSolution
Dim returnValue As Double

returnValue = instance.GetPrimaryObjectiveValue()

Return Value

Double
Optimization variable value for this solution.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution.GetValue Method

Visual Basic Usage

CB Com Devkit
OptSolution..::GetValue Method
Get the value for an optimization variable in this solution. Values may be obtained for: Decision Variables, Objectives, Requirements and Constraints. The value type argument applies only for constraints. For Constraints you can select the value from either the left hand side or right hand side of the equation. The Default is left hand side.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double GetValue(
    OptVar optimizationVariable,
    [OptionalAttribute] SolutionValueType valueType
)
Public Function GetValue (
    optimizationVariable As OptVar,
    <OptionalAttribute> valueType As SolutionValueType
) As Double
Dim instance As OptSolution
Dim optimizationVariable As OptVar
Dim valueType As SolutionValueType
Dim returnValue As Double

returnValue = instance.GetValue(optimizationVariable,
    valueType)

Parameters

optimizationVariable
OptVar
Optimization variable.
valueType (Optional)
SolutionValueType
Get the equation right hand side value or left hand side value. Applies to constraints.

Return Value

Double
Optimization variable value for this solution.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution.IsFeasible Method

Visual Basic Usage

CB Com Devkit
OptSolution..::IsFeasible Method
Determins whether a specific optimization variable in this solution is feasible. This may be obtained for: Objectives, Requirements and Constraints.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsFeasible(
    OptVar optimizationVariable
)
Public Function IsFeasible (
    optimizationVariable As OptVar
) As Boolean
Dim instance As OptSolution
Dim optimizationVariable As OptVar
Dim returnValue As Boolean

returnValue = instance.IsFeasible(optimizationVariable)

Parameters

optimizationVariable
OptVar
Optimization variable.

Return Value

Boolean
Optimization variable value for this solution.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution Properties

Visual Basic Usage

CB Com Devkit
OptSolution Properties

The OptSolution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ErrorDescription | The error description if an error occurred. If used the SolutionStatus should be OptSolution.OptSolutionStatus.StoppedOnError.
ErrorNumber | The CB error number if an error occurred, 0 for no error, -1010 for unexpected error. If used the SolutionStatus should be OptSolution.OptSolutionStatus.StoppedOnError.
IsSolutionFeasible | Is this solution feasible.
NewBestSolution | A new best solution. This solution was the Best solution at the time it was evaluated. This property does not have meaning for Efficient Frontier optimizations because of solution reuse across test cases.
SimTrialCount | The count of trials if a simulation was run, otherwise 1.
SolutionIndex | The zero based index for this solution. This is the index based upon the order that solutions were generated (not best order).
SolutionStatus | The solution status, including the state of the simulation if run.

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution.ErrorDescription Property

Visual Basic Usage

CB Com Devkit
OptSolution..::ErrorDescription Property
The error description if an error occurred. If used the SolutionStatus should be OptSolution.OptSolutionStatus.StoppedOnError.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string ErrorDescription { get; }
Public ReadOnly Property ErrorDescription As String
    Get
Dim instance As OptSolution
Dim value As String

value = instance.ErrorDescription

Property Value

String

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution.ErrorNumber Property

Visual Basic Usage

CB Com Devkit
OptSolution..::ErrorNumber Property
The CB error number if an error occurred, 0 for no error, -1010 for unexpected error. If used the SolutionStatus should be OptSolution.OptSolutionStatus.StoppedOnError.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ErrorNumber { get; }
Public ReadOnly Property ErrorNumber As Integer
    Get
Dim instance As OptSolution
Dim value As Integer

value = instance.ErrorNumber

Property Value

Int32

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution.IsSolutionFeasible Property

Visual Basic Usage

CB Com Devkit
OptSolution..::IsSolutionFeasible Property
Is this solution feasible.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsSolutionFeasible { get; }
Public ReadOnly Property IsSolutionFeasible As Boolean
    Get
Dim instance As OptSolution
Dim value As Boolean

value = instance.IsSolutionFeasible

Property Value

Boolean

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution.NewBestSolution Property

Visual Basic Usage

CB Com Devkit
OptSolution..::NewBestSolution Property
A new best solution. This solution was the Best solution at the time it was evaluated. This property does not have meaning for Efficient Frontier optimizations because of solution reuse across test cases.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool NewBestSolution { get; }
Public ReadOnly Property NewBestSolution As Boolean
    Get
Dim instance As OptSolution
Dim value As Boolean

value = instance.NewBestSolution

Property Value

Boolean

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution.SimTrialCount Property

Visual Basic Usage

CB Com Devkit
OptSolution..::SimTrialCount Property
The count of trials if a simulation was run, otherwise 1.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SimTrialCount { get; }
Public ReadOnly Property SimTrialCount As Integer
    Get
Dim instance As OptSolution
Dim value As Integer

value = instance.SimTrialCount

Property Value

Int32

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution.SolutionIndex Property

Visual Basic Usage

CB Com Devkit
OptSolution..::SolutionIndex Property
The zero based index for this solution. This is the index based upon the order that solutions were generated (not best order).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SolutionIndex { get; }
Public ReadOnly Property SolutionIndex As Integer
    Get
Dim instance As OptSolution
Dim value As Integer

value = instance.SolutionIndex

Property Value

Int32

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution.SolutionStatus Property

Visual Basic Usage

CB Com Devkit
OptSolution..::SolutionStatus Property
The solution status, including the state of the simulation if run.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SolutionStatus SolutionStatus { get; }
Public ReadOnly Property SolutionStatus As SolutionStatus
    Get
Dim instance As OptSolution
Dim value As SolutionStatus

value = instance.SolutionStatus

Property Value

SolutionStatus

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolutionEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptSolutionEnumerator Class
OptSolution enumerator class. This class is used to enumerate a list of solutions generated by an Optimization.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptSolutionEnumerator : VarEnumerator
Public Class OptSolutionEnumerator
    Inherits VarEnumerator
Dim instance As OptSolutionEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumeration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Sync and Reload Constraint vars (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptSolutionEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolutionEnumerator Methods

Visual Basic Usage

CB Com Devkit
OptSolutionEnumerator Methods

The OptSolutionEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Sync and Reload Constraint vars (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

OptSolutionEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolutionEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
OptSolutionEnumerator..::Reload Method
Sync and Reload Constraint vars

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As OptSolutionEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
True on success

Implements

IVarEnumerator..::..Reload()()()()

See Also

OptSolutionEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolutionEnumerator Properties

Visual Basic Usage

CB Com Devkit
OptSolutionEnumerator Properties

The OptSolutionEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumeration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

OptSolutionEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolutionEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
OptSolutionEnumerator..::Current Property
Returns the current variable in the enumeration (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As OptSolutionEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

OptSolutionEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolutionEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
OptSolutionEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSolution this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As OptSolution
    Get
Dim instance As OptSolutionEnumerator
Dim index As Integer
Dim value As OptSolution

value = instance(index)

Parameters

index
Int32

Property Value

OptSolution

See Also

OptSolutionEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSupportedStatistics Enumeration

Visual Basic Usage

CB Com Devkit
OptSupportedStatistics Enumeration
Supported Statistics

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptSupportedStatistics
Public Enumeration OptSupportedStatistics
Dim instance As OptSupportedStatistics

Members

Member | Value | Description
Mean | 0 | Mean statistic
Median | 1 | Median statistic
Mode | 2 | Mode statistic
StandardDeviation | 3 | Standard Deviation statistic
Variance | 4 | Variance statistic
Skewness | 5 | Skewness statistic
Kurtosis | 6 | Kurtosis statistic
CoeffOfVariability | 7 | Coefficient of variability statistic
Minimum | 8 | Minimum statistic
Maximum | 9 | Maximum statistic
RangeWidth | 10 | Range width statistic
FinalValue | 11 | Final value statistic
Percentile | 12 | Percentile statistic
Probability | 13 | Probability statistic
Chance | 14 | Chance statistic
Certainty | 15 | Certainty statistic
Cp | 16 | Cp statistic
CpkLower | 17 | CpkLower statistic
CpkUpper | 18 | CpkUpper statistic
Cpk | 19 | Cpk statistic
Cpm | 20 | Cpm statistic
ZLSL | 21 | ZLSL statistic
ZUSL | 22 | ZUSL statistic
Zst | 23 | Zst statistic
Zlt | 24 | Zlt statistic
pNCbelow | 25 | pNCbelow statistic
pNCabove | 26 | pNCabove statistic
pNCtotal | 27 | pNCtotal statistic
PPMbelow | 28 | PPMbelow statistic
PPMabove | 29 | PPMabove statistic
PPMtotal | 30 | PPMtotal statistic
Pp | 31 | Pp statistic
PpkLower | 32 | PpkLower statistic
PpkUpper | 33 | PpkUpper statistic
Ppk | 34 | Ppk statistic
Ppm | 35 | Ppm statistic

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVar Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptVar Class
Base class for Optimization variable objects

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptVar
Public Class OptVar
Dim instance As OptVar

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Comment | Var comment
DisplayName | Var display name
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exclude | Is var excluded
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVar
Decisioneering.CB.CBCOMDevKit.Optimization..::..Constraint
Decisioneering.CB.CBCOMDevKit.Optimization..::..ObjReqBase

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVar Methods

Visual Basic Usage

CB Com Devkit
OptVar Methods

The OptVar type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVar Properties

Visual Basic Usage

CB Com Devkit
OptVar Properties

The OptVar type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Comment | Var comment
DisplayName | Var display name
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier)
Exclude | Is var excluded
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter.

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVar.Comment Property

Visual Basic Usage

CB Com Devkit
OptVar..::Comment Property
Var comment

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
Dim instance As OptVar
Dim value As String

value = instance.Comment

instance.Comment = value

Property Value

String

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVar.DisplayName Property

Visual Basic Usage

CB Com Devkit
OptVar..::DisplayName Property
Var display name

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
Dim instance As OptVar
Dim value As String

value = instance.DisplayName

Property Value

String

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVar.EFDisplayName Property

Visual Basic Usage

CB Com Devkit
OptVar..::EFDisplayName Property
Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier)

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string EFDisplayName { get; }
Public ReadOnly Property EFDisplayName As String
    Get
Dim instance As OptVar
Dim value As String

value = instance.EFDisplayName

Property Value

String

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVar.Exclude Property

Visual Basic Usage

CB Com Devkit
OptVar..::Exclude Property
Is var excluded

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Exclude { get; set; }
Public Property Exclude As Boolean
    Get
    Set
Dim instance As OptVar
Dim value As Boolean

value = instance.Exclude

instance.Exclude = value

Property Value

Boolean

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVar.OptimizationStatistics Property

Visual Basic Usage

CB Com Devkit
OptVar..::OptimizationStatistics Property
Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptVarStatistics OptimizationStatistics { get; }
Public ReadOnly Property OptimizationStatistics As OptVarStatistics
    Get
Dim instance As OptVar
Dim value As OptVarStatistics

value = instance.OptimizationStatistics

Return Value

OptVarStatistics
Optimization Variable statistics for this Optimization.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun | Optimization must have been run to access this data

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarSolutionFilter Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptVarSolutionFilter Class
The Optimization variable statistics filter. The statistics filter limits the set of solutions that affect the Optimization variable statistics.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptVarSolutionFilter
Public Class OptVarSolutionFilter
Dim instance As OptVarSolutionFilter

Members

All Members | Fields | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CountLimit | Limit to count solutions, values: 0.0 all, greater than 0.0 and less than 1.0 percentage, greater than 1.0 Count
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IncludeFeasible | Include feasible solutions
IncludeInFeasible | Include infeasible solutions
IncludeLowConfidence | Include low-confidence solutions
SortBestOrder | Use best solution order, otherwise iteration order
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVarSolutionFilter

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarSolutionFilter Fields

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter Fields

The OptVarSolutionFilter type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CountLimit | Limit to count solutions, values: 0.0 all, greater than 0.0 and less than 1.0 percentage, greater than 1.0 Count
IncludeFeasible | Include feasible solutions
IncludeInFeasible | Include infeasible solutions
IncludeLowConfidence | Include low-confidence solutions
SortBestOrder | Use best solution order, otherwise iteration order

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarSolutionFilter.CountLimit Field

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter..::CountLimit Field
Limit to count solutions, values: 0.0 all, greater than 0.0 and less than 1.0 percentage, greater than 1.0 Count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public float CountLimit
Public CountLimit As Single
Dim instance As OptVarSolutionFilter
Dim value As Single

value = instance.CountLimit

instance.CountLimit = value

Field Value

Single

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarSolutionFilter.IncludeFeasible Field

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter..::IncludeFeasible Field
Include feasible solutions

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IncludeFeasible
Public IncludeFeasible As Boolean
Dim instance As OptVarSolutionFilter
Dim value As Boolean

value = instance.IncludeFeasible

instance.IncludeFeasible = value

Field Value

Boolean

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarSolutionFilter.IncludeInFeasible Field

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter..::IncludeInFeasible Field
Include infeasible solutions

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IncludeInFeasible
Public IncludeInFeasible As Boolean
Dim instance As OptVarSolutionFilter
Dim value As Boolean

value = instance.IncludeInFeasible

instance.IncludeInFeasible = value

Field Value

Boolean

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarSolutionFilter.IncludeLowConfidence Field

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter..::IncludeLowConfidence Field
Include low-confidence solutions

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IncludeLowConfidence
Public IncludeLowConfidence As Boolean
Dim instance As OptVarSolutionFilter
Dim value As Boolean

value = instance.IncludeLowConfidence

instance.IncludeLowConfidence = value

Field Value

Boolean

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarSolutionFilter.SortBestOrder Field

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter..::SortBestOrder Field
Use best solution order, otherwise iteration order

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SortBestOrder
Public SortBestOrder As Boolean
Dim instance As OptVarSolutionFilter
Dim value As Boolean

value = instance.SortBestOrder

instance.SortBestOrder = value

Field Value

Boolean

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarSolutionFilter Methods

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter Methods

The OptVarSolutionFilter type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptVarStatistics Class
Optimization variable statistics. These summarize the statistics for a single optimization variable in the current Optimization. They are based upon the selected statistics filter.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptVarStatistics
Public Class OptVarStatistics
Dim instance As OptVarStatistics

Members

All Members | Fields | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Maximum | Maximum value
Mean | Mean of values
Minimum | Minimum value
RhsStatistics | Right hand side statistics
SolutionCount | Count of solutions that affected these stats
StdDev | Standard Deviation of values
Sum | Sum of values
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Variance of values

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVarStatistics

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics Fields

Visual Basic Usage

CB Com Devkit
OptVarStatistics Fields

The OptVarStatistics type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Maximum | Maximum value
Mean | Mean of values
Minimum | Minimum value
SolutionCount | Count of solutions that affected these stats
StdDev | Standard Deviation of values
Sum | Sum of values
Variance | Variance of values

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics.Maximum Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::Maximum Field
Maximum value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Maximum
Public Maximum As Double
Dim instance As OptVarStatistics
Dim value As Double

value = instance.Maximum

instance.Maximum = value

Field Value

Double

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics.Mean Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::Mean Field
Mean of values

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Mean
Public Mean As Double
Dim instance As OptVarStatistics
Dim value As Double

value = instance.Mean

instance.Mean = value

Field Value

Double

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics.Minimum Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::Minimum Field
Minimum value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Minimum
Public Minimum As Double
Dim instance As OptVarStatistics
Dim value As Double

value = instance.Minimum

instance.Minimum = value

Field Value

Double

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics.SolutionCount Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::SolutionCount Field
Count of solutions that affected these stats

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SolutionCount
Public SolutionCount As Integer
Dim instance As OptVarStatistics
Dim value As Integer

value = instance.SolutionCount

instance.SolutionCount = value

Field Value

Int32

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics.StdDev Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::StdDev Field
Standard Deviation of values

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StdDev
Public StdDev As Double
Dim instance As OptVarStatistics
Dim value As Double

value = instance.StdDev

instance.StdDev = value

Field Value

Double

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics.Sum Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::Sum Field
Sum of values

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Sum
Public Sum As Double
Dim instance As OptVarStatistics
Dim value As Double

value = instance.Sum

instance.Sum = value

Field Value

Double

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics.Variance Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::Variance Field
Variance of values

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Variance
Public Variance As Double
Dim instance As OptVarStatistics
Dim value As Double

value = instance.Variance

instance.Variance = value

Field Value

Double

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics Methods

Visual Basic Usage

CB Com Devkit
OptVarStatistics Methods

The OptVarStatistics type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics Properties

Visual Basic Usage

CB Com Devkit
OptVarStatistics Properties

The OptVarStatistics type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RhsStatistics | Right hand side statistics

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics.RhsStatistics Property

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::RhsStatistics Property
Right hand side statistics

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptVarStatistics RhsStatistics { get; internal set; }
Public Property RhsStatistics As OptVarStatistics
    Get
    Friend Set
Dim instance As OptVarStatistics
Dim value As OptVarStatistics

value = instance.RhsStatistics

Property Value

OptVarStatistics

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ReqEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
ReqEnumerator Class
Requirement var enumerator class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class ReqEnumerator : VarEnumerator
Public Class ReqEnumerator
    Inherits VarEnumerator
Dim instance As ReqEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumeration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Delete(Int32) | Delete the object at specified index
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..ReqEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ReqEnumerator Methods

Visual Basic Usage

CB Com Devkit
ReqEnumerator Methods

The ReqEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Delete(Int32) | Delete the object at specified index
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReqEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ReqEnumerator.Delete Method

Visual Basic Usage

CB Com Devkit
ReqEnumerator..::Delete Method
Delete the object at specified index

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Delete(
    int index
)
Public Function Delete (
    index As Integer
) As Boolean
Dim instance As ReqEnumerator
Dim index As Integer
Dim returnValue As Boolean

returnValue = instance.Delete(index)

Parameters

index
Int32
index to use

Return Value

Boolean
Was object deleted

See Also

ReqEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ReqEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
ReqEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As ReqEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
Was enumeration successfully reloaded

Implements

IVarEnumerator..::..Reload()()()()

See Also

ReqEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ReqEnumerator Properties

Visual Basic Usage

CB Com Devkit
ReqEnumerator Properties

The ReqEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumeration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

ReqEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ReqEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
ReqEnumerator..::Current Property
Returns the current variable in the enumeration (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As ReqEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

ReqEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ReqEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
ReqEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Requirement this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Requirement
    Get
Dim instance As ReqEnumerator
Dim index As Integer
Dim value As Requirement

value = instance(index)

Parameters

index
Int32

Property Value

Requirement

See Also

ReqEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
Requirement Class
Requirement class is responsible for handling all requirement related operations.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class Requirement : ObjReqBase
Public Class Requirement
    Inherits ObjReqBase
Dim instance As Requirement

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member Description
AbbreviatedName
Requirement abbreviated name in a string form (note it doesn't include the forecast)
Comment
Var comment
(Inherited from OptVar.)
Condition
Requirement condition, one of values defined in the OptConditionType enumeration Every requirement has to have Condition specified. For example, the requirement "The Mean of Forecast1 must be greater than 100.00 inch" has a Condition equal to OptConditionType.GreaterThan.
ConditionValue1
ConditionValue1 is used to define the condition in requirement equation. Here are the rules on the ConditionValue1 usage: - For all statistics except for the Probability and the Between condition, ConditionValue1 is used to represent the right side of the requirements equation. Example: "The Minimum of Forecast1 must be greater than 100.00 inch" requirement has ConditionValue1 equal to 100, - For between condition it's used to represent the lower boundary of the between range. For example, requirement "The Standard Deviation of Forecast1 must be between 1.00 and 2.00 inch" has ConditionValue1 equal to 1 and ConditionValue2 equal to 2, - For the probability it's used to define the probability percentile value in range [0, 100]. So, the requirement "A 95% Probability or more that Forecast1 is less than 15.00 inch" has ConditionValue1 equal to 95.
ConditionValue2
ConditionValue2 is used to define the upper boundary for the requirement that has Between condition, for all other requirements it's ignored. So, the requirement "The Skewness of Forecast1 must be between 0 and 0.1" has ConditionValue1 equal to 0 and ConditionValue2 equal to 0.1.
DisplayName
Var display name
(Inherited from OptVar.)
EFDisplayName
Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier)
(Inherited from OptVar.)
Equals(Object)
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Equation
The Requirement equation as a read-only value.
Exclude
Is var excluded
(Inherited from OptVar.)
Forecast
Get / Set the Requirement forecast range. This value is an Excel range that refers to the Forecast used in the objective equation.
FullAbbreviatedName
Requirement abbreviated name in a string form, including the requirement forecast
GetHashCode()()()()
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType()()()()
Gets the Type of the current instance.
(Inherited from Object.)
MoreLessCondition
MoreLessCondition defines the more/less condition for this requirement, specified with one of the values in the OptMoreLessCondition enumeration. It is used only for Probability and Chance statistics. For Probability it represents the upper boundary of the specified range when Between Condition is used. For example, the requirement "A 95% Probability or less that Forecast1 is between 90 and 95" has StatisticValue2 equal to 95. For Certainty it also represents the upper boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the second chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.
OptimizationStatistics
Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter.
(Inherited from OptVar.)
Statistic
Access to requirement Statistic. This is a statistic from the Forecast value used in the Objective equation.
StatisticValue1
StatisticValue1 defines the first statistic value for the requirement. It is used only for Percentile, Probability, Certainty and Chance statistics. For Percentile statistic, it represents the numeric percentile value in range [0, 100]. For example, the requirement "The 91% Percentile of Forecast1 must be less than 100.00 inch" has StatisticValue1 equal to 91. For Probability it represents the lower boundary of the specified range. For example, the requirement "A 95% Probability or more that Forecast1 is less than 20" has StatisticValue1 equal to 20. For Certainty it also represents the lower boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the first chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.
StatisticValue2
StatisticValue2 defines the second statistic value for the requirement. It is used only for Probability, Certainty and Chance statistics. For Probability it represents the upper boundary of the specified range when Between Condition is used. For example, the requirement "A 95% Probability or less that Forecast1 is between 90 and 95" has StatisticValue2 equal to 95. For Certainty it also represents the upper boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the second chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.
ToString()()()()
Returns a string that represents the current object.
(Inherited from Object.)
Validate()()()()
Validate the requirement, sets the error code if not valid

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVar
Decisioneering.CB.CBCOMDevKit.Optimization..::..ObjReqBase
Decisioneering.CB.CBCOMDevKit.Optimization..::..Requirement

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement Methods

Visual Basic Usage

CB Com Devkit
Requirement Methods

The Requirement type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate the requirement, sets the error code if not valid

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement.Validate Method

Visual Basic Usage

CB Com Devkit
Requirement..::Validate Method
Validate the requirement, sets the error code if not valid

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As Requirement
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

Boolean
True if OK, false if requirent is not valid

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement Properties

Visual Basic Usage

CB Com Devkit
Requirement Properties

The Requirement type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member Description
AbbreviatedName
Requirement abbreviated name in a string form (note it doesn't include the forecast)
Comment
Var comment
(Inherited from OptVar.)
Condition
Requirement condition, one of values defined in the OptConditionType enumeration Every requirement has to have Condition specified. For example, the requirement "The Mean of Forecast1 must be greater than 100.00 inch" has a Condition equal to OptConditionType.GreaterThan.
ConditionValue1
ConditionValue1 is used to define the condition in requirement equation. Here are the rules on the ConditionValue1 usage: - For all statistics except for the Probability and the Between condition, ConditionValue1 is used to represent the right side of the requirements equation. Example: "The Minimum of Forecast1 must be greater than 100.00 inch" requirement has ConditionValue1 equal to 100, - For between condition it's used to represent the lower boundary of the between range. For example, requirement "The Standard Deviation of Forecast1 must be between 1.00 and 2.00 inch" has ConditionValue1 equal to 1 and ConditionValue2 equal to 2, - For the probability it's used to define the probability percentile value in range [0, 100]. So, the requirement "A 95% Probability or more that Forecast1 is less than 15.00 inch" has ConditionValue1 equal to 95.
ConditionValue2
ConditionValue2 is used to define the upper boundary for the requirement that has Between condition, for all other requirements it's ignored. So, the requirement "The Skewness of Forecast1 must be between 0 and 0.1" has ConditionValue1 equal to 0 and ConditionValue2 equal to 0.1.
DisplayName
Var display name
(Inherited from OptVar.)
EFDisplayName
Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier)
(Inherited from OptVar.)
Equation
The Requirement equation as a read-only value.
Exclude
Is var excluded
(Inherited from OptVar.)
Forecast
Get / Set the Requirement forecast range. This value is an Excel range that refers to the Forecast used in the objective equation.
FullAbbreviatedName
Requirement abbreviated name in a string form, including the requirement forecast
MoreLessCondition
MoreLessCondition defines the more/less condition for this requirement, specified with one of the values in the OptMoreLessCondition enumeration. It is used only for Probability and Chance statistics. For Probability it represents the upper boundary of the specified range when Between Condition is used. For example, the requirement "A 95% Probability or less that Forecast1 is between 90 and 95" has StatisticValue2 equal to 95. For Certainty it also represents the upper boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the second chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.
OptimizationStatistics
Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter.
(Inherited from OptVar.)
Statistic
Access to requirement Statistic. This is a statistic from the Forecast value used in the Objective equation.
StatisticValue1
StatisticValue1 defines the first statistic value for the requirement. It is used only for Percentile, Probability, Certainty and Chance statistics. For Percentile statistic, it represents the numeric percentile value in range [0, 100]. For example, the requirement "The 91% Percentile of Forecast1 must be less than 100.00 inch" has StatisticValue1 equal to 91. For Probability it represents the lower boundary of the specified range. For example, the requirement "A 95% Probability or more that Forecast1 is less than 20" has StatisticValue1 equal to 20. For Certainty it also represents the lower boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the first chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.
StatisticValue2
StatisticValue2 defines the second statistic value for the requirement. It is used only for Probability, Certainty and Chance statistics. For Probability it represents the upper boundary of the specified range when Between Condition is used. For example, the requirement "A 95% Probability or less that Forecast1 is between 90 and 95" has StatisticValue2 equal to 95. For Certainty it also represents the upper boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the second chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement.AbbreviatedName Property

Visual Basic Usage

CB Com Devkit
Requirement..::AbbreviatedName Property
Requirement abbreviated name in a string form (note it doesn't include the forecast)

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string AbbreviatedName { get; }
Public ReadOnly Property AbbreviatedName As String
    Get
Dim instance As Requirement
Dim value As String

value = instance.AbbreviatedName

Property Value

String

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement.Condition Property

Visual Basic Usage

CB Com Devkit
Requirement..::Condition Property
Requirement condition, one of values defined in the OptConditionType enumeration Every requirement has to have Condition specified. For example, the requirement "The Mean of Forecast1 must be greater than 100.00 inch" has a Condition equal to OptConditionType.GreaterThan.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptConditionType Condition { get; set; }
Public Property Condition As OptConditionType
    Get
    Set
Dim instance As Requirement
Dim value As OptConditionType

value = instance.Condition

instance.Condition = value

Property Value

OptConditionType

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement.ConditionValue1 Property

Visual Basic Usage

CB Com Devkit
Requirement..::ConditionValue1 Property
ConditionValue1 is used to define the condition in requirement equation. Here are the rules on the ConditionValue1 usage: - For all statistics except for the Probability and the Between condition, ConditionValue1 is used to represent the right side of the requirements equation. Example: "The Minimum of Forecast1 must be greater than 100.00 inch" requirement has ConditionValue1 equal to 100, - For between condition it's used to represent the lower boundary of the between range. For example, requirement "The Standard Deviation of Forecast1 must be between 1.00 and 2.00 inch" has ConditionValue1 equal to 1 and ConditionValue2 equal to 2, - For the probability it's used to define the probability percentile value in range [0, 100]. So, the requirement "A 95% Probability or more that Forecast1 is less than 15.00 inch" has ConditionValue1 equal to 95.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ConditionValue1 { get; set; }
Public Property ConditionValue1 As Double
    Get
    Set
Dim instance As Requirement
Dim value As Double

value = instance.ConditionValue1

instance.ConditionValue1 = value

Property Value

Double

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement.ConditionValue2 Property

Visual Basic Usage

CB Com Devkit
Requirement..::ConditionValue2 Property
ConditionValue2 is used to define the upper boundary for the requirement that has Between condition, for all other requirements it's ignored. So, the requirement "The Skewness of Forecast1 must be between 0 and 0.1" has ConditionValue1 equal to 0 and ConditionValue2 equal to 0.1.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ConditionValue2 { get; set; }
Public Property ConditionValue2 As Double
    Get
    Set
Dim instance As Requirement
Dim value As Double

value = instance.ConditionValue2

instance.ConditionValue2 = value

Property Value

Double

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement.Equation Property

Visual Basic Usage

CB Com Devkit
Requirement..::Equation Property
The Requirement equation as a read-only value.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Equation { get; protected set; }
Public Property Equation As String
    Get
    Protected Set
Dim instance As Requirement
Dim value As String

value = instance.Equation

instance.Equation = value

Property Value

String

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement.Forecast Property

Visual Basic Usage

CB Com Devkit
Requirement..::Forecast Property
Get / Set the Requirement forecast range. This value is an Excel range that refers to the Forecast used in the objective equation.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range Forecast { get; set; }
Public Property Forecast As Range
    Get
    Set
Dim instance As Requirement
Dim value As Range

value = instance.Forecast

instance.Forecast = value

Property Value

Range

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement.FullAbbreviatedName Property

Visual Basic Usage

CB Com Devkit
Requirement..::FullAbbreviatedName Property
Requirement abbreviated name in a string form, including the requirement forecast

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string FullAbbreviatedName { get; }
Public ReadOnly Property FullAbbreviatedName As String
    Get
Dim instance As Requirement
Dim value As String

value = instance.FullAbbreviatedName

Property Value

String

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement.MoreLessCondition Property

Visual Basic Usage

CB Com Devkit
Requirement..::MoreLessCondition Property
MoreLessCondition defines the more/less condition for this requirement, specified with one of the values in the OptMoreLessCondition enumeration. It is used only for Probability and Chance statistics. For Probability it represents the upper boundary of the specified range when Between Condition is used. For example, the requirement "A 95% Probability or less that Forecast1 is between 90 and 95" has StatisticValue2 equal to 95. For Certainty it also represents the upper boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the second chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptMoreLessCondition MoreLessCondition { get; set; }
Public Property MoreLessCondition As OptMoreLessCondition
    Get
    Set
Dim instance As Requirement
Dim value As OptMoreLessCondition

value = instance.MoreLessCondition

instance.MoreLessCondition = value

Property Value

OptMoreLessCondition

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement.Statistic Property

Visual Basic Usage

CB Com Devkit
Requirement..::Statistic Property
Access to requirement Statistic. This is a statistic from the Forecast value used in the Objective equation.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSupportedStatistics Statistic { get; set; }
Public Property Statistic As OptSupportedStatistics
    Get
    Set
Dim instance As Requirement
Dim value As OptSupportedStatistics

value = instance.Statistic

instance.Statistic = value

Property Value

OptSupportedStatistics

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement.StatisticValue1 Property

Visual Basic Usage

CB Com Devkit
Requirement..::StatisticValue1 Property
StatisticValue1 defines the first statistic value for the requirement. It is used only for Percentile, Probability, Certainty and Chance statistics. For Percentile statistic, it represents the numeric percentile value in range [0, 100]. For example, the requirement "The 91% Percentile of Forecast1 must be less than 100.00 inch" has StatisticValue1 equal to 91. For Probability it represents the lower boundary of the specified range. For example, the requirement "A 95% Probability or more that Forecast1 is less than 20" has StatisticValue1 equal to 20. For Certainty it also represents the lower boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the first chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StatisticValue1 { get; set; }
Public Property StatisticValue1 As Double
    Get
    Set
Dim instance As Requirement
Dim value As Double

value = instance.StatisticValue1

instance.StatisticValue1 = value

Property Value

Double

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement.StatisticValue2 Property

Visual Basic Usage

CB Com Devkit
Requirement..::StatisticValue2 Property
StatisticValue2 defines the second statistic value for the requirement. It is used only for Probability, Certainty and Chance statistics. For Probability it represents the upper boundary of the specified range when Between Condition is used. For example, the requirement "A 95% Probability or less that Forecast1 is between 90 and 95" has StatisticValue2 equal to 95. For Certainty it also represents the upper boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the second chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StatisticValue2 { get; set; }
Public Property StatisticValue2 As Double
    Get
    Set
Dim instance As Requirement
Dim value As Double

value = instance.StatisticValue2

instance.StatisticValue2 = value

Property Value

Double

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
ResultsWindow Class
The OptQuest Results Window

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class ResultsWindow
Public Class ResultsWindow
Dim instance As ResultsWindow

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChartType | Set / Get the current chart type in the Best Solution view.
CurrentTestPoint | The current Efficient Frontier test point number. This selects a specific Test Point. This value can only be changed after an Optimization is executed. Setting this value will effect solution lists and feasibility for all solutions based upon this new test point. The value may be from 1 to number of Test Points.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCellValue(ResultsWindow..::..GridType, Int32, Int32) | Returns the displayed value within the grid at the column and row location specified.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ShowAllSolutions | Set / Get whether all solutions should be shown on the performance chart.
ShowAllTestPoints | Specify if only best Efficient Frontier solutions should be shown in the OptQuest Results window
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
View | Set / Get the current active view.
Visible | Set / Get whether the form is visible

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..ResultsWindow

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow Methods

Visual Basic Usage

CB Com Devkit
ResultsWindow Methods

The ResultsWindow type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCellValue(ResultsWindow..::..GridType, Int32, Int32) | Returns the displayed value within the grid at the column and row location specified.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.GetCellValue Method

Visual Basic Usage

CB Com Devkit
ResultsWindow..::GetCellValue Method
Returns the displayed value within the grid at the column and row location specified.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string GetCellValue(
    ResultsWindow..::..GridType gridType,
    int columnIndex,
    int rowIndex
)
Public Function GetCellValue (
    gridType As ResultsWindow..::..GridType,
    columnIndex As Integer,
    rowIndex As Integer
) As String
Dim instance As ResultsWindow
Dim gridType As ResultsWindow..::..GridType
Dim columnIndex As Integer
Dim rowIndex As Integer
Dim returnValue As String

returnValue = instance.GetCellValue(gridType,
    columnIndex, rowIndex)

Parameters

gridType
ResultsWindow..::..GridType
The grid to search within.
columnIndex
Int32
The column index (1-based)
rowIndex
Int32
The row index (1-based)

Return Value

String
The text as displayed in the cell.

Remarks

If the gridType passed in is not on the current View, then the View is changed to ensure that the grid is visible. The column and row index values are 1-based. Row and column headers are considered within the indexes. If the Results Window is not currenlty visible, it will become visible

Exceptions

Exception | Condition
CBExceptionIDGridInvalidRowOrColumnIndex | The value of the row or column index is invalid

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow Properties

Visual Basic Usage

CB Com Devkit
ResultsWindow Properties

The ResultsWindow type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChartType | Set / Get the current chart type in the Best Solution view.
CurrentTestPoint | The current Efficient Frontier test point number. This selects a specific Test Point. This value can only be changed after an Optimization is executed. Setting this value will effect solution lists and feasibility for all solutions based upon this new test point. The value may be from 1 to number of Test Points.
ShowAllSolutions | Set / Get whether all solutions should be shown on the performance chart.
ShowAllTestPoints | Specify if only best Efficient Frontier solutions should be shown in the OptQuest Results window
View | Set / Get the current active view.
Visible | Set / Get whether the form is visible

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.ChartType Property

Visual Basic Usage

CB Com Devkit
ResultsWindow..::ChartType Property
Set / Get the current chart type in the Best Solution view.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ResultsWindow..::..BestSolutionChartType ChartType { get; set; }
Public Property ChartType As ResultsWindow..::..BestSolutionChartType
    Get
    Set
Dim instance As ResultsWindow
Dim value As ResultsWindow..::..BestSolutionChartType

value = instance.ChartType

instance.ChartType = value

Property Value

ResultsWindow..::..BestSolutionChartType

Remarks

If the Results Window is not currenlty visible, it will become visible. The Best Solution view will become active when setting this property.

Exceptions

Exception | Condition
CBExceptionIDOptNotInEfficientFrontierMode | Setting to EfficientFrontierChart when not running an Efficient Frontier

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.CurrentTestPoint Property

Visual Basic Usage

CB Com Devkit
ResultsWindow..::CurrentTestPoint Property
The current Efficient Frontier test point number. This selects a specific Test Point. This value can only be changed after an Optimization is executed. Setting this value will effect solution lists and feasibility for all solutions based upon this new test point. The value may be from 1 to number of Test Points.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int CurrentTestPoint { get; set; }
Public Property CurrentTestPoint As Integer
    Get
    Set
Dim instance As ResultsWindow
Dim value As Integer

value = instance.CurrentTestPoint

instance.CurrentTestPoint = value

Property Value

Int32

Remarks

If the Results Window is not currenlty visible, it will become visible

Exceptions

Exception | Condition
CBExceptionIDOptNotInEfficientFrontierMode | Property not applicable when not running an Efficient Frontier

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.ShowAllSolutions Property

Visual Basic Usage

CB Com Devkit
ResultsWindow..::ShowAllSolutions Property
Set / Get whether all solutions should be shown on the performance chart.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowAllSolutions { get; set; }
Public Property ShowAllSolutions As Boolean
    Get
    Set
Dim instance As ResultsWindow
Dim value As Boolean

value = instance.ShowAllSolutions

instance.ShowAllSolutions = value

Property Value

Boolean

Remarks

If the Results Window is not currenlty visible, it will become visible. The Best Solution view will become active when setting this property.

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.ShowAllTestPoints Property

Visual Basic Usage

CB Com Devkit
ResultsWindow..::ShowAllTestPoints Property
Specify if only best Efficient Frontier solutions should be shown in the OptQuest Results window

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowAllTestPoints { get; set; }
Public Property ShowAllTestPoints As Boolean
    Get
    Set
Dim instance As ResultsWindow
Dim value As Boolean

value = instance.ShowAllTestPoints

instance.ShowAllTestPoints = value

Property Value

Boolean

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.View Property

Visual Basic Usage

CB Com Devkit
ResultsWindow..::View Property
Set / Get the current active view.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ResultsWindow..::..ResultsWindowViewType View { get; set; }
Public Property View As ResultsWindow..::..ResultsWindowViewType
    Get
    Set
Dim instance As ResultsWindow
Dim value As ResultsWindow..::..ResultsWindowViewType

value = instance.View

instance.View = value

Property Value

ResultsWindow..::..ResultsWindowViewType

Remarks

If the Results Window is not currenlty visible, it will become visible

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.Visible Property

Visual Basic Usage

CB Com Devkit
ResultsWindow..::Visible Property
Set / Get whether the form is visible

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
Dim instance As ResultsWindow
Dim value As Boolean

value = instance.Visible

instance.Visible = value

Property Value

Boolean

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.BestSolutionChartType Enumeration

Visual Basic Usage

CB Com Devkit
ResultsWindow..::..BestSolutionChartType Enumeration
Chart type within the Best Solution view enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum BestSolutionChartType
Public Enumeration BestSolutionChartType
Dim instance As ResultsWindow.BestSolutionChartType

Members

Member | Value | Description
PerformanceChart | 0 | The Performance chart
EfficientFrontierChart | 1 | The Efficient Frontier chart

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.GridType Enumeration

Visual Basic Usage

CB Com Devkit
ResultsWindow..::..GridType Enumeration
The Grid type enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum GridType
Public Enumeration GridType
Dim instance As ResultsWindow.GridType

Members

Member | Value | Description
Objective | 0 | The Objective grid on the Best Solution view
Requirement | 1 | The Requirement grid on the Best Solution view
Constraint | 2 | The Constraint grid on the Best Solution view
DecVar | 3 | The DecVar grid on the Best Solution view
Solutions | 4 | The Solutions grid on the Solutions Analysis view
Statistics | 5 | The Statistics grid on the Solutions Analysis view

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.ResultsWindowViewType Enumeration

Visual Basic Usage

CB Com Devkit
ResultsWindow..::..ResultsWindowViewType Enumeration
Window view enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum ResultsWindowViewType
Public Enumeration ResultsWindowViewType
Dim instance As ResultsWindow.ResultsWindowViewType

Members

Member | Value | Description
BestSolution | 0 | The Best Solution view
SolutionAnalysis | 1 | The Solution Analysis view

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RuntimeEfficientFrontier Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
RuntimeEfficientFrontier Class
Optimization runtime information for Efficient Frontier. Efficient Frontier allows users to create a variable list of constraint and requirement RHS (right hand side) values using a list of test points.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class RuntimeEfficientFrontier
Public Class RuntimeEfficientFrontier
Dim instance As RuntimeEfficientFrontier

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CurrentTestPoint | The current Efficient Frontier test point number. This selects a specific Test Point. This value can only be changed after an Optimization is executed. Setting this value will effect solution lists and feasibility for all solutions based upon this new test point. The value may be from 1 to number of Test Points.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IsEfficientFrontierRun | Has an Efficient Frontier optimization been run.
TestPointCount | The count of Efficient Frontier Test Points. Even if an Efficient Frontier Test Point range is currently defined, the count of actual values to test is returned.
TestPointInfo(Int32) | Get the Efficient Frontier Test Point results information. Includes best solution for that test point, feasibility and test point start index.
TestPointList | The list of Efficient Frontier Test Points. Even if an Efficient Frontier Test Point range is currently defined, a list of actual values to test is returned.
TestPointValue | The current Efficient Frontier Test Point value. This is the currently selected Efficient Frontier test point value. To modify after an Optimization is run, set the EFTestPointNumber.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..RuntimeEfficientFrontier

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RuntimeEfficientFrontier Methods

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier Methods

The RuntimeEfficientFrontier type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
TestPointInfo(Int32) | Get the Efficient Frontier Test Point results information. Includes best solution for that test point, feasibility and test point start index.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RuntimeEfficientFrontier.TestPointInfo Method

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier..::TestPointInfo Method
Get the Efficient Frontier Test Point results information. Includes best solution for that test point, feasibility and test point start index.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TestPointInfo TestPointInfo(
    [OptionalAttribute] int testPointNumber
)
Public Function TestPointInfo (
    <OptionalAttribute> testPointNumber As Integer
) As TestPointInfo
Dim instance As RuntimeEfficientFrontier
Dim testPointNumber As Integer
Dim returnValue As TestPointInfo

returnValue = instance.TestPointInfo(testPointNumber)

Parameters

testPointNumber (Optional)
Int32
The Efficient Frontier Test Point number, 1 based value. Default is to use the currently selected Test Point.

Return Value

TestPointInfo
The Test Point information

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RuntimeEfficientFrontier Properties

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier Properties

The RuntimeEfficientFrontier type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CurrentTestPoint | The current Efficient Frontier test point number. This selects a specific Test Point. This value can only be changed after an Optimization is executed. Setting this value will effect solution lists and feasibility for all solutions based upon this new test point. The value may be from 1 to number of Test Points.
IsEfficientFrontierRun | Has an Efficient Frontier optimization been run.
TestPointCount | The count of Efficient Frontier Test Points. Even if an Efficient Frontier Test Point range is currently defined, the count of actual values to test is returned.
TestPointList | The list of Efficient Frontier Test Points. Even if an Efficient Frontier Test Point range is currently defined, a list of actual values to test is returned.
TestPointValue | The current Efficient Frontier Test Point value. This is the currently selected Efficient Frontier test point value. To modify after an Optimization is run, set the EFTestPointNumber.

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RuntimeEfficientFrontier.CurrentTestPoint Property

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier..::CurrentTestPoint Property
The current Efficient Frontier test point number. This selects a specific Test Point. This value can only be changed after an Optimization is executed. Setting this value will effect solution lists and feasibility for all solutions based upon this new test point. The value may be from 1 to number of Test Points.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int CurrentTestPoint { get; set; }
Public Property CurrentTestPoint As Integer
    Get
    Set
Dim instance As RuntimeEfficientFrontier
Dim value As Integer

value = instance.CurrentTestPoint

instance.CurrentTestPoint = value

Property Value

Int32

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RuntimeEfficientFrontier.IsEfficientFrontierRun Property

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier..::IsEfficientFrontierRun Property
Has an Efficient Frontier optimization been run.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsEfficientFrontierRun { get; }
Public ReadOnly Property IsEfficientFrontierRun As Boolean
    Get
Dim instance As RuntimeEfficientFrontier
Dim value As Boolean

value = instance.IsEfficientFrontierRun

Property Value

Boolean

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RuntimeEfficientFrontier.TestPointCount Property

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier..::TestPointCount Property
The count of Efficient Frontier Test Points. Even if an Efficient Frontier Test Point range is currently defined, the count of actual values to test is returned.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int TestPointCount { get; }
Public ReadOnly Property TestPointCount As Integer
    Get
Dim instance As RuntimeEfficientFrontier
Dim value As Integer

value = instance.TestPointCount

Property Value

Int32

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RuntimeEfficientFrontier.TestPointList Property

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier..::TestPointList Property
The list of Efficient Frontier Test Points. Even if an Efficient Frontier Test Point range is currently defined, a list of actual values to test is returned.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double[] TestPointList { get; }
Public ReadOnly Property TestPointList As Double()
    Get
Dim instance As RuntimeEfficientFrontier
Dim value As Double()

value = instance.TestPointList

Property Value

array< Double >[]()[][]

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RuntimeEfficientFrontier.TestPointValue Property

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier..::TestPointValue Property
The current Efficient Frontier Test Point value. This is the currently selected Efficient Frontier test point value. To modify after an Optimization is run, set the EFTestPointNumber.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TestPointValue { get; }
Public ReadOnly Property TestPointValue As Double
    Get
Dim instance As RuntimeEfficientFrontier
Dim value As Double

value = instance.TestPointValue

Property Value

Double

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SolutionListSort Enumeration

Visual Basic Usage

CB Com Devkit
SolutionListSort Enumeration
Possible sort orders for solution lists

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum SolutionListSort
Public Enumeration SolutionListSort
Dim instance As SolutionListSort

Members

Member | Value | Description
IterationOrder | 0 | In order by iteration (not sorted)
BestOrder | 1 | In order by best solution first

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SolutionStatus Enumeration

Visual Basic Usage

CB Com Devkit
SolutionStatus Enumeration
The status of the solution, including the state of the simulation if run.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum SolutionStatus
Public Enumeration SolutionStatus
Dim instance As SolutionStatus

Members

Member | Value | Description
CompletedSimulation | 0 | The simulation was completed
StoppedOnObjectiveLowConfidence | 1 | The simultion stopped because an objective low-confidence condition was detected.
NonLinearInfeasible | 2 | One or more non-linear constraints were infeasible, no simulation was run.
StoppedOnPrecision | 3 | The simulation stopped because forecast precision was met for one or more forecasts.
StoppedOnError | 4 | Stopped due an error occurring

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SolutionValueType Enumeration

Visual Basic Usage

CB Com Devkit
SolutionValueType Enumeration
Type of value for a solution equation variable

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum SolutionValueType
Public Enumeration SolutionValueType
Dim instance As SolutionValueType

Members

Member | Value | Description
Default | 0 | Default value
LeftHandSide | 1 | Left hand side equation value
RightHandSide | 2 | Right hand side equation value

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TerminationReason Enumeration

Visual Basic Usage

CB Com Devkit
TerminationReason Enumeration
Optimization Termination reasons

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum TerminationReason
Public Enumeration TerminationReason
Dim instance As TerminationReason

Members

Member | Value | Description
NotStarted | 0 | Optimization has not started
Running | 1 | The optimization is still running
LP | 3 | Linear progression
AutoStop | 4 | The auto stop feature was activated
OptimalFound | 5 | The optimal solution has been found
MaxIterations | 6 | The maximum number of iterations has been completed
MaxTime | 7 | The maximum time has been run
UserStopped | 8 | Stopped by the user
BestFound | 9 | The best solutionhas been found
OnException | 10 | An error occurred
SolutionDatabaseFull | 100 | The solution database is full
ConstraintsInfeasible | 12 | The constraints are invalid (-1201)

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointInfo Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
TestPointInfo Class
Optimization Test Point Information for an Efficient frontier. This information summarizes the results for a single test point.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class TestPointInfo
Public Class TestPointInfo
Dim instance As TestPointInfo

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BestObjectiveFeasibility | The best objective Feasibility for this test point.
BestSolution | The best solution for this test point. See TestPointInfo.BestObjectiveFeasibility for the correct Feasibility at this test point.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
StartIterationIndex | The first optimization iteration index for this test point.
TestPointIndex | The test point index (which test point from the test point list).
TestPointValue | The test point value (test point value from the test point list).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..TestPointInfo

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointInfo Methods

Visual Basic Usage

CB Com Devkit
TestPointInfo Methods

The TestPointInfo type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointInfo Properties

Visual Basic Usage

CB Com Devkit
TestPointInfo Properties

The TestPointInfo type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BestObjectiveFeasibility | The best objective Feasibility for this test point.
BestSolution | The best solution for this test point. See TestPointInfo.BestObjectiveFeasibility for the correct Feasibility at this test point.
StartIterationIndex | The first optimization iteration index for this test point.
TestPointIndex | The test point index (which test point from the test point list).
TestPointValue | The test point value (test point value from the test point list).

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointInfo.BestObjectiveFeasibility Property

Visual Basic Usage

CB Com Devkit
TestPointInfo..::BestObjectiveFeasibility Property
The best objective Feasibility for this test point.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool BestObjectiveFeasibility { get; }
Public ReadOnly Property BestObjectiveFeasibility As Boolean
    Get
Dim instance As TestPointInfo
Dim value As Boolean

value = instance.BestObjectiveFeasibility

Property Value

Boolean

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointInfo.BestSolution Property

Visual Basic Usage

CB Com Devkit
TestPointInfo..::BestSolution Property
The best solution for this test point. See TestPointInfo.BestObjectiveFeasibility for the correct Feasibility at this test point.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSolution BestSolution { get; }
Public ReadOnly Property BestSolution As OptSolution
    Get
Dim instance As TestPointInfo
Dim value As OptSolution

value = instance.BestSolution

Property Value

OptSolution

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointInfo.StartIterationIndex Property

Visual Basic Usage

CB Com Devkit
TestPointInfo..::StartIterationIndex Property
The first optimization iteration index for this test point.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int StartIterationIndex { get; }
Public ReadOnly Property StartIterationIndex As Integer
    Get
Dim instance As TestPointInfo
Dim value As Integer

value = instance.StartIterationIndex

Property Value

Int32

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointInfo.TestPointIndex Property

Visual Basic Usage

CB Com Devkit
TestPointInfo..::TestPointIndex Property
The test point index (which test point from the test point list).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int TestPointIndex { get; }
Public ReadOnly Property TestPointIndex As Integer
    Get
Dim instance As TestPointInfo
Dim value As Integer

value = instance.TestPointIndex

Property Value

Int32

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointInfo.TestPointValue Property

Visual Basic Usage

CB Com Devkit
TestPointInfo..::TestPointValue Property
The test point value (test point value from the test point list).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TestPointValue { get; }
Public ReadOnly Property TestPointValue As Double
    Get
Dim instance As TestPointInfo
Dim value As Double

value = instance.TestPointValue

Property Value

Double

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
VarEnumerator Class
Base var enumerator class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public abstract class VarEnumerator : IVarEnumerator,
    IEnumerable, IEnumerator
Public MustInherit Class VarEnumerator
    Implements IVarEnumerator, IEnumerable, IEnumerator
Dim instance As VarEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type.
Current | Returns the current variable in the enumeration (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified.
Reload()()()() | Reload / resync the collection
Reset()()()() | Resets method required by IEnumerator (resets to first variable).
SelectedCount | Returns the count of non excluded variables of the specified type.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..ConEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..DecEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..ObjEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptSolutionEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..ReqEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator Methods

Visual Basic Usage

CB Com Devkit
VarEnumerator Methods

The VarEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified.
Reload()()()() | Reload / resync the collection
Reset()()()() | Resets method required by IEnumerator (resets to first variable).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator.GetEnumerator Method

Visual Basic Usage

CB Com Devkit
VarEnumerator..::GetEnumerator Method
Returns an enumerator for these variables.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As VarEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

IEnumerator
variable enumerator

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator.MoveNext Method

Visual Basic Usage

CB Com Devkit
VarEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As VarEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

Boolean
Can we move to next collection object

Implements

IEnumerator..::..MoveNext()()()()

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
VarEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As VarEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
Was enumeration successfully reloaded

Implements

IVarEnumerator..::..Reload()()()()

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator.Reset Method

Visual Basic Usage

CB Com Devkit
VarEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first variable).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As VarEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator Properties

Visual Basic Usage

CB Com Devkit
VarEnumerator Properties

The VarEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type.
Current | Returns the current variable in the enumeration (required by IEnumerator).
SelectedCount | Returns the count of non excluded variables of the specified type.

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
VarEnumerator..::Count Property
Returns the count of variables of the specified type.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As VarEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

Implements

IVarEnumerator..::..Count

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
VarEnumerator..::Current Property
Returns the current variable in the enumeration (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public abstract Object Current { get; }
Public MustOverride ReadOnly Property Current As Object
    Get
Dim instance As VarEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator.SelectedCount Property

Visual Basic Usage

CB Com Devkit
VarEnumerator..::SelectedCount Property
Returns the count of non excluded variables of the specified type.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int SelectedCount { get; }
Public Overridable ReadOnly Property SelectedCount As Integer
    Get
Dim instance As VarEnumerator
Dim value As Integer

value = instance.SelectedCount

Property Value

Int32

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decisioneering.CB.CBCOMDevKit.Predictor Namespace

Visual Basic Usage

CB Com Devkit
Decisioneering.CB.CBCOMDevKit.Predictor Namespace
Predictor COM and .NET Development Kit Namespace

Types

All Types | Classes | Interfaces | Enumerations
Name | Description
ARIMAModelEnumerator | List of custom ARIMA models (only for Custom ARIMA).
EventRecurrenceEnum | Event repeat type
IObjectEnumerator | Base interface for the Predictor series and method enumerators.
IPredLagEnumerator | Interface for the PredLag object Enumerator.
MethodEnumerator | List of available methods for selected series.
PredAdjustForecast | Main interface to forecast adjustment settings. Provides access to forecast adjustment settings such as percentile, rounding, adjust by value, and value range restriction.
PredAdjustForecastPercentileType | Adjust forecast percentile options.
PredAdjustForecastRoundType | Adjust forecast rounding options.
PredARIMABoxCoxTransformation | Type of Box-Cox transformation to be applied.
PredARIMAConstant | Handle constant in ARIMA equation.
PredARIMAModel | Main interface to ARIMA model.
PredARIMAModelSelection | ARIMA model selection type
PredARIMAModelSelectionCriterion | Criterion for selection among ARIMA models. Used in automatic ARIMA.
PredConfidenceType | Confidence interval options.
PredDataAttributes | Main interface for data attribute setting corresponding the the Predictor wizard Data Attributes panel. This lets you control items such as seasonality, screening and outlier detection.
PredDateType | Recognized Date types for the date series.
PredErrorMeasureType | Error measure options.
PredEvent | The main interface to event details.
PredEventDate | The main interface to event date occurrence details.
PredEventDateEnumerator | Access to the current list of dates for the event.
PredEventEnumerator | Access to the current list of events.
PredForecastingTechnique | Forecasting technique options.
PredForecastMethodType | Forecast method options.
PredictorGridType | Statistics Grid type options
PredictorViewType | Window view options.
PredInputData | Main interface to input data properties corresponding the the Predictor wizard Input Data panel. This lets you control items such as data orientation and headers.
PredInputDataOrientation | Input data oriantation options.
PredLag | Lag information interface. Provides access to autocorrelation lag details.
PredLagEnumerator | List of autocorrelation lags.
PredMethods | Main interface to methods settings corresponding the Predictor Methods panel. This lets you control what methods to use and method parameters.
PredMissingValueFillInMethod | Missing values missing values fill in methods.
PredNeighborInterpolationStatistic | Statistic used for neighbor interpolation.
PredOptions | Main interface to predictor options corresponding to the Predictor Options panel. This povides access to options such as error measure and forecasting technique.
PredOutlierDetectionMethod | Outlier detection methods.
PredRegression | Series regression variable settings. Provides access to regression variable settings such as independent/dependent, lag, and exclude.
PredRegressionMethod | Regression method options.
PredResults | Predictor Results. Provides an interface to access predictor run results. This is the top level interface class that provides access to objects to retrieve results available through the Predictor results form.
PredResultsPreferences | Main interface to results persistant preferences. Provides access to preferences such as confidence interval, forcast periods, statistics grid display, and error measure display.
PredResultsWindow | Interface for the Predictor Results Window. Provides access to the results window and allows setting items such as selected series and method.
PredSeasonality | Series seasonality settings. Provides access to series seasonality settings such as seasonality type and seasonal cycle.
PredSeasonalityType | Seasonality type options.
PredSeries | The main interface to input series specific settings. This provides access to information such as series name, Excel number format, seasonality and cycle, regression variable details, statistics, and series data values.
PredSeriesEnumerator | List of series in input data set.
PredSeriesResult | The main interface to output series specific settings. This provides access to information such as series name, Excel number format, forecast adjustments, statistics, and series data values.
PredSeriesResultEnumerator | List of series in results set.
PredSetup | Predictor Setup / Definition Provides an interface to define a predictor run. This is the top level interface class that provides access to objects to set and define all predictor settings available through the wizard
PredStatistics | Main interface to series statistics.


ARIMAModelEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
ARIMAModelEnumerator Class
List of custom ARIMA models (only for Custom ARIMA).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class ARIMAModelEnumerator : IObjectEnumerator,
    IEnumerable, IEnumerator
Public Class ARIMAModelEnumerator
    Implements IObjectEnumerator, IEnumerable, IEnumerator
Dim instance As ARIMAModelEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get ARIMAModel by index.
MoveNext()()()() | Declares the MoveNext ARIMAModel required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets ARIMAModel required by IEnumerator (resets to first series).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..ARIMAModelEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelEnumerator Methods

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator Methods

The ARIMAModelEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext ARIMAModel required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets ARIMAModel required by IEnumerator (resets to first series).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelEnumerator.GetEnumerator Method

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::GetEnumerator Method
Returns an enumerator for these series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As ARIMAModelEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

IEnumerator
the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelEnumerator.MoveNext Method

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::MoveNext Method
Declares the MoveNext ARIMAModel required by IEnumerator; returns the next valid series

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As ARIMAModelEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

Boolean
true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As ARIMAModelEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
true if successful

Implements

IObjectEnumerator..::..Reload()()()()

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelEnumerator.Reset Method

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::Reset Method
Resets ARIMAModel required by IEnumerator (resets to first series).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As ARIMAModelEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelEnumerator Properties

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator Properties

The ARIMAModelEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Item[([( Int32])]) | Get ARIMAModel by index.

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::Count Property
Returns the series count

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As ARIMAModelEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

Implements

IObjectEnumerator..::..Count

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::Current Property
Returns the current series (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As ARIMAModelEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::Item Property
Get ARIMAModel by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMAModel this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As PredARIMAModel
    Get
Dim instance As ARIMAModelEnumerator
Dim index As Integer
Dim value As PredARIMAModel

value = instance(index)

Parameters

index
Int32

Return Value

PredARIMAModel

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


EventRecurrenceEnum Enumeration

Visual Basic Usage

CB Com Devkit
EventRecurrenceEnum Enumeration
Event repeat type

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum EventRecurrenceEnum
Public Enumeration EventRecurrenceEnum
Dim instance As EventRecurrenceEnum

Members

Member | Value | Description
RepeatsNever | 0 | Event never repeats
RepeatsEvery | 1 | Event repeats in fixed periods
RepeatsCustomDates | 2 | Event repeats in customly defined intervals

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IObjectEnumerator Interface

Visual Basic Usage

| Members | See Also
CB Com Devkit
IObjectEnumerator Interface
Base interface for the Predictor series and method enumerators.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public interface IObjectEnumerator : IEnumerable,
    IEnumerator
Public Interface IObjectEnumerator
    Inherits IEnumerable, IEnumerator
Dim instance As IObjectEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of series in collection.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IObjectEnumerator Methods

Visual Basic Usage

CB Com Devkit
IObjectEnumerator Methods

The IObjectEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

IObjectEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IObjectEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
IObjectEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
bool Reload()
Function Reload As Boolean
Dim instance As IObjectEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
true if successful

See Also

IObjectEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IObjectEnumerator Properties

Visual Basic Usage

CB Com Devkit
IObjectEnumerator Properties

The IObjectEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of series in collection.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)

See Also

IObjectEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IObjectEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
IObjectEnumerator..::Count Property
Returns the count of series in collection.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
int Count { get; }
ReadOnly Property Count As Integer
    Get
Dim instance As IObjectEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

See Also

IObjectEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IPredLagEnumerator Interface

Visual Basic Usage

| Members | See Also
CB Com Devkit
IPredLagEnumerator Interface
Interface for the PredLag object Enumerator.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public interface IPredLagEnumerator : IEnumerable,
    IEnumerator
Public Interface IPredLagEnumerator
    Inherits IEnumerable, IEnumerator
Dim instance As IPredLagEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of lags in collection.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IPredLagEnumerator Methods

Visual Basic Usage

CB Com Devkit
IPredLagEnumerator Methods

The IPredLagEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

IPredLagEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IPredLagEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
IPredLagEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
bool Reload()
Function Reload As Boolean
Dim instance As IPredLagEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
true if successful

See Also

IPredLagEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IPredLagEnumerator Properties

Visual Basic Usage

CB Com Devkit
IPredLagEnumerator Properties

The IPredLagEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of lags in collection.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)

See Also

IPredLagEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IPredLagEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
IPredLagEnumerator..::Count Property
Returns the count of lags in collection.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
int Count { get; }
ReadOnly Property Count As Integer
    Get
Dim instance As IPredLagEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

See Also

IPredLagEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
MethodEnumerator Class
List of available methods for selected series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class MethodEnumerator : IObjectEnumerator,
    IEnumerable, IEnumerator
Public Class MethodEnumerator
    Implements IObjectEnumerator, IEnumerable, IEnumerator
Dim instance As MethodEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get method by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..MethodEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator Methods

Visual Basic Usage

CB Com Devkit
MethodEnumerator Methods

The MethodEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator.GetEnumerator Method

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::GetEnumerator Method
Returns an enumerator for these series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As MethodEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

IEnumerator
the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator.MoveNext Method

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid series

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As MethodEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

Boolean
true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As MethodEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
true if successful

Implements

IObjectEnumerator..::..Reload()()()()

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator.Reset Method

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first series).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As MethodEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator Properties

Visual Basic Usage

CB Com Devkit
MethodEnumerator Properties

The MethodEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Item[([( Int32])]) | Get method by index.

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::Count Property
Returns the series count

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As MethodEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

Implements

IObjectEnumerator..::..Count

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::Current Property
Returns the current series (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As MethodEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::Item Property
Get method by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastMethodType this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As PredForecastMethodType
    Get
Dim instance As MethodEnumerator
Dim index As Integer
Dim value As PredForecastMethodType

value = instance(index)

Parameters

index
Int32

Return Value

PredForecastMethodType

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredAdjustForecast Class
Main interface to forecast adjustment settings. Provides access to forecast adjustment settings such as percentile, rounding, adjust by value, and value range restriction.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredAdjustForecast
Public Class PredAdjustForecast
Dim instance As PredAdjustForecast

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjustByValue | Adjust forecast by value.
ApplyToAll()()()() | Apply forecast adjustments for this series to all series.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Percentile | Forecast adjustment percentile type. Default is P_Median.
PercentileCustomValue | Precentile adjustment custom value. This value is used if Percentile is set to P_Custom.
PercentileValue | Adjustment percentile value.
RestrictMax | Restrict forecast values to maximum value.
RestrictMin | Restrict forecast values to minimum value.
Round | Round forecast values to type. Default is NoRounding.
RoundCustomValue | Custom rounding round to digits value. This is used if Round is set to Custom.
RoundValue | Round to digits value. Default is 0 for no rounding.
SetDefault()()()() | Reset to forecast adjustment defaults - no adjustment.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredAdjustForecast

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast Methods

Visual Basic Usage

CB Com Devkit
PredAdjustForecast Methods

The PredAdjustForecast type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ApplyToAll()()()() | Apply forecast adjustments for this series to all series.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SetDefault()()()() | Reset to forecast adjustment defaults - no adjustment.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast.ApplyToAll Method

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::ApplyToAll Method
Apply forecast adjustments for this series to all series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ApplyToAll()
Public Sub ApplyToAll
Dim instance As PredAdjustForecast

instance.ApplyToAll()

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast.SetDefault Method

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::SetDefault Method
Reset to forecast adjustment defaults - no adjustment.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SetDefault()
Public Sub SetDefault
Dim instance As PredAdjustForecast

instance.SetDefault()

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast Properties

Visual Basic Usage

CB Com Devkit
PredAdjustForecast Properties

The PredAdjustForecast type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjustByValue | Adjust forecast by value.
Percentile | Forecast adjustment percentile type. Default is P_Median.
PercentileCustomValue | Precentile adjustment custom value. This value is used if Percentile is set to P_Custom.
PercentileValue | Adjustment percentile value.
RestrictMax | Restrict forecast values to maximum value.
RestrictMin | Restrict forecast values to minimum value.
Round | Round forecast values to type. Default is NoRounding.
RoundCustomValue | Custom rounding round to digits value. This is used if Round is set to Custom.
RoundValue | Round to digits value. Default is 0 for no rounding.

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast.AdjustByValue Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::AdjustByValue Property
Adjust forecast by value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double AdjustByValue { get; set; }
Public Property AdjustByValue As Double
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As Double

value = instance.AdjustByValue

instance.AdjustByValue = value

Property Value

Double

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast.Percentile Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::Percentile Property
Forecast adjustment percentile type. Default is P_Median.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredAdjustForecastPercentileType Percentile { get; set; }
Public Property Percentile As PredAdjustForecastPercentileType
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As PredAdjustForecastPercentileType

value = instance.Percentile

instance.Percentile = value

Property Value

PredAdjustForecastPercentileType

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast.PercentileCustomValue Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::PercentileCustomValue Property
Precentile adjustment custom value. This value is used if Percentile is set to P_Custom.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double PercentileCustomValue { get; set; }
Public Property PercentileCustomValue As Double
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As Double

value = instance.PercentileCustomValue

instance.PercentileCustomValue = value

Property Value

Double

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast.PercentileValue Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::PercentileValue Property
Adjustment percentile value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double PercentileValue { get; }
Public ReadOnly Property PercentileValue As Double
    Get
Dim instance As PredAdjustForecast
Dim value As Double

value = instance.PercentileValue

Property Value

Double

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast.RestrictMax Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::RestrictMax Property
Restrict forecast values to maximum value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RestrictMax { get; set; }
Public Property RestrictMax As Double
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As Double

value = instance.RestrictMax

instance.RestrictMax = value

Property Value

Double

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast.RestrictMin Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::RestrictMin Property
Restrict forecast values to minimum value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RestrictMin { get; set; }
Public Property RestrictMin As Double
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As Double

value = instance.RestrictMin

instance.RestrictMin = value

Property Value

Double

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast.Round Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::Round Property
Round forecast values to type. Default is NoRounding.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredAdjustForecastRoundType Round { get; set; }
Public Property Round As PredAdjustForecastRoundType
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As PredAdjustForecastRoundType

value = instance.Round

instance.Round = value

Property Value

PredAdjustForecastRoundType

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast.RoundCustomValue Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::RoundCustomValue Property
Custom rounding round to digits value. This is used if Round is set to Custom.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int RoundCustomValue { get; set; }
Public Property RoundCustomValue As Integer
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As Integer

value = instance.RoundCustomValue

instance.RoundCustomValue = value

Property Value

Int32

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast.RoundValue Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::RoundValue Property
Round to digits value. Default is 0 for no rounding.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int RoundValue { get; }
Public ReadOnly Property RoundValue As Integer
    Get
Dim instance As PredAdjustForecast
Dim value As Integer

value = instance.RoundValue

Property Value

Int32

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecastPercentileType Enumeration

Visual Basic Usage

CB Com Devkit
PredAdjustForecastPercentileType Enumeration
Adjust forecast percentile options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredAdjustForecastPercentileType
Public Enumeration PredAdjustForecastPercentileType
Dim instance As PredAdjustForecastPercentileType

Members

Member | Value | Description
P_Median | 0 | Median percentile forecast adjustment
P_5 | 1 | 5th percentile forecast adjustment
P_10 | 2 | 10th percentile forecast adjustment
P_20 | 3 | 20th percentile forecast adjustment
P_80 | 4 | 80th percentile forecast adjustment
P_90 | 5 | 90th percentile forecast adjustment
P_95 | 6 | 95th percentile forecast adjustment
P_Custom | 7 | Custom percentile forecast adjustment

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecastRoundType Enumeration

Visual Basic Usage

CB Com Devkit
PredAdjustForecastRoundType Enumeration
Adjust forecast rounding options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredAdjustForecastRoundType
Public Enumeration PredAdjustForecastRoundType
Dim instance As PredAdjustForecastRoundType

Members

Member | Value | Description
NoRounding | 0 | No forecast adjustment rounding
Integers | 1 | Round to integers
Tens | 2 | Round to tens
Hundreds | 3 | Round to hundreds
Thousands | 4 | Round to thousands
Custom | 5 | Custom rounding

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMABoxCoxTransformation Enumeration

Visual Basic Usage

CB Com Devkit
PredARIMABoxCoxTransformation Enumeration
Type of Box-Cox transformation to be applied.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredARIMABoxCoxTransformation
Public Enumeration PredARIMABoxCoxTransformation
Dim instance As PredARIMABoxCoxTransformation

Members

Member | Value | Description
Optimize | 0 | Use optimized value.
Logarithmic | 1 | Logarithmic transformation.
SquareRoot | 2 | Square root transformation.
CustomLambda | 3 | Custom lambda value.
None | 4 | No transformation.

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAConstant Enumeration

Visual Basic Usage

CB Com Devkit
PredARIMAConstant Enumeration
Handle constant in ARIMA equation.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredARIMAConstant
Public Enumeration PredARIMAConstant
Dim instance As PredARIMAConstant

Members

Member | Value | Description
AutoSelect | 0 | AutoSelect: automatically decide to include or exclude ARIMA constant in the model.
Always | 1 | Always: include constant in the ARIMA equation.
Never | 2 | Never: exclude constant from the ARIMA equation.

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredARIMAModel Class
Main interface to ARIMA model.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredARIMAModel
Public Class PredARIMAModel
Dim instance As PredARIMAModel

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PredARIMAModel()()()() | Default constructor is internal since this class is not intended to be created as a standalone class
ARIMANonSeasonalAROrder | Non-seasonal AR order, the p component of ARIMA(p, d, q). Has to be inside [0, 10]
ARIMANonSeasonalDifference | Non-seasonal difference, the d component of ARIMA(p, d, q). Has to be inside [0, 10]
ARIMANonSeasonalMAOrder | Non-seasonal MA order, the q component of ARIMA(p, d, q). Has to be inside [0, 10]
ARIMASeasonalAROrder | Seasonal AR order, the P component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]
ARIMASeasonalDifference | Seasonal difference, the D component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]
ARIMASeasonalMAOrder | Seasonal MA order, the Q component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IsSeasonal | Returns true if model is seasonal
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate ARIMA model settings.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredARIMAModel

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel Constructor

Visual Basic Usage

CB Com Devkit
PredARIMAModel Constructor
Default constructor is internal since this class is not intended to be created as a standalone class

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMAModel()
Public Sub New
Dim instance As New PredARIMAModel()

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel Methods

Visual Basic Usage

CB Com Devkit
PredARIMAModel Methods

The PredARIMAModel type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate ARIMA model settings.

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel.Validate Method

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::Validate Method
Validate ARIMA model settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredARIMAModel
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

Boolean
true if successful

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel Properties

Visual Basic Usage

CB Com Devkit
PredARIMAModel Properties

The PredARIMAModel type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ARIMANonSeasonalAROrder | Non-seasonal AR order, the p component of ARIMA(p, d, q). Has to be inside [0, 10]
ARIMANonSeasonalDifference | Non-seasonal difference, the d component of ARIMA(p, d, q). Has to be inside [0, 10]
ARIMANonSeasonalMAOrder | Non-seasonal MA order, the q component of ARIMA(p, d, q). Has to be inside [0, 10]
ARIMASeasonalAROrder | Seasonal AR order, the P component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]
ARIMASeasonalDifference | Seasonal difference, the D component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]
ARIMASeasonalMAOrder | Seasonal MA order, the Q component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]
IsSeasonal | Returns true if model is seasonal

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel.ARIMANonSeasonalAROrder Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::ARIMANonSeasonalAROrder Property
Non-seasonal AR order, the p component of ARIMA(p, d, q). Has to be inside [0, 10]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMANonSeasonalAROrder { get; set; }
Public Property ARIMANonSeasonalAROrder As Integer
    Get
    Set
Dim instance As PredARIMAModel
Dim value As Integer

value = instance.ARIMANonSeasonalAROrder

instance.ARIMANonSeasonalAROrder = value

Property Value

Int32

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel.ARIMANonSeasonalDifference Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::ARIMANonSeasonalDifference Property
Non-seasonal difference, the d component of ARIMA(p, d, q). Has to be inside [0, 10]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMANonSeasonalDifference { get; set; }
Public Property ARIMANonSeasonalDifference As Integer
    Get
    Set
Dim instance As PredARIMAModel
Dim value As Integer

value = instance.ARIMANonSeasonalDifference

instance.ARIMANonSeasonalDifference = value

Property Value

Int32

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel.ARIMANonSeasonalMAOrder Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::ARIMANonSeasonalMAOrder Property
Non-seasonal MA order, the q component of ARIMA(p, d, q). Has to be inside [0, 10]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMANonSeasonalMAOrder { get; set; }
Public Property ARIMANonSeasonalMAOrder As Integer
    Get
    Set
Dim instance As PredARIMAModel
Dim value As Integer

value = instance.ARIMANonSeasonalMAOrder

instance.ARIMANonSeasonalMAOrder = value

Property Value

Int32

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel.ARIMASeasonalAROrder Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::ARIMASeasonalAROrder Property
Seasonal AR order, the P component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMASeasonalAROrder { get; set; }
Public Property ARIMASeasonalAROrder As Integer
    Get
    Set
Dim instance As PredARIMAModel
Dim value As Integer

value = instance.ARIMASeasonalAROrder

instance.ARIMASeasonalAROrder = value

Property Value

Int32

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel.ARIMASeasonalDifference Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::ARIMASeasonalDifference Property
Seasonal difference, the D component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMASeasonalDifference { get; set; }
Public Property ARIMASeasonalDifference As Integer
    Get
    Set
Dim instance As PredARIMAModel
Dim value As Integer

value = instance.ARIMASeasonalDifference

instance.ARIMASeasonalDifference = value

Property Value

Int32

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel.ARIMASeasonalMAOrder Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::ARIMASeasonalMAOrder Property
Seasonal MA order, the Q component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMASeasonalMAOrder { get; set; }
Public Property ARIMASeasonalMAOrder As Integer
    Get
    Set
Dim instance As PredARIMAModel
Dim value As Integer

value = instance.ARIMASeasonalMAOrder

instance.ARIMASeasonalMAOrder = value

Property Value

Int32

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel.IsSeasonal Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::IsSeasonal Property
Returns true if model is seasonal

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsSeasonal { get; }
Public ReadOnly Property IsSeasonal As Boolean
    Get
Dim instance As PredARIMAModel
Dim value As Boolean

value = instance.IsSeasonal

Property Value

Boolean

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModelSelection Enumeration

Visual Basic Usage

CB Com Devkit
PredARIMAModelSelection Enumeration
ARIMA model selection type

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredARIMAModelSelection
Public Enumeration PredARIMAModelSelection
Dim instance As PredARIMAModelSelection

Members

Member | Value | Description
Automatic | 0 | Automatic model selected
Custom | 1 | Custom model selected

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModelSelectionCriterion Enumeration

Visual Basic Usage

CB Com Devkit
PredARIMAModelSelectionCriterion Enumeration
Criterion for selection among ARIMA models. Used in automatic ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredARIMAModelSelectionCriterion
Public Enumeration PredARIMAModelSelectionCriterion
Dim instance As PredARIMAModelSelectionCriterion

Members

Member | Value | Description
BIC | 0 | Minimize Bayesian Information Criterion
AIC | 1 | Minimize Akaike Information Criterion
AICc | 2 | Minimize Corrected AIC
ErrorMeasure | 3 | Minimize selected error measure

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredConfidenceType Enumeration

Visual Basic Usage

CB Com Devkit
PredConfidenceType Enumeration
Confidence interval options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredConfidenceType
Public Enumeration PredConfidenceType
Dim instance As PredConfidenceType

Members

Member | Value | Description
CI_None | 0 | None
CI_80 | 1 | 80% confidence interval, corresponds to 10% and 90% limits
CI_90 | 2 | 90% confidence interval, corresponds to 5% and 95% limits
CI_95 | 3 | 95% confidence interval, corresponds to 2.5% and 97.5% limits
CI_99 | 4 | 99% confidence interval, corresponds to 0.5% and 99.5% limits
CI_Custom | 5 | Custom confidence interval

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredDataAttributes Class
Main interface for data attribute setting corresponding the the Predictor wizard Data Attributes panel. This lets you control items such as seasonality, screening and outlier detection.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredDataAttributes
Public Class PredDataAttributes
Dim instance As PredDataAttributes

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddEvent(String, Int32, Int32, EventRecurrenceEnum, Int32, Int32) | Adds an event to the list, returns the event index.
AdjustOutliers | Will outlier adjustment will be used.
DateType | Selected date type for the selected date series.
DeleteAllEvents()()()() | Delete allexisting events.
DeleteEvent(Int32) | Deletes the existing event.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EventFuturePeriods | Number of future periods to include in events. Has to be a positive integer less or equal to 1000.
Events | The list of currently defined events.
FillInMissingValues | Will missing values in the input data be filled in using the selected MissingValueFillInMethod. Must be set to true to work with data that has missing values.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IncludeEvents | Defines if events are used.
InterQuartileDeviations | Number of InterQuartile deviations to use for the MedianAndIQD OutlierDetectionMethod.
MedianAbsoluteDeviations | Number of median absolute deviations to use for the MedianAndMAD OutlierDetectionMethod.
MissingValueFillInMethod | The missing value fillin method to use.
NeighborInterpolationStatistic | Statistic to use for the NeighborInterpolationMethod
NeighborsOnEitherSide | Number of neighbors to factor into the NeighborInterpolationMethod
OutlierDetectionMethod | The outlier detection method to use.
ReloadEvents | Initiate the re-loading of events.
SeasonalityType | Seasonality type. Seasonal, non-seasonal, or Autodetect to have predictor detect based on the data.
StandardDeviations | Number of standard deviations to use for the MeanAndStdDev OutlierDetectionMethod.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate all data attribute settings.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredDataAttributes

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes Methods

Visual Basic Usage

CB Com Devkit
PredDataAttributes Methods

The PredDataAttributes type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddEvent(String, Int32, Int32, EventRecurrenceEnum, Int32, Int32) | Adds an event to the list, returns the event index.
DeleteAllEvents()()()() | Delete allexisting events.
DeleteEvent(Int32) | Deletes the existing event.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate all data attribute settings.

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.AddEvent Method

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::AddEvent Method
Adds an event to the list, returns the event index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int AddEvent(
    string Name,
    int StartDate,
    int Duration,
    EventRecurrenceEnum RepeatsType,
    int RepeatInterval = -1,
    int SeriesIndex = -1
)
Public Function AddEvent (
    Name As String,
    StartDate As Integer,
    Duration As Integer,
    RepeatsType As EventRecurrenceEnum,
    Optional RepeatInterval As Integer = -1,
    Optional SeriesIndex As Integer = -1
) As Integer
Dim instance As PredDataAttributes
Dim Name As String
Dim StartDate As Integer
Dim Duration As Integer
Dim RepeatsType As EventRecurrenceEnum
Dim RepeatInterval As Integer
Dim SeriesIndex As Integer
Dim returnValue As Integer

returnValue = instance.AddEvent(Name,
    StartDate, Duration, RepeatsType,
    RepeatInterval, SeriesIndex)

Parameters

Name
String
Name of the event
StartDate
Int32
: Start Date of the event (integer period index)
Duration
Int32
Duration of the event (in integer period units)
RepeatsType
EventRecurrenceEnum
Defines how the event repeats
RepeatInterval (Optional)
Int32
Defines the event repeat interval
SeriesIndex (Optional)
Int32
Optional series index for the local event

Return Value

Int32
Returns the index of a new event, -1 if error

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.DeleteAllEvents Method

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::DeleteAllEvents Method
Delete allexisting events.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void DeleteAllEvents()
Public Sub DeleteAllEvents
Dim instance As PredDataAttributes

instance.DeleteAllEvents()

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.DeleteEvent Method

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::DeleteEvent Method
Deletes the existing event.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void DeleteEvent(
    int EventIndex
)
Public Sub DeleteEvent (
    EventIndex As Integer
)
Dim instance As PredDataAttributes
Dim EventIndex As Integer

instance.DeleteEvent(EventIndex)

Parameters

EventIndex
Int32
Index of the event to be deleted

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.Validate Method

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::Validate Method
Validate all data attribute settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredDataAttributes
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

Boolean
true if successful

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes Properties

Visual Basic Usage

CB Com Devkit
PredDataAttributes Properties

The PredDataAttributes type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjustOutliers | Will outlier adjustment will be used.
DateType | Selected date type for the selected date series.
EventFuturePeriods | Number of future periods to include in events. Has to be a positive integer less or equal to 1000.
Events | The list of currently defined events.
FillInMissingValues | Will missing values in the input data be filled in using the selected MissingValueFillInMethod. Must be set to true to work with data that has missing values.
IncludeEvents | Defines if events are used.
InterQuartileDeviations | Number of InterQuartile deviations to use for the MedianAndIQD OutlierDetectionMethod.
MedianAbsoluteDeviations | Number of median absolute deviations to use for the MedianAndMAD OutlierDetectionMethod.
MissingValueFillInMethod | The missing value fillin method to use.
NeighborInterpolationStatistic | Statistic to use for the NeighborInterpolationMethod
NeighborsOnEitherSide | Number of neighbors to factor into the NeighborInterpolationMethod
OutlierDetectionMethod | The outlier detection method to use.
ReloadEvents | Initiate the re-loading of events.
SeasonalityType | Seasonality type. Seasonal, non-seasonal, or Autodetect to have predictor detect based on the data.
StandardDeviations | Number of standard deviations to use for the MeanAndStdDev OutlierDetectionMethod.

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.AdjustOutliers Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::AdjustOutliers Property
Will outlier adjustment will be used.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool AdjustOutliers { get; set; }
Public Property AdjustOutliers As Boolean
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Boolean

value = instance.AdjustOutliers

instance.AdjustOutliers = value

Property Value

Boolean

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.DateType Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::DateType Property
Selected date type for the selected date series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredDateType DateType { get; set; }
Public Property DateType As PredDateType
    Get
    Set
Dim instance As PredDataAttributes
Dim value As PredDateType

value = instance.DateType

instance.DateType = value

Property Value

PredDateType

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.EventFuturePeriods Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::EventFuturePeriods Property
Number of future periods to include in events. Has to be a positive integer less or equal to 1000.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int EventFuturePeriods { get; set; }
Public Property EventFuturePeriods As Integer
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Integer

value = instance.EventFuturePeriods

instance.EventFuturePeriods = value

Property Value

Int32

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.Events Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::Events Property
The list of currently defined events.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredEventEnumerator Events { get; }
Public ReadOnly Property Events As PredEventEnumerator
    Get
Dim instance As PredDataAttributes
Dim value As PredEventEnumerator

value = instance.Events

Property Value

PredEventEnumerator

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.FillInMissingValues Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::FillInMissingValues Property
Will missing values in the input data be filled in using the selected MissingValueFillInMethod. Must be set to true to work with data that has missing values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool FillInMissingValues { get; set; }
Public Property FillInMissingValues As Boolean
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Boolean

value = instance.FillInMissingValues

instance.FillInMissingValues = value

Property Value

Boolean

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.IncludeEvents Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::IncludeEvents Property
Defines if events are used.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IncludeEvents { get; set; }
Public Property IncludeEvents As Boolean
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Boolean

value = instance.IncludeEvents

instance.IncludeEvents = value

Property Value

Boolean

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.InterQuartileDeviations Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::InterQuartileDeviations Property
Number of InterQuartile deviations to use for the MedianAndIQD OutlierDetectionMethod.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double InterQuartileDeviations { get; set; }
Public Property InterQuartileDeviations As Double
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Double

value = instance.InterQuartileDeviations

instance.InterQuartileDeviations = value

Property Value

Double

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.MedianAbsoluteDeviations Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::MedianAbsoluteDeviations Property
Number of median absolute deviations to use for the MedianAndMAD OutlierDetectionMethod.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MedianAbsoluteDeviations { get; set; }
Public Property MedianAbsoluteDeviations As Double
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Double

value = instance.MedianAbsoluteDeviations

instance.MedianAbsoluteDeviations = value

Property Value

Double

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.MissingValueFillInMethod Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::MissingValueFillInMethod Property
The missing value fillin method to use.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredMissingValueFillInMethod MissingValueFillInMethod { get; set; }
Public Property MissingValueFillInMethod As PredMissingValueFillInMethod
    Get
    Set
Dim instance As PredDataAttributes
Dim value As PredMissingValueFillInMethod

value = instance.MissingValueFillInMethod

instance.MissingValueFillInMethod = value

Property Value

PredMissingValueFillInMethod

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.NeighborInterpolationStatistic Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::NeighborInterpolationStatistic Property
Statistic to use for the NeighborInterpolationMethod

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredNeighborInterpolationStatistic NeighborInterpolationStatistic { get; set; }
Public Property NeighborInterpolationStatistic As PredNeighborInterpolationStatistic
    Get
    Set
Dim instance As PredDataAttributes
Dim value As PredNeighborInterpolationStatistic

value = instance.NeighborInterpolationStatistic

instance.NeighborInterpolationStatistic = value

Property Value

PredNeighborInterpolationStatistic

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.NeighborsOnEitherSide Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::NeighborsOnEitherSide Property
Number of neighbors to factor into the NeighborInterpolationMethod

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NeighborsOnEitherSide { get; set; }
Public Property NeighborsOnEitherSide As Integer
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Integer

value = instance.NeighborsOnEitherSide

instance.NeighborsOnEitherSide = value

Property Value

Int32

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.OutlierDetectionMethod Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::OutlierDetectionMethod Property
The outlier detection method to use.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredOutlierDetectionMethod OutlierDetectionMethod { get; set; }
Public Property OutlierDetectionMethod As PredOutlierDetectionMethod
    Get
    Set
Dim instance As PredDataAttributes
Dim value As PredOutlierDetectionMethod

value = instance.OutlierDetectionMethod

instance.OutlierDetectionMethod = value

Property Value

PredOutlierDetectionMethod

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.ReloadEvents Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::ReloadEvents Property
Initiate the re-loading of events.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public static bool ReloadEvents { get; set; }
Public Shared Property ReloadEvents As Boolean
    Get
    Set
Dim value As Boolean

value = PredDataAttributes.ReloadEvents

PredDataAttributes.ReloadEvents = value

Property Value

Boolean

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.SeasonalityType Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::SeasonalityType Property
Seasonality type. Seasonal, non-seasonal, or Autodetect to have predictor detect based on the data.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeasonalityType SeasonalityType { get; set; }
Public Property SeasonalityType As PredSeasonalityType
    Get
    Set
Dim instance As PredDataAttributes
Dim value As PredSeasonalityType

value = instance.SeasonalityType

instance.SeasonalityType = value

Property Value

PredSeasonalityType

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes.StandardDeviations Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::StandardDeviations Property
Number of standard deviations to use for the MeanAndStdDev OutlierDetectionMethod.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StandardDeviations { get; set; }
Public Property StandardDeviations As Double
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Double

value = instance.StandardDeviations

instance.StandardDeviations = value

Property Value

Double

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDateType Enumeration

Visual Basic Usage

CB Com Devkit
PredDateType Enumeration
Recognized Date types for the date series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredDateType
Public Enumeration PredDateType
Dim instance As PredDateType

Members

Member | Value | Description
Periods | 0 | Period time intervals
Seconds | 1 | Second time intervals
Minutes | 2 | Minute time intervals
Hours | 3 | Hour time intervals
Days | 4 | Day time intervals
Workdays | 5 | Workday time intervals
Weeks | 6 | Week time intervals
Months | 7 | Month time intervals
Quarters | 8 | Quarter time intervals
Years | 9 | Year time intervals

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredErrorMeasureType Enumeration

Visual Basic Usage

CB Com Devkit
PredErrorMeasureType Enumeration
Error measure options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredErrorMeasureType
Public Enumeration PredErrorMeasureType
Dim instance As PredErrorMeasureType

Members

Member | Value | Description
RMSE | 0 | Root Mean Squared Error
MAD | 1 | Mean Absolute Deviation
MAPE | 2 | Mean Absolute Percent Error

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredEvent Class
The main interface to event details.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredEvent
Public Class PredEvent
Dim instance As PredEvent

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddCustomDate(Int32) | Adds a custom date. Should be used when EventRecurrenceEnum.RepeatsCustomDates option is selected.
CustomDates | Provides enumeration access by index into the custom dates collection
DatesOfOccurrence | Returns the string display for the list of all occurrence dates as shown in the events grid.
Duration | Defines the event duration.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Name | Defines the event name.
RemoveCustomDate(Int32) | Removes a custom start date. Should be used when EventRecurrenceEnum.RepeatsCustomDates option is selected.
RepeatInterval | Defines the event repeat interval
RepeatsType | Defines how the event repeats.
SeriesIndex | Defines the event series index for local events, -1 for global events
SetStartDate(Int32) | Update the event start date index
StartDate | Defines the event start date.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate event settings and store event.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredEvent

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent Methods

Visual Basic Usage

CB Com Devkit
PredEvent Methods

The PredEvent type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddCustomDate(Int32) | Adds a custom date. Should be used when EventRecurrenceEnum.RepeatsCustomDates option is selected.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
RemoveCustomDate(Int32) | Removes a custom start date. Should be used when EventRecurrenceEnum.RepeatsCustomDates option is selected.
SetStartDate(Int32) | Update the event start date index
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate event settings and store event.

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent.AddCustomDate Method

Visual Basic Usage

CB Com Devkit
PredEvent..::AddCustomDate Method
Adds a custom date. Should be used when EventRecurrenceEnum.RepeatsCustomDates option is selected.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int AddCustomDate(
    int DateInteger
)
Public Function AddCustomDate (
    DateInteger As Integer
) As Integer
Dim instance As PredEvent
Dim DateInteger As Integer
Dim returnValue As Integer

returnValue = instance.AddCustomDate(DateInteger)

Parameters

DateInteger
Int32
new event date

Return Value

Int32
Returns the index of the newly added custom date, -1 if wrong date is passed in.

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent.RemoveCustomDate Method

Visual Basic Usage

CB Com Devkit
PredEvent..::RemoveCustomDate Method
Removes a custom start date. Should be used when EventRecurrenceEnum.RepeatsCustomDates option is selected.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void RemoveCustomDate(
    int DateInteger
)
Public Sub RemoveCustomDate (
    DateInteger As Integer
)
Dim instance As PredEvent
Dim DateInteger As Integer

instance.RemoveCustomDate(DateInteger)

Parameters

DateInteger
Int32
defines event date

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent.SetStartDate Method

Visual Basic Usage

CB Com Devkit
PredEvent..::SetStartDate Method
Update the event start date index

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SetStartDate(
    int DateIndex
)
Public Function SetStartDate (
    DateIndex As Integer
) As Boolean
Dim instance As PredEvent
Dim DateIndex As Integer
Dim returnValue As Boolean

returnValue = instance.SetStartDate(DateIndex)

Parameters

DateIndex
Int32
Index for the event start date

Return Value

Boolean
Returns true if that is the valid start date

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent.Validate Method

Visual Basic Usage

CB Com Devkit
PredEvent..::Validate Method
Validate event settings and store event.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredEvent
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

Boolean
true if successful

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent Properties

Visual Basic Usage

CB Com Devkit
PredEvent Properties

The PredEvent type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CustomDates | Provides enumeration access by index into the custom dates collection
DatesOfOccurrence | Returns the string display for the list of all occurrence dates as shown in the events grid.
Duration | Defines the event duration.
Name | Defines the event name.
RepeatInterval | Defines the event repeat interval
RepeatsType | Defines how the event repeats.
SeriesIndex | Defines the event series index for local events, -1 for global events
StartDate | Defines the event start date.

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent.CustomDates Property

Visual Basic Usage

CB Com Devkit
PredEvent..::CustomDates Property
Provides enumeration access by index into the custom dates collection

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredEventDateEnumerator CustomDates { get; }
Public ReadOnly Property CustomDates As PredEventDateEnumerator
    Get
Dim instance As PredEvent
Dim value As PredEventDateEnumerator

value = instance.CustomDates

Property Value

PredEventDateEnumerator

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent.DatesOfOccurrence Property

Visual Basic Usage

CB Com Devkit
PredEvent..::DatesOfOccurrence Property
Returns the string display for the list of all occurrence dates as shown in the events grid.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string DatesOfOccurrence { get; }
Public ReadOnly Property DatesOfOccurrence As String
    Get
Dim instance As PredEvent
Dim value As String

value = instance.DatesOfOccurrence

Property Value

String

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent.Duration Property

Visual Basic Usage

CB Com Devkit
PredEvent..::Duration Property
Defines the event duration.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int Duration { get; set; }
Public Property Duration As Integer
    Get
    Set
Dim instance As PredEvent
Dim value As Integer

value = instance.Duration

instance.Duration = value

Property Value

Int32

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent.Name Property

Visual Basic Usage

CB Com Devkit
PredEvent..::Name Property
Defines the event name.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Dim instance As PredEvent
Dim value As String

value = instance.Name

instance.Name = value

Property Value

String

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent.RepeatInterval Property

Visual Basic Usage

CB Com Devkit
PredEvent..::RepeatInterval Property
Defines the event repeat interval

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int RepeatInterval { get; set; }
Public Property RepeatInterval As Integer
    Get
    Set
Dim instance As PredEvent
Dim value As Integer

value = instance.RepeatInterval

instance.RepeatInterval = value

Property Value

Int32

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent.RepeatsType Property

Visual Basic Usage

CB Com Devkit
PredEvent..::RepeatsType Property
Defines how the event repeats.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public EventRecurrenceEnum RepeatsType { get; set; }
Public Property RepeatsType As EventRecurrenceEnum
    Get
    Set
Dim instance As PredEvent
Dim value As EventRecurrenceEnum

value = instance.RepeatsType

instance.RepeatsType = value

Property Value

EventRecurrenceEnum

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent.SeriesIndex Property

Visual Basic Usage

CB Com Devkit
PredEvent..::SeriesIndex Property
Defines the event series index for local events, -1 for global events

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SeriesIndex { get; set; }
Public Property SeriesIndex As Integer
    Get
    Set
Dim instance As PredEvent
Dim value As Integer

value = instance.SeriesIndex

instance.SeriesIndex = value

Property Value

Int32

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent.StartDate Property

Visual Basic Usage

CB Com Devkit
PredEvent..::StartDate Property
Defines the event start date.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredEventDate StartDate { get; }
Public ReadOnly Property StartDate As PredEventDate
    Get
Dim instance As PredEvent
Dim value As PredEventDate

value = instance.StartDate

Property Value

PredEventDate

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDate Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredEventDate Class
The main interface to event date occurrence details.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredEventDate
Public Class PredEventDate
Dim instance As PredEventDate

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DateDisplay | Returns the date display string.
DateIndex | Defines the date index.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredEventDate

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDate Methods

Visual Basic Usage

CB Com Devkit
PredEventDate Methods

The PredEventDate type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredEventDate Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDate Properties

Visual Basic Usage

CB Com Devkit
PredEventDate Properties

The PredEventDate type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DateDisplay | Returns the date display string.
DateIndex | Defines the date index.

See Also

PredEventDate Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDate.DateDisplay Property

Visual Basic Usage

CB Com Devkit
PredEventDate..::DateDisplay Property
Returns the date display string.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string DateDisplay { get; }
Public ReadOnly Property DateDisplay As String
    Get
Dim instance As PredEventDate
Dim value As String

value = instance.DateDisplay

Property Value

String

See Also

PredEventDate Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDate.DateIndex Property

Visual Basic Usage

CB Com Devkit
PredEventDate..::DateIndex Property
Defines the date index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int DateIndex { get; set; }
Public Property DateIndex As Integer
    Get
    Set
Dim instance As PredEventDate
Dim value As Integer

value = instance.DateIndex

instance.DateIndex = value

Property Value

Int32

See Also

PredEventDate Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredEventDateEnumerator Class
Access to the current list of dates for the event.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredEventDateEnumerator : IObjectEnumerator,
    IEnumerable, IEnumerator
Public Class PredEventDateEnumerator
    Implements IObjectEnumerator, IEnumerable, IEnumerator
Dim instance As PredEventDateEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the total number of dates
Current | Returns the current date (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get date by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid date
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first date).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredEventDateEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator Methods

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator Methods

The PredEventDateEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid date
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first date).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator.GetEnumerator Method

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::GetEnumerator Method
Returns an enumerator for these series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As PredEventDateEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

IEnumerator
the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator.MoveNext Method

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid date

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As PredEventDateEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

Boolean
true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As PredEventDateEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
true if successful

Implements

IObjectEnumerator..::..Reload()()()()

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator.Reset Method

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first date).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As PredEventDateEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator Properties

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator Properties

The PredEventDateEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the total number of dates
Current | Returns the current date (required by IEnumerator).
Item[([( Int32])]) | Get date by index.

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::Count Property
Returns the total number of dates

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As PredEventDateEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

Implements

IObjectEnumerator..::..Count

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::Current Property
Returns the current date (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As PredEventDateEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::Item Property
Get date by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredEventDate this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As PredEventDate
    Get
Dim instance As PredEventDateEnumerator
Dim index As Integer
Dim value As PredEventDate

value = instance(index)

Parameters

index
Int32
the date index

Return Value

PredEventDate
returned date

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredEventEnumerator Class
Access to the current list of events.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredEventEnumerator : IObjectEnumerator,
    IEnumerable, IEnumerator
Public Class PredEventEnumerator
    Implements IObjectEnumerator, IEnumerable, IEnumerator
Dim instance As PredEventEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the events count
Current | Returns the current event.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these events.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get event by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid event
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first event).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredEventEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator Methods

Visual Basic Usage

CB Com Devkit
PredEventEnumerator Methods

The PredEventEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these events.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid event
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first event).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator.GetEnumerator Method

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::GetEnumerator Method
Returns an enumerator for these events.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As PredEventEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

IEnumerator
the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator.MoveNext Method

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid event

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As PredEventEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

Boolean
true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As PredEventEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
true if successful

Implements

IObjectEnumerator..::..Reload()()()()

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator.Reset Method

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first event).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As PredEventEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator Properties

Visual Basic Usage

CB Com Devkit
PredEventEnumerator Properties

The PredEventEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the events count
Current | Returns the current event.
Item[([( Int32])]) | Get event by index.

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::Count Property
Returns the events count

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As PredEventEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

Implements

IObjectEnumerator..::..Count

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::Current Property
Returns the current event.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As PredEventEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::Item Property
Get event by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredEvent this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As PredEvent
    Get
Dim instance As PredEventEnumerator
Dim index As Integer
Dim value As PredEvent

value = instance(index)

Parameters

index
Int32
index of the event

Return Value

PredEvent
returns the requested event

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredForecastingTechnique Enumeration

Visual Basic Usage

CB Com Devkit
PredForecastingTechnique Enumeration
Forecasting technique options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredForecastingTechnique
Public Enumeration PredForecastingTechnique
Dim instance As PredForecastingTechnique

Members

Member | Value | Description
Standard | 0 | Standard forecasting technique
SimpleLead | 1 | Simple lead forecasting technique
WeightedLead | 2 | Weighted lead forecasting technique
Holdout | 3 | Holdout forecasting technique

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredForecastMethodType Enumeration

Visual Basic Usage

CB Com Devkit
PredForecastMethodType Enumeration
Forecast method options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredForecastMethodType
Public Enumeration PredForecastMethodType
Dim instance As PredForecastMethodType

Members

Member | Value | Description
SingleMovingAverageMethod | 0 | Single Moving Average Method
DoubleMovingAverageMethod | 1 | Double Moving Average Method
SingleExponentialSmoothingMethod | 2 | Single Exponential Smoothing Method
DoubleExponentialSmoothingMethod | 3 | Double Exponential Smoothing Method
SeasonalAdditiveMethod | 4 | Additive Method
HoltWintersAdditiveMethod | 5 | Holt Winters Additive Method
SeasonalMultiplicativeMethod | 6 | Multiplicative Method
HoltWintersMultiplicativeMethod | 7 | Holt Winters Multiplicative Method
StandardRegressionMethod | 8 | Standard Regression Method
ForwardStepwiseRegressionMethod | 9 | Forward Stepwise Regression Method
IterativeStepwiseRegressionMethod | 10 | Iterative Stepwise Regression Method
CustomARIMAMethod | 11 | Custom ARIMA Method
AutomaticARIMAMethod | 12 | Automatic ARIMA Method

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredictorGridType Enumeration

Visual Basic Usage

CB Com Devkit
PredictorGridType Enumeration
Statistics Grid type options

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredictorGridType
Public Enumeration PredictorGridType
Dim instance As PredictorGridType

Members

Member | Value | Description
Data | 0 | The table view grid
DataStats | 1 | The Historical Data stats grid
ForecastStats | 2 | The Forecast stats grid
ParmStats | 3 | The DecVar grid on the Best Solution view

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredictorViewType Enumeration

Visual Basic Usage

CB Com Devkit
PredictorViewType Enumeration
Window view options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredictorViewType
Public Enumeration PredictorViewType
Dim instance As PredictorViewType

Members

Member | Value | Description
Chart | 0 | Chart view
Table | 1 | Table view

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredInputData Class
Main interface to input data properties corresponding the the Predictor wizard Input Data panel. This lets you control items such as data orientation and headers.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredInputData
Public Class PredInputData
Dim instance As PredInputData

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DataOrientation | Orientation of the detected range
DetectedRange | Acces to detected range
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
HasLeftHeader | HasLeftHeader is true if a detected range has left header
HasTopHeader | HasTopHeader is true if a detected range has top header
NumberOfDataPoints | Return the number of data points in detected range (series with no data are ignored)
NumberOfDataSeries | Return the number of data series in detected range
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate all input data settings.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredInputData

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData Methods

Visual Basic Usage

CB Com Devkit
PredInputData Methods

The PredInputData type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate all input data settings.

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData.Validate Method

Visual Basic Usage

CB Com Devkit
PredInputData..::Validate Method
Validate all input data settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredInputData
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

Boolean
true if successful

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData Properties

Visual Basic Usage

CB Com Devkit
PredInputData Properties

The PredInputData type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DataOrientation | Orientation of the detected range
DetectedRange | Acces to detected range
HasLeftHeader | HasLeftHeader is true if a detected range has left header
HasTopHeader | HasTopHeader is true if a detected range has top header
NumberOfDataPoints | Return the number of data points in detected range (series with no data are ignored)
NumberOfDataSeries | Return the number of data series in detected range

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData.DataOrientation Property

Visual Basic Usage

CB Com Devkit
PredInputData..::DataOrientation Property
Orientation of the detected range

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredInputDataOrientation DataOrientation { get; set; }
Public Property DataOrientation As PredInputDataOrientation
    Get
    Set
Dim instance As PredInputData
Dim value As PredInputDataOrientation

value = instance.DataOrientation

instance.DataOrientation = value

Property Value

PredInputDataOrientation

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData.DetectedRange Property

Visual Basic Usage

CB Com Devkit
PredInputData..::DetectedRange Property
Acces to detected range

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range DetectedRange { get; }
Public ReadOnly Property DetectedRange As Range
    Get
Dim instance As PredInputData
Dim value As Range

value = instance.DetectedRange

Property Value

Range

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData.HasLeftHeader Property

Visual Basic Usage

CB Com Devkit
PredInputData..::HasLeftHeader Property
HasLeftHeader is true if a detected range has left header

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HasLeftHeader { get; set; }
Public Property HasLeftHeader As Boolean
    Get
    Set
Dim instance As PredInputData
Dim value As Boolean

value = instance.HasLeftHeader

instance.HasLeftHeader = value

Property Value

Boolean

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData.HasTopHeader Property

Visual Basic Usage

CB Com Devkit
PredInputData..::HasTopHeader Property
HasTopHeader is true if a detected range has top header

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HasTopHeader { get; set; }
Public Property HasTopHeader As Boolean
    Get
    Set
Dim instance As PredInputData
Dim value As Boolean

value = instance.HasTopHeader

instance.HasTopHeader = value

Property Value

Boolean

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData.NumberOfDataPoints Property

Visual Basic Usage

CB Com Devkit
PredInputData..::NumberOfDataPoints Property
Return the number of data points in detected range (series with no data are ignored)

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfDataPoints { get; }
Public ReadOnly Property NumberOfDataPoints As Integer
    Get
Dim instance As PredInputData
Dim value As Integer

value = instance.NumberOfDataPoints

Property Value

Int32

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData.NumberOfDataSeries Property

Visual Basic Usage

CB Com Devkit
PredInputData..::NumberOfDataSeries Property
Return the number of data series in detected range

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfDataSeries { get; }
Public ReadOnly Property NumberOfDataSeries As Integer
    Get
Dim instance As PredInputData
Dim value As Integer

value = instance.NumberOfDataSeries

Property Value

Int32

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputDataOrientation Enumeration

Visual Basic Usage

CB Com Devkit
PredInputDataOrientation Enumeration
Input data oriantation options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredInputDataOrientation
Public Enumeration PredInputDataOrientation
Dim instance As PredInputDataOrientation

Members

Member | Value | Description
InputDataInRows | 0 | Input data in rows
InputDataInColumns | 1 | Input data in columns

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLag Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredLag Class
Lag information interface. Provides access to autocorrelation lag details.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredLag
Public Class PredLag
Dim instance As PredLag

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Autocorrelation | Autocorrelation value.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Index | Autocorrelation index offset.
Probability | Probability value.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredLag

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLag Methods

Visual Basic Usage

CB Com Devkit
PredLag Methods

The PredLag type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredLag Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLag Properties

Visual Basic Usage

CB Com Devkit
PredLag Properties

The PredLag type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Autocorrelation | Autocorrelation value.
Index | Autocorrelation index offset.
Probability | Probability value.

See Also

PredLag Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLag.Autocorrelation Property

Visual Basic Usage

CB Com Devkit
PredLag..::Autocorrelation Property
Autocorrelation value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Autocorrelation { get; }
Public ReadOnly Property Autocorrelation As Double
    Get
Dim instance As PredLag
Dim value As Double

value = instance.Autocorrelation

Property Value

Double

See Also

PredLag Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLag.Index Property

Visual Basic Usage

CB Com Devkit
PredLag..::Index Property
Autocorrelation index offset.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
Dim instance As PredLag
Dim value As Integer

value = instance.Index

Property Value

Int32

See Also

PredLag Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLag.Probability Property

Visual Basic Usage

CB Com Devkit
PredLag..::Probability Property
Probability value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Probability { get; }
Public ReadOnly Property Probability As Double
    Get
Dim instance As PredLag
Dim value As Double

value = instance.Probability

Property Value

Double

See Also

PredLag Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredLagEnumerator Class
List of autocorrelation lags.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredLagEnumerator : IPredLagEnumerator,
    IEnumerable, IEnumerator
Public Class PredLagEnumerator
    Implements IPredLagEnumerator, IEnumerable, IEnumerator
Dim instance As PredLagEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get lag by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredLagEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator Methods

Visual Basic Usage

CB Com Devkit
PredLagEnumerator Methods

The PredLagEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator.GetEnumerator Method

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::GetEnumerator Method
Returns an enumerator for these series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As PredLagEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

IEnumerator
the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator.MoveNext Method

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid series

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As PredLagEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

Boolean
true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As PredLagEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
true if successful

Implements

IPredLagEnumerator..::..Reload()()()()

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator.Reset Method

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first series).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As PredLagEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator Properties

Visual Basic Usage

CB Com Devkit
PredLagEnumerator Properties

The PredLagEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Item[([( Int32])]) | Get lag by index.

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::Count Property
Returns the series count

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As PredLagEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

Implements

IPredLagEnumerator..::..Count

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::Current Property
Returns the current series (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As PredLagEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::Item Property
Get lag by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredLag this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As PredLag
    Get
Dim instance As PredLagEnumerator
Dim index As Integer
Dim value As PredLag

value = instance(index)

Parameters

index
Int32

Return Value

PredLag

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredMethods Class
Main interface to methods settings corresponding the Predictor Methods panel. This lets you control what methods to use and method parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredMethods
Public Class PredMethods
Dim instance As PredMethods

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ARIMAAddModel(PredARIMAModel) | Adds an ARIMA model to the method list. Returns the index number of the model in the list if the model has been successfully added, -1 otherwise. Only valid for custom ARIMA.
ARIMAConstant | Defines if constant is used in the ARIMA equation.
ARIMAExtendedSearchAutomatic | Defines the current setting for the extended search. True if the extended search is turned on in Automatic ARIMA.
ARIMAMethods | Indicates if ARIMA methods are executed, true if ARIMA methods are selected, false otherwise.
ARIMAModels | Access to the ARIMA models currently included in the method list. Only valid for custom ARIMA.
ARIMAModelSelection | Defines the ARIMA model used (either automatic or manual)
ARIMAModelSelectionCriterion | Defines the criterion by which the best model is selected in automatic ARIMA.
ARIMARemoveModel(Int32) | Deletes the model at the specified position. Only valid for custom ARIMA.
ARIMAReplaceModel(Int32, PredARIMAModel) | Replaces the ARIMA model at the index position by the new ARIMA model. Only valid for custom ARIMA.
ARIMATransformation | Defines the transformation to be performed on the input data series.
ARIMATransformationLambda | Defines the custom lambda value for Box-Cox transformation. Has to be inside [-5, 5]
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetMethodName(PredForecastMethodType) | Get the method name
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MethodDoubleExponentialSmoothing | Will the DoubleExponentialSmoothing method be run.
MethodDoubleExponentialSmoothingAlpha | DoubleExponentialSmoothing method alpha parameter value.
MethodDoubleExponentialSmoothingBeta | DoubleExponentialSmoothing method beta parameter value.
MethodDoubleExponentialSmoothingOptimize | Will the DoubleExponentialSmoothing method automatically set parameters.
MethodDoubleMovingAverage | Will the DoubleMovingAverage method be run.
MethodDoubleMovingAverageOptimize | Will the DoubleMovingAverage method automatically set parameters.
MethodDoubleMovingAverageOrder | DoubleMovingAverage method order parameter value.
MethodHoltWintersAdditive | Will the HoltWintersAdditive method be run.
MethodHoltWintersAdditiveAlpha | HoltWintersAdditive method alpha parameter value.
MethodHoltWintersAdditiveBeta | HoltWintersAdditive method beta parameter value.
MethodHoltWintersAdditiveGamma | HoltWintersAdditive method gamma parameter value.
MethodHoltWintersAdditiveOptimize | Will the HoltWintersAdditive method automatically set parameters.
MethodHoltWintersMultiplicative | Will the HoltWintersMultiplicative method be run.
MethodHoltWintersMultiplicativeAlpha | HoltWintersMultiplicative method alpha parameter value.
MethodHoltWintersMultiplicativeBeta | HoltWintersMultiplicative method beta parameter value.
MethodHoltWintersMultiplicativeGamma | HoltWintersMultiplicative method gamma parameter value.
MethodHoltWintersMultiplicativeOptimize | Will the HoltWintersMultiplicative method automatically set parameters.
MethodSeasonalAdditive | Will the SeasonalAdditive method be run.
MethodSeasonalAdditiveAlpha | SeasonalAdditive method alpha parameter value.
MethodSeasonalAdditiveGamma | SeasonalAdditive method gamma parameter value.
MethodSeasonalAdditiveOptimize | Will the SeasonalAdditive method automatically set parameters.
MethodSeasonalMultiplicative | Will the SeasonalMultiplicative method be run.
MethodSeasonalMultiplicativeAlpha | SeasonalMultiplicative method alpha parameter value.
MethodSeasonalMultiplicativeGamma | SeasonalMultiplicative method gamma parameter value.
MethodSeasonalMultiplicativeOptimize | Will the SeasonalMultiplicative method automatically set parameters.
MethodSingleExponentialSmoothing | Will the SingleExponentialSmoothing method be run.
MethodSingleExponentialSmoothingAlpha | SingleExponentialSmoothing method alpha parameter value.
MethodSingleExponentialSmoothingOptimize | Will the SingleExponentialSmoothing method automatically set parameters.
MethodSingleMovingAverage | Will the SingleMovingAverage method be run.
MethodSingleMovingAverageOptimize | Will the SingleMovingAverage method automatically set parameters.
MethodSingleMovingAverageOrder | SingleMovingAverage method order parameter value.
NonSeasonalMethods | Will non-seasonal methods will be run.
RegressionCalculateVIF | Calculate regression VIF (variance inflation factor).
RegressionFTest | Will regression Partial F-Test significance be used.
RegressionIncludeConstant | Include constant in regression.
RegressionMethod | Choose which regression method to run. Default is Standard.
RegressionMethods | Will regression methods be run.
RegressionPartialFTestProbabilityAdd | Regression Partial F-Test probability to add value.
RegressionPartialFTestProbabilityRemove | Regression Partial F-Test probability to remove value.
RegressionRSquared | Will regression R-Squared stopping be used.
RegressionRSquaredAdjusted | Will regression Adjusted R-Squared stopping be used.
RegressionRSquaredAdjustedThreshold | Regression R-Squared stopping threshold value.
RegressionRunOnlyRegressionMethods | Run only the selected regression method for the dependent variable, skip all other selected methods.
SeasonalMethods | Will seasonal methods will be run.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate all method settings.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredMethods

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods Methods

Visual Basic Usage

CB Com Devkit
PredMethods Methods

The PredMethods type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ARIMAAddModel(PredARIMAModel) | Adds an ARIMA model to the method list. Returns the index number of the model in the list if the model has been successfully added, -1 otherwise. Only valid for custom ARIMA.
ARIMARemoveModel(Int32) | Deletes the model at the specified position. Only valid for custom ARIMA.
ARIMAReplaceModel(Int32, PredARIMAModel) | Replaces the ARIMA model at the index position by the new ARIMA model. Only valid for custom ARIMA.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetMethodName(PredForecastMethodType) | Get the method name
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate all method settings.

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.ARIMAAddModel Method

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAAddModel Method
Adds an ARIMA model to the method list. Returns the index number of the model in the list if the model has been successfully added, -1 otherwise. Only valid for custom ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMAAddModel(
    PredARIMAModel model
)
Public Function ARIMAAddModel (
    model As PredARIMAModel
) As Integer
Dim instance As PredMethods
Dim model As PredARIMAModel
Dim returnValue As Integer

returnValue = instance.ARIMAAddModel(model)

Parameters

model
PredARIMAModel
model to be added to the list

Return Value

Int32
index of the added model

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.ARIMARemoveModel Method

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMARemoveModel Method
Deletes the model at the specified position. Only valid for custom ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ARIMARemoveModel(
    int index
)
Public Sub ARIMARemoveModel (
    index As Integer
)
Dim instance As PredMethods
Dim index As Integer

instance.ARIMARemoveModel(index)

Parameters

index
Int32
index of model to be deleted

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.ARIMAReplaceModel Method

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAReplaceModel Method
Replaces the ARIMA model at the index position by the new ARIMA model. Only valid for custom ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ARIMAReplaceModel(
    int index,
    PredARIMAModel model
)
Public Sub ARIMAReplaceModel (
    index As Integer,
    model As PredARIMAModel
)
Dim instance As PredMethods
Dim index As Integer
Dim model As PredARIMAModel

instance.ARIMAReplaceModel(index, model)

Parameters

index
Int32
position in model list
model
PredARIMAModel
model to be added to the list

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.GetMethodName Method

Visual Basic Usage

CB Com Devkit
PredMethods..::GetMethodName Method
Get the method name

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string GetMethodName(
    PredForecastMethodType method
)
Public Function GetMethodName (
    method As PredForecastMethodType
) As String
Dim instance As PredMethods
Dim method As PredForecastMethodType
Dim returnValue As String

returnValue = instance.GetMethodName(method)

Parameters

method
PredForecastMethodType
Provided method type

Return Value

String
Method name

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.Validate Method

Visual Basic Usage

CB Com Devkit
PredMethods..::Validate Method
Validate all method settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredMethods
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

Boolean
true if successful

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods Properties

Visual Basic Usage

CB Com Devkit
PredMethods Properties

The PredMethods type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ARIMAConstant | Defines if constant is used in the ARIMA equation.
ARIMAExtendedSearchAutomatic | Defines the current setting for the extended search. True if the extended search is turned on in Automatic ARIMA.
ARIMAMethods | Indicates if ARIMA methods are executed, true if ARIMA methods are selected, false otherwise.
ARIMAModels | Access to the ARIMA models currently included in the method list. Only valid for custom ARIMA.
ARIMAModelSelection | Defines the ARIMA model used (either automatic or manual)
ARIMAModelSelectionCriterion | Defines the criterion by which the best model is selected in automatic ARIMA.
ARIMATransformation | Defines the transformation to be performed on the input data series.
ARIMATransformationLambda | Defines the custom lambda value for Box-Cox transformation. Has to be inside [-5, 5]
MethodDoubleExponentialSmoothing | Will the DoubleExponentialSmoothing method be run.
MethodDoubleExponentialSmoothingAlpha | DoubleExponentialSmoothing method alpha parameter value.
MethodDoubleExponentialSmoothingBeta | DoubleExponentialSmoothing method beta parameter value.
MethodDoubleExponentialSmoothingOptimize | Will the DoubleExponentialSmoothing method automatically set parameters.
MethodDoubleMovingAverage | Will the DoubleMovingAverage method be run.
MethodDoubleMovingAverageOptimize | Will the DoubleMovingAverage method automatically set parameters.
MethodDoubleMovingAverageOrder | DoubleMovingAverage method order parameter value.
MethodHoltWintersAdditive | Will the HoltWintersAdditive method be run.
MethodHoltWintersAdditiveAlpha | HoltWintersAdditive method alpha parameter value.
MethodHoltWintersAdditiveBeta | HoltWintersAdditive method beta parameter value.
MethodHoltWintersAdditiveGamma | HoltWintersAdditive method gamma parameter value.
MethodHoltWintersAdditiveOptimize | Will the HoltWintersAdditive method automatically set parameters.
MethodHoltWintersMultiplicative | Will the HoltWintersMultiplicative method be run.
MethodHoltWintersMultiplicativeAlpha | HoltWintersMultiplicative method alpha parameter value.
MethodHoltWintersMultiplicativeBeta | HoltWintersMultiplicative method beta parameter value.
MethodHoltWintersMultiplicativeGamma | HoltWintersMultiplicative method gamma parameter value.
MethodHoltWintersMultiplicativeOptimize | Will the HoltWintersMultiplicative method automatically set parameters.
MethodSeasonalAdditive | Will the SeasonalAdditive method be run.
MethodSeasonalAdditiveAlpha | SeasonalAdditive method alpha parameter value.
MethodSeasonalAdditiveGamma | SeasonalAdditive method gamma parameter value.
MethodSeasonalAdditiveOptimize | Will the SeasonalAdditive method automatically set parameters.
MethodSeasonalMultiplicative | Will the SeasonalMultiplicative method be run.
MethodSeasonalMultiplicativeAlpha | SeasonalMultiplicative method alpha parameter value.
MethodSeasonalMultiplicativeGamma | SeasonalMultiplicative method gamma parameter value.
MethodSeasonalMultiplicativeOptimize | Will the SeasonalMultiplicative method automatically set parameters.
MethodSingleExponentialSmoothing | Will the SingleExponentialSmoothing method be run.
MethodSingleExponentialSmoothingAlpha | SingleExponentialSmoothing method alpha parameter value.
MethodSingleExponentialSmoothingOptimize | Will the SingleExponentialSmoothing method automatically set parameters.
MethodSingleMovingAverage | Will the SingleMovingAverage method be run.
MethodSingleMovingAverageOptimize | Will the SingleMovingAverage method automatically set parameters.
MethodSingleMovingAverageOrder | SingleMovingAverage method order parameter value.
NonSeasonalMethods | Will non-seasonal methods will be run.
RegressionCalculateVIF | Calculate regression VIF (variance inflation factor).
RegressionFTest | Will regression Partial F-Test significance be used.
RegressionIncludeConstant | Include constant in regression.
RegressionMethod | Choose which regression method to run. Default is Standard.
RegressionMethods | Will regression methods be run.
RegressionPartialFTestProbabilityAdd | Regression Partial F-Test probability to add value.
RegressionPartialFTestProbabilityRemove | Regression Partial F-Test probability to remove value.
RegressionRSquared | Will regression R-Squared stopping be used.
RegressionRSquaredAdjusted | Will regression Adjusted R-Squared stopping be used.
RegressionRSquaredAdjustedThreshold | Regression R-Squared stopping threshold value.
RegressionRunOnlyRegressionMethods | Run only the selected regression method for the dependent variable, skip all other selected methods.
SeasonalMethods | Will seasonal methods will be run.

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.ARIMAConstant Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAConstant Property
Defines if constant is used in the ARIMA equation.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMAConstant ARIMAConstant { get; set; }
Public Property ARIMAConstant As PredARIMAConstant
    Get
    Set
Dim instance As PredMethods
Dim value As PredARIMAConstant

value = instance.ARIMAConstant

instance.ARIMAConstant = value

Property Value

PredARIMAConstant

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.ARIMAExtendedSearchAutomatic Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAExtendedSearchAutomatic Property
Defines the current setting for the extended search. True if the extended search is turned on in Automatic ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ARIMAExtendedSearchAutomatic { get; set; }
Public Property ARIMAExtendedSearchAutomatic As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.ARIMAExtendedSearchAutomatic

instance.ARIMAExtendedSearchAutomatic = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.ARIMAMethods Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAMethods Property
Indicates if ARIMA methods are executed, true if ARIMA methods are selected, false otherwise.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ARIMAMethods { get; set; }
Public Property ARIMAMethods As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.ARIMAMethods

instance.ARIMAMethods = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.ARIMAModels Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAModels Property
Access to the ARIMA models currently included in the method list. Only valid for custom ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ARIMAModelEnumerator ARIMAModels { get; }
Public ReadOnly Property ARIMAModels As ARIMAModelEnumerator
    Get
Dim instance As PredMethods
Dim value As ARIMAModelEnumerator

value = instance.ARIMAModels

Property Value

ARIMAModelEnumerator

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.ARIMAModelSelection Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAModelSelection Property
Defines the ARIMA model used (either automatic or manual)

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMAModelSelection ARIMAModelSelection { get; set; }
Public Property ARIMAModelSelection As PredARIMAModelSelection
    Get
    Set
Dim instance As PredMethods
Dim value As PredARIMAModelSelection

value = instance.ARIMAModelSelection

instance.ARIMAModelSelection = value

Property Value

PredARIMAModelSelection

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.ARIMAModelSelectionCriterion Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAModelSelectionCriterion Property
Defines the criterion by which the best model is selected in automatic ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMAModelSelectionCriterion ARIMAModelSelectionCriterion { get; set; }
Public Property ARIMAModelSelectionCriterion As PredARIMAModelSelectionCriterion
    Get
    Set
Dim instance As PredMethods
Dim value As PredARIMAModelSelectionCriterion

value = instance.ARIMAModelSelectionCriterion

instance.ARIMAModelSelectionCriterion = value

Property Value

PredARIMAModelSelectionCriterion

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.ARIMATransformation Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMATransformation Property
Defines the transformation to be performed on the input data series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMABoxCoxTransformation ARIMATransformation { get; set; }
Public Property ARIMATransformation As PredARIMABoxCoxTransformation
    Get
    Set
Dim instance As PredMethods
Dim value As PredARIMABoxCoxTransformation

value = instance.ARIMATransformation

instance.ARIMATransformation = value

Property Value

PredARIMABoxCoxTransformation

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.ARIMATransformationLambda Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMATransformationLambda Property
Defines the custom lambda value for Box-Cox transformation. Has to be inside [-5, 5]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ARIMATransformationLambda { get; set; }
Public Property ARIMATransformationLambda As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.ARIMATransformationLambda

instance.ARIMATransformationLambda = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodDoubleExponentialSmoothing Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleExponentialSmoothing Property
Will the DoubleExponentialSmoothing method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodDoubleExponentialSmoothing { get; set; }
Public Property MethodDoubleExponentialSmoothing As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodDoubleExponentialSmoothing

instance.MethodDoubleExponentialSmoothing = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodDoubleExponentialSmoothingAlpha Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleExponentialSmoothingAlpha Property
DoubleExponentialSmoothing method alpha parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodDoubleExponentialSmoothingAlpha { get; set; }
Public Property MethodDoubleExponentialSmoothingAlpha As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodDoubleExponentialSmoothingAlpha

instance.MethodDoubleExponentialSmoothingAlpha = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodDoubleExponentialSmoothingBeta Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleExponentialSmoothingBeta Property
DoubleExponentialSmoothing method beta parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodDoubleExponentialSmoothingBeta { get; set; }
Public Property MethodDoubleExponentialSmoothingBeta As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodDoubleExponentialSmoothingBeta

instance.MethodDoubleExponentialSmoothingBeta = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodDoubleExponentialSmoothingOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleExponentialSmoothingOptimize Property
Will the DoubleExponentialSmoothing method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodDoubleExponentialSmoothingOptimize { get; set; }
Public Property MethodDoubleExponentialSmoothingOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodDoubleExponentialSmoothingOptimize

instance.MethodDoubleExponentialSmoothingOptimize = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodDoubleMovingAverage Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleMovingAverage Property
Will the DoubleMovingAverage method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodDoubleMovingAverage { get; set; }
Public Property MethodDoubleMovingAverage As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodDoubleMovingAverage

instance.MethodDoubleMovingAverage = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodDoubleMovingAverageOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleMovingAverageOptimize Property
Will the DoubleMovingAverage method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodDoubleMovingAverageOptimize { get; set; }
Public Property MethodDoubleMovingAverageOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodDoubleMovingAverageOptimize

instance.MethodDoubleMovingAverageOptimize = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodDoubleMovingAverageOrder Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleMovingAverageOrder Property
DoubleMovingAverage method order parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int MethodDoubleMovingAverageOrder { get; set; }
Public Property MethodDoubleMovingAverageOrder As Integer
    Get
    Set
Dim instance As PredMethods
Dim value As Integer

value = instance.MethodDoubleMovingAverageOrder

instance.MethodDoubleMovingAverageOrder = value

Property Value

Int32

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodHoltWintersAdditive Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersAdditive Property
Will the HoltWintersAdditive method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodHoltWintersAdditive { get; set; }
Public Property MethodHoltWintersAdditive As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodHoltWintersAdditive

instance.MethodHoltWintersAdditive = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodHoltWintersAdditiveAlpha Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersAdditiveAlpha Property
HoltWintersAdditive method alpha parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodHoltWintersAdditiveAlpha { get; set; }
Public Property MethodHoltWintersAdditiveAlpha As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodHoltWintersAdditiveAlpha

instance.MethodHoltWintersAdditiveAlpha = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodHoltWintersAdditiveBeta Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersAdditiveBeta Property
HoltWintersAdditive method beta parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodHoltWintersAdditiveBeta { get; set; }
Public Property MethodHoltWintersAdditiveBeta As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodHoltWintersAdditiveBeta

instance.MethodHoltWintersAdditiveBeta = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodHoltWintersAdditiveGamma Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersAdditiveGamma Property
HoltWintersAdditive method gamma parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodHoltWintersAdditiveGamma { get; set; }
Public Property MethodHoltWintersAdditiveGamma As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodHoltWintersAdditiveGamma

instance.MethodHoltWintersAdditiveGamma = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodHoltWintersAdditiveOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersAdditiveOptimize Property
Will the HoltWintersAdditive method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodHoltWintersAdditiveOptimize { get; set; }
Public Property MethodHoltWintersAdditiveOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodHoltWintersAdditiveOptimize

instance.MethodHoltWintersAdditiveOptimize = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodHoltWintersMultiplicative Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersMultiplicative Property
Will the HoltWintersMultiplicative method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodHoltWintersMultiplicative { get; set; }
Public Property MethodHoltWintersMultiplicative As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodHoltWintersMultiplicative

instance.MethodHoltWintersMultiplicative = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodHoltWintersMultiplicativeAlpha Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersMultiplicativeAlpha Property
HoltWintersMultiplicative method alpha parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodHoltWintersMultiplicativeAlpha { get; set; }
Public Property MethodHoltWintersMultiplicativeAlpha As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodHoltWintersMultiplicativeAlpha

instance.MethodHoltWintersMultiplicativeAlpha = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodHoltWintersMultiplicativeBeta Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersMultiplicativeBeta Property
HoltWintersMultiplicative method beta parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodHoltWintersMultiplicativeBeta { get; set; }
Public Property MethodHoltWintersMultiplicativeBeta As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodHoltWintersMultiplicativeBeta

instance.MethodHoltWintersMultiplicativeBeta = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodHoltWintersMultiplicativeGamma Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersMultiplicativeGamma Property
HoltWintersMultiplicative method gamma parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodHoltWintersMultiplicativeGamma { get; set; }
Public Property MethodHoltWintersMultiplicativeGamma As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodHoltWintersMultiplicativeGamma

instance.MethodHoltWintersMultiplicativeGamma = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodHoltWintersMultiplicativeOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersMultiplicativeOptimize Property
Will the HoltWintersMultiplicative method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodHoltWintersMultiplicativeOptimize { get; set; }
Public Property MethodHoltWintersMultiplicativeOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodHoltWintersMultiplicativeOptimize

instance.MethodHoltWintersMultiplicativeOptimize = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSeasonalAdditive Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalAdditive Property
Will the SeasonalAdditive method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSeasonalAdditive { get; set; }
Public Property MethodSeasonalAdditive As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSeasonalAdditive

instance.MethodSeasonalAdditive = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSeasonalAdditiveAlpha Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalAdditiveAlpha Property
SeasonalAdditive method alpha parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodSeasonalAdditiveAlpha { get; set; }
Public Property MethodSeasonalAdditiveAlpha As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodSeasonalAdditiveAlpha

instance.MethodSeasonalAdditiveAlpha = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSeasonalAdditiveGamma Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalAdditiveGamma Property
SeasonalAdditive method gamma parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodSeasonalAdditiveGamma { get; set; }
Public Property MethodSeasonalAdditiveGamma As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodSeasonalAdditiveGamma

instance.MethodSeasonalAdditiveGamma = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSeasonalAdditiveOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalAdditiveOptimize Property
Will the SeasonalAdditive method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSeasonalAdditiveOptimize { get; set; }
Public Property MethodSeasonalAdditiveOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSeasonalAdditiveOptimize

instance.MethodSeasonalAdditiveOptimize = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSeasonalMultiplicative Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalMultiplicative Property
Will the SeasonalMultiplicative method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSeasonalMultiplicative { get; set; }
Public Property MethodSeasonalMultiplicative As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSeasonalMultiplicative

instance.MethodSeasonalMultiplicative = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSeasonalMultiplicativeAlpha Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalMultiplicativeAlpha Property
SeasonalMultiplicative method alpha parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodSeasonalMultiplicativeAlpha { get; set; }
Public Property MethodSeasonalMultiplicativeAlpha As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodSeasonalMultiplicativeAlpha

instance.MethodSeasonalMultiplicativeAlpha = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSeasonalMultiplicativeGamma Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalMultiplicativeGamma Property
SeasonalMultiplicative method gamma parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodSeasonalMultiplicativeGamma { get; set; }
Public Property MethodSeasonalMultiplicativeGamma As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodSeasonalMultiplicativeGamma

instance.MethodSeasonalMultiplicativeGamma = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSeasonalMultiplicativeOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalMultiplicativeOptimize Property
Will the SeasonalMultiplicative method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSeasonalMultiplicativeOptimize { get; set; }
Public Property MethodSeasonalMultiplicativeOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSeasonalMultiplicativeOptimize

instance.MethodSeasonalMultiplicativeOptimize = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSingleExponentialSmoothing Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSingleExponentialSmoothing Property
Will the SingleExponentialSmoothing method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSingleExponentialSmoothing { get; set; }
Public Property MethodSingleExponentialSmoothing As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSingleExponentialSmoothing

instance.MethodSingleExponentialSmoothing = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSingleExponentialSmoothingAlpha Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSingleExponentialSmoothingAlpha Property
SingleExponentialSmoothing method alpha parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodSingleExponentialSmoothingAlpha { get; set; }
Public Property MethodSingleExponentialSmoothingAlpha As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodSingleExponentialSmoothingAlpha

instance.MethodSingleExponentialSmoothingAlpha = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSingleExponentialSmoothingOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSingleExponentialSmoothingOptimize Property
Will the SingleExponentialSmoothing method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSingleExponentialSmoothingOptimize { get; set; }
Public Property MethodSingleExponentialSmoothingOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSingleExponentialSmoothingOptimize

instance.MethodSingleExponentialSmoothingOptimize = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSingleMovingAverage Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSingleMovingAverage Property
Will the SingleMovingAverage method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSingleMovingAverage { get; set; }
Public Property MethodSingleMovingAverage As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSingleMovingAverage

instance.MethodSingleMovingAverage = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSingleMovingAverageOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSingleMovingAverageOptimize Property
Will the SingleMovingAverage method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSingleMovingAverageOptimize { get; set; }
Public Property MethodSingleMovingAverageOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSingleMovingAverageOptimize

instance.MethodSingleMovingAverageOptimize = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.MethodSingleMovingAverageOrder Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSingleMovingAverageOrder Property
SingleMovingAverage method order parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int MethodSingleMovingAverageOrder { get; set; }
Public Property MethodSingleMovingAverageOrder As Integer
    Get
    Set
Dim instance As PredMethods
Dim value As Integer

value = instance.MethodSingleMovingAverageOrder

instance.MethodSingleMovingAverageOrder = value

Property Value

Int32

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.NonSeasonalMethods Property

Visual Basic Usage

CB Com Devkit
PredMethods..::NonSeasonalMethods Property
Will non-seasonal methods will be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool NonSeasonalMethods { get; set; }
Public Property NonSeasonalMethods As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.NonSeasonalMethods

instance.NonSeasonalMethods = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.RegressionCalculateVIF Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionCalculateVIF Property
Calculate regression VIF (variance inflation factor).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionCalculateVIF { get; set; }
Public Property RegressionCalculateVIF As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionCalculateVIF

instance.RegressionCalculateVIF = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.RegressionFTest Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionFTest Property
Will regression Partial F-Test significance be used.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionFTest { get; set; }
Public Property RegressionFTest As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionFTest

instance.RegressionFTest = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.RegressionIncludeConstant Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionIncludeConstant Property
Include constant in regression.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionIncludeConstant { get; set; }
Public Property RegressionIncludeConstant As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionIncludeConstant

instance.RegressionIncludeConstant = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.RegressionMethod Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionMethod Property
Choose which regression method to run. Default is Standard.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredRegressionMethod RegressionMethod { get; set; }
Public Property RegressionMethod As PredRegressionMethod
    Get
    Set
Dim instance As PredMethods
Dim value As PredRegressionMethod

value = instance.RegressionMethod

instance.RegressionMethod = value

Property Value

PredRegressionMethod

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.RegressionMethods Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionMethods Property
Will regression methods be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionMethods { get; set; }
Public Property RegressionMethods As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionMethods

instance.RegressionMethods = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.RegressionPartialFTestProbabilityAdd Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionPartialFTestProbabilityAdd Property
Regression Partial F-Test probability to add value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RegressionPartialFTestProbabilityAdd { get; set; }
Public Property RegressionPartialFTestProbabilityAdd As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.RegressionPartialFTestProbabilityAdd

instance.RegressionPartialFTestProbabilityAdd = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.RegressionPartialFTestProbabilityRemove Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionPartialFTestProbabilityRemove Property
Regression Partial F-Test probability to remove value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RegressionPartialFTestProbabilityRemove { get; set; }
Public Property RegressionPartialFTestProbabilityRemove As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.RegressionPartialFTestProbabilityRemove

instance.RegressionPartialFTestProbabilityRemove = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.RegressionRSquared Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionRSquared Property
Will regression R-Squared stopping be used.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionRSquared { get; set; }
Public Property RegressionRSquared As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionRSquared

instance.RegressionRSquared = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.RegressionRSquaredAdjusted Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionRSquaredAdjusted Property
Will regression Adjusted R-Squared stopping be used.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionRSquaredAdjusted { get; set; }
Public Property RegressionRSquaredAdjusted As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionRSquaredAdjusted

instance.RegressionRSquaredAdjusted = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.RegressionRSquaredAdjustedThreshold Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionRSquaredAdjustedThreshold Property
Regression R-Squared stopping threshold value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RegressionRSquaredAdjustedThreshold { get; set; }
Public Property RegressionRSquaredAdjustedThreshold As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.RegressionRSquaredAdjustedThreshold

instance.RegressionRSquaredAdjustedThreshold = value

Property Value

Double

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.RegressionRunOnlyRegressionMethods Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionRunOnlyRegressionMethods Property
Run only the selected regression method for the dependent variable, skip all other selected methods.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionRunOnlyRegressionMethods { get; set; }
Public Property RegressionRunOnlyRegressionMethods As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionRunOnlyRegressionMethods

instance.RegressionRunOnlyRegressionMethods = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods.SeasonalMethods Property

Visual Basic Usage

CB Com Devkit
PredMethods..::SeasonalMethods Property
Will seasonal methods will be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SeasonalMethods { get; set; }
Public Property SeasonalMethods As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.SeasonalMethods

instance.SeasonalMethods = value

Property Value

Boolean

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMissingValueFillInMethod Enumeration

Visual Basic Usage

CB Com Devkit
PredMissingValueFillInMethod Enumeration
Missing values missing values fill in methods.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredMissingValueFillInMethod
Public Enumeration PredMissingValueFillInMethod
Dim instance As PredMissingValueFillInMethod

Members

Member | Value | Description
CubicSpline | 0 | Cubic spline interpolation
NeighborInterpolation | 1 | Neighbor interpolation

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredNeighborInterpolationStatistic Enumeration

Visual Basic Usage

CB Com Devkit
PredNeighborInterpolationStatistic Enumeration
Statistic used for neighbor interpolation.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredNeighborInterpolationStatistic
Public Enumeration PredNeighborInterpolationStatistic
Dim instance As PredNeighborInterpolationStatistic

Members

Member | Value | Description
Mean | 0 | Mean neighbor interpolation statistic
Median | 1 | Median neighbor interpolation statistic

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOptions Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredOptions Class
Main interface to predictor options corresponding to the Predictor Options panel. This povides access to options such as error measure and forecasting technique.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredOptions
Public Class PredOptions
Dim instance As PredOptions

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ErrorMeasure | The selected error measure. Default is RMSE - Root Mean Squared Error
ForecastingTechnique | The selected forecasting technique.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Holdout | Holdout forecast period value.
SimpleLead | Simple lead forecast period value.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate all options settings.
WeightedLead | Weighted lead forecast period value.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredOptions

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOptions Methods

Visual Basic Usage

CB Com Devkit
PredOptions Methods

The PredOptions type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate all options settings.

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOptions.Validate Method

Visual Basic Usage

CB Com Devkit
PredOptions..::Validate Method
Validate all options settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredOptions
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

Boolean
true if successful

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOptions Properties

Visual Basic Usage

CB Com Devkit
PredOptions Properties

The PredOptions type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ErrorMeasure | The selected error measure. Default is RMSE - Root Mean Squared Error
ForecastingTechnique | The selected forecasting technique.
Holdout | Holdout forecast period value.
SimpleLead | Simple lead forecast period value.
WeightedLead | Weighted lead forecast period value.

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOptions.ErrorMeasure Property

Visual Basic Usage

CB Com Devkit
PredOptions..::ErrorMeasure Property
The selected error measure. Default is RMSE - Root Mean Squared Error

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredErrorMeasureType ErrorMeasure { get; set; }
Public Property ErrorMeasure As PredErrorMeasureType
    Get
    Set
Dim instance As PredOptions
Dim value As PredErrorMeasureType

value = instance.ErrorMeasure

instance.ErrorMeasure = value

Property Value

PredErrorMeasureType

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOptions.ForecastingTechnique Property

Visual Basic Usage

CB Com Devkit
PredOptions..::ForecastingTechnique Property
The selected forecasting technique.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastingTechnique ForecastingTechnique { get; set; }
Public Property ForecastingTechnique As PredForecastingTechnique
    Get
    Set
Dim instance As PredOptions
Dim value As PredForecastingTechnique

value = instance.ForecastingTechnique

instance.ForecastingTechnique = value

Property Value

PredForecastingTechnique

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOptions.Holdout Property

Visual Basic Usage

CB Com Devkit
PredOptions..::Holdout Property
Holdout forecast period value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int Holdout { get; set; }
Public Property Holdout As Integer
    Get
    Set
Dim instance As PredOptions
Dim value As Integer

value = instance.Holdout

instance.Holdout = value

Property Value

Int32

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOptions.SimpleLead Property

Visual Basic Usage

CB Com Devkit
PredOptions..::SimpleLead Property
Simple lead forecast period value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SimpleLead { get; set; }
Public Property SimpleLead As Integer
    Get
    Set
Dim instance As PredOptions
Dim value As Integer

value = instance.SimpleLead

instance.SimpleLead = value

Property Value

Int32

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOptions.WeightedLead Property

Visual Basic Usage

CB Com Devkit
PredOptions..::WeightedLead Property
Weighted lead forecast period value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int WeightedLead { get; set; }
Public Property WeightedLead As Integer
    Get
    Set
Dim instance As PredOptions
Dim value As Integer

value = instance.WeightedLead

instance.WeightedLead = value

Property Value

Int32

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOutlierDetectionMethod Enumeration

Visual Basic Usage

CB Com Devkit
PredOutlierDetectionMethod Enumeration
Outlier detection methods.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredOutlierDetectionMethod
Public Enumeration PredOutlierDetectionMethod
Dim instance As PredOutlierDetectionMethod

Members

Member | Value | Description
MeanAndStdDev | 0 | Mean and standard deviation outlier detection method
MedianAndMAD | 1 | Median and median absolute deviation (MAD) outlier detection method
MedianAndIQD | 2 | Median and interquartile (IQD) outlier detection method

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredRegression Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredRegression Class
Series regression variable settings. Provides access to regression variable settings such as independent/dependent, lag, and exclude.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredRegression
Public Class PredRegression
Dim instance As PredRegression

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exclude | Exclude this series from regression.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Independent | Is this an independent variable.
Lag | Regression variable lag value.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredRegression

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredRegression Methods

Visual Basic Usage

CB Com Devkit
PredRegression Methods

The PredRegression type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredRegression Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredRegression Properties

Visual Basic Usage

CB Com Devkit
PredRegression Properties

The PredRegression type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Exclude | Exclude this series from regression.
Independent | Is this an independent variable.
Lag | Regression variable lag value.

See Also

PredRegression Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredRegression.Exclude Property

Visual Basic Usage

CB Com Devkit
PredRegression..::Exclude Property
Exclude this series from regression.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Exclude { get; set; }
Public Property Exclude As Boolean
    Get
    Set
Dim instance As PredRegression
Dim value As Boolean

value = instance.Exclude

instance.Exclude = value

Property Value

Boolean

See Also

PredRegression Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredRegression.Independent Property

Visual Basic Usage

CB Com Devkit
PredRegression..::Independent Property
Is this an independent variable.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Independent { get; set; }
Public Property Independent As Boolean
    Get
    Set
Dim instance As PredRegression
Dim value As Boolean

value = instance.Independent

instance.Independent = value

Property Value

Boolean

See Also

PredRegression Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredRegression.Lag Property

Visual Basic Usage

CB Com Devkit
PredRegression..::Lag Property
Regression variable lag value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int Lag { get; set; }
Public Property Lag As Integer
    Get
    Set
Dim instance As PredRegression
Dim value As Integer

value = instance.Lag

instance.Lag = value

Property Value

Int32

See Also

PredRegression Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredRegressionMethod Enumeration

Visual Basic Usage

CB Com Devkit
PredRegressionMethod Enumeration
Regression method options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredRegressionMethod
Public Enumeration PredRegressionMethod
Dim instance As PredRegressionMethod

Members

Member | Value | Description
Standard | 0 | Standard regression
ForwardStepwise | 1 | Forward stepwise regression
IterativeStepwise | 2 | Iterative stepwise regression

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredResults Class
Predictor Results. Provides an interface to access predictor run results. This is the top level interface class that provides access to objects to retrieve results available through the Predictor results form.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredResults
Public Class PredResults
Dim instance As PredResults

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PredResults()()()() | Predictor Results. Provides an interface to access predictor run results. This is the top level interface class that provides access to objects to retrieve results available through the Predictor results form.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Paste(Range, Boolean, Boolean, Boolean, Boolean) | Paste forecast results to worksheet.
Preferences | Interface to results preferences. This provides access to results preferences such as confidence intervals and forcast periods.
ResultsLoaded | Has predictor been sucessfully run and is there a valid results set
ResultsWindow | Interface to the Predictor Results Window. This provides access to results settings such as selected series and method. This allows updates to the results window settings.
Series | The list of result series from the predictor run. The list is ordered by position in the input range, left to right for column oriented data or top to bottom for row oriented data. This provides access to series specific information such as statistics and data values.
ThrowErrors | Setting to determine whether to throw errors to the client app
ThrowWarningsAsErrors | Setting to determine whether to throw warnings to the client app
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredResults

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults Constructor

Visual Basic Usage

CB Com Devkit
PredResults Constructor
Predictor Results. Provides an interface to access predictor run results. This is the top level interface class that provides access to objects to retrieve results available through the Predictor results form.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredResults()
Public Sub New
Dim instance As New PredResults()

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults Methods

Visual Basic Usage

CB Com Devkit
PredResults Methods

The PredResults type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Paste(Range, Boolean, Boolean, Boolean, Boolean) | Paste forecast results to worksheet.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults.Paste Method

Visual Basic Usage

CB Com Devkit
PredResults..::Paste Method
Paste forecast results to worksheet.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Paste(
    Range Location = null,
    bool IncludeDateSeries,
    bool PasteAsAssumptions,
    bool AutoFormat,
    bool FlipDataOrientation = false
)
Public Sub Paste (
    Optional Location As Range = Nothing,
    IncludeDateSeries As Boolean,
    PasteAsAssumptions As Boolean,
    AutoFormat As Boolean,
    Optional FlipDataOrientation As Boolean = false
)
Dim instance As PredResults
Dim Location As Range
Dim IncludeDateSeries As Boolean
Dim PasteAsAssumptions As Boolean
Dim AutoFormat As Boolean
Dim FlipDataOrientation As Boolean

instance.Paste(Location, IncludeDateSeries,
    PasteAsAssumptions, AutoFormat,
    FlipDataOrientation)

Parameters

Location (Optional)
Range
Optional location start cell for the paste range.
IncludeDateSeries
Boolean
Include the date series in paste.
PasteAsAssumptions
Boolean
Define assumptions for pasted results.
AutoFormat
Boolean
Format paste range.
FlipDataOrientation (Optional)
Boolean
Change the pasted orientation to be oposite from input data.

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults Properties

Visual Basic Usage

CB Com Devkit
PredResults Properties

The PredResults type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Preferences | Interface to results preferences. This provides access to results preferences such as confidence intervals and forcast periods.
ResultsLoaded | Has predictor been sucessfully run and is there a valid results set
ResultsWindow | Interface to the Predictor Results Window. This provides access to results settings such as selected series and method. This allows updates to the results window settings.
Series | The list of result series from the predictor run. The list is ordered by position in the input range, left to right for column oriented data or top to bottom for row oriented data. This provides access to series specific information such as statistics and data values.
ThrowErrors | Setting to determine whether to throw errors to the client app
ThrowWarningsAsErrors | Setting to determine whether to throw warnings to the client app

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults.Preferences Property

Visual Basic Usage

CB Com Devkit
PredResults..::Preferences Property
Interface to results preferences. This provides access to results preferences such as confidence intervals and forcast periods.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredResultsPreferences Preferences { get; }
Public ReadOnly Property Preferences As PredResultsPreferences
    Get
Dim instance As PredResults
Dim value As PredResultsPreferences

value = instance.Preferences

Property Value

PredResultsPreferences

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults.ResultsLoaded Property

Visual Basic Usage

CB Com Devkit
PredResults..::ResultsLoaded Property
Has predictor been sucessfully run and is there a valid results set

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ResultsLoaded { get; }
Public ReadOnly Property ResultsLoaded As Boolean
    Get
Dim instance As PredResults
Dim value As Boolean

value = instance.ResultsLoaded

Property Value

Boolean

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults.ResultsWindow Property

Visual Basic Usage

CB Com Devkit
PredResults..::ResultsWindow Property
Interface to the Predictor Results Window. This provides access to results settings such as selected series and method. This allows updates to the results window settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredResultsWindow ResultsWindow { get; }
Public ReadOnly Property ResultsWindow As PredResultsWindow
    Get
Dim instance As PredResults
Dim value As PredResultsWindow

value = instance.ResultsWindow

Property Value

PredResultsWindow

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults.Series Property

Visual Basic Usage

CB Com Devkit
PredResults..::Series Property
The list of result series from the predictor run. The list is ordered by position in the input range, left to right for column oriented data or top to bottom for row oriented data. This provides access to series specific information such as statistics and data values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeriesResultEnumerator Series { get; }
Public ReadOnly Property Series As PredSeriesResultEnumerator
    Get
Dim instance As PredResults
Dim value As PredSeriesResultEnumerator

value = instance.Series

Property Value

PredSeriesResultEnumerator

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults.ThrowErrors Property

Visual Basic Usage

CB Com Devkit
PredResults..::ThrowErrors Property
Setting to determine whether to throw errors to the client app

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowErrors { get; set; }
Public Property ThrowErrors As Boolean
    Get
    Set
Dim instance As PredResults
Dim value As Boolean

value = instance.ThrowErrors

instance.ThrowErrors = value

Property Value

Boolean

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults.ThrowWarningsAsErrors Property

Visual Basic Usage

CB Com Devkit
PredResults..::ThrowWarningsAsErrors Property
Setting to determine whether to throw warnings to the client app

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowWarningsAsErrors { get; set; }
Public Property ThrowWarningsAsErrors As Boolean
    Get
    Set
Dim instance As PredResults
Dim value As Boolean

value = instance.ThrowWarningsAsErrors

instance.ThrowWarningsAsErrors = value

Property Value

Boolean

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredResultsPreferences Class
Main interface to results persistant preferences. Provides access to preferences such as confidence interval, forcast periods, statistics grid display, and error measure display.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredResultsPreferences
Public Class PredResultsPreferences
Dim instance As PredResultsPreferences

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ConfidenceInterval | The selected confidence interval.
ConfidenceLower | Lower confidence interval percentage value.
ConfidenceUpper | Upper confidence interval percentage value.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForecastPeriods | Periods to forecast.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
HighlightEvents | Highlight events. This determines if the events are highlighted in the results display.
HighlightScreenedData | Highlight screened data. This determines if the missing and adjusted values are highlighted in the results display.
HighlightSeasonality | Highlight seasonality. This determines if the seasonal cycle is highlighted in the results display.
PasteShowExternalDataSubmitWarning | On forecast values paste, do we show a warning that a user must submit (accept) or refresh (undo) after the paste of Smart View data.
PasteShowOverwriteWarning | On forecast values paste, do we show a data overwrite warning.
SetCustomConfidenceInterval(Double, Double) | Set the custom confidence interval values.
ShowAllErrorMeasures | Show all error measures in statistics grid.
ShowStatistics | Show statistics grid on results window.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredResultsPreferences

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences Methods

Visual Basic Usage

CB Com Devkit
PredResultsPreferences Methods

The PredResultsPreferences type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SetCustomConfidenceInterval(Double, Double) | Set the custom confidence interval values.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences.SetCustomConfidenceInterval Method

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::SetCustomConfidenceInterval Method
Set the custom confidence interval values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SetCustomConfidenceInterval(
    double lower,
    double upper
)
Public Sub SetCustomConfidenceInterval (
    lower As Double,
    upper As Double
)
Dim instance As PredResultsPreferences
Dim lower As Double
Dim upper As Double

instance.SetCustomConfidenceInterval(lower,
    upper)

Parameters

lower
Double
Lower confidence interval percentage value.
upper
Double
Upper confidence interval percentage value.

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences Properties

Visual Basic Usage

CB Com Devkit
PredResultsPreferences Properties

The PredResultsPreferences type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ConfidenceInterval | The selected confidence interval.
ConfidenceLower | Lower confidence interval percentage value.
ConfidenceUpper | Upper confidence interval percentage value.
ForecastPeriods | Periods to forecast.
HighlightEvents | Highlight events. This determines if the events are highlighted in the results display.
HighlightScreenedData | Highlight screened data. This determines if the missing and adjusted values are highlighted in the results display.
HighlightSeasonality | Highlight seasonality. This determines if the seasonal cycle is highlighted in the results display.
PasteShowExternalDataSubmitWarning | On forecast values paste, do we show a warning that a user must submit (accept) or refresh (undo) after the paste of Smart View data.
PasteShowOverwriteWarning | On forecast values paste, do we show a data overwrite warning.
ShowAllErrorMeasures | Show all error measures in statistics grid.
ShowStatistics | Show statistics grid on results window.

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences.ConfidenceInterval Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::ConfidenceInterval Property
The selected confidence interval.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredConfidenceType ConfidenceInterval { get; set; }
Public Property ConfidenceInterval As PredConfidenceType
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As PredConfidenceType

value = instance.ConfidenceInterval

instance.ConfidenceInterval = value

Property Value

PredConfidenceType

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences.ConfidenceLower Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::ConfidenceLower Property
Lower confidence interval percentage value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ConfidenceLower { get; }
Public ReadOnly Property ConfidenceLower As Double
    Get
Dim instance As PredResultsPreferences
Dim value As Double

value = instance.ConfidenceLower

Property Value

Double

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences.ConfidenceUpper Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::ConfidenceUpper Property
Upper confidence interval percentage value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ConfidenceUpper { get; }
Public ReadOnly Property ConfidenceUpper As Double
    Get
Dim instance As PredResultsPreferences
Dim value As Double

value = instance.ConfidenceUpper

Property Value

Double

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences.ForecastPeriods Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::ForecastPeriods Property
Periods to forecast.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ForecastPeriods { get; set; }
Public Property ForecastPeriods As Integer
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Integer

value = instance.ForecastPeriods

instance.ForecastPeriods = value

Property Value

Int32

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences.HighlightEvents Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::HighlightEvents Property
Highlight events. This determines if the events are highlighted in the results display.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HighlightEvents { get; set; }
Public Property HighlightEvents As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.HighlightEvents

instance.HighlightEvents = value

Property Value

Boolean

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences.HighlightScreenedData Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::HighlightScreenedData Property
Highlight screened data. This determines if the missing and adjusted values are highlighted in the results display.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HighlightScreenedData { get; set; }
Public Property HighlightScreenedData As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.HighlightScreenedData

instance.HighlightScreenedData = value

Property Value

Boolean

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences.HighlightSeasonality Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::HighlightSeasonality Property
Highlight seasonality. This determines if the seasonal cycle is highlighted in the results display.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HighlightSeasonality { get; set; }
Public Property HighlightSeasonality As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.HighlightSeasonality

instance.HighlightSeasonality = value

Property Value

Boolean

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences.PasteShowExternalDataSubmitWarning Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::PasteShowExternalDataSubmitWarning Property
On forecast values paste, do we show a warning that a user must submit (accept) or refresh (undo) after the paste of Smart View data.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool PasteShowExternalDataSubmitWarning { get; set; }
Public Property PasteShowExternalDataSubmitWarning As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.PasteShowExternalDataSubmitWarning

instance.PasteShowExternalDataSubmitWarning = value

Property Value

Boolean

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences.PasteShowOverwriteWarning Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::PasteShowOverwriteWarning Property
On forecast values paste, do we show a data overwrite warning.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool PasteShowOverwriteWarning { get; set; }
Public Property PasteShowOverwriteWarning As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.PasteShowOverwriteWarning

instance.PasteShowOverwriteWarning = value

Property Value

Boolean

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences.ShowAllErrorMeasures Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::ShowAllErrorMeasures Property
Show all error measures in statistics grid.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowAllErrorMeasures { get; set; }
Public Property ShowAllErrorMeasures As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.ShowAllErrorMeasures

instance.ShowAllErrorMeasures = value

Property Value

Boolean

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences.ShowStatistics Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::ShowStatistics Property
Show statistics grid on results window.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowStatistics { get; set; }
Public Property ShowStatistics As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.ShowStatistics

instance.ShowStatistics = value

Property Value

Boolean

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredResultsWindow Class
Interface for the Predictor Results Window. Provides access to the results window and allows setting items such as selected series and method.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredResultsWindow
Public Class PredResultsWindow
Dim instance As PredResultsWindow

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CurrentARIMAMethod | Currently selected ARIMA model for currently selected series Valid only for Custom ARIMA.
CurrentARIMAMethods | Returns the list of all ARIMA models for currently selected series.
CurrentMethod | Currently selected method.
CurrentMethodDisplay | Currently selected method display name.
CurrentMethodRank | Currently selected method by method rank.
CurrentMethods | List of currently available methods in rank order.
CurrentSeries | The currently selected series.
CurrentSeriesDisplay | Current selected series display name.
DisplayedScreenedValues | Number of screened values for current series and method.
DisplayedValues | Number of displayed values.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FootnoteText | Returns the current summary footnote text as displayed in the results window, includes info about missing values, outliers and events if applicable.
GetCellValue(PredictorGridType, Int32, Int32, Boolean) | Returns the displayed value within the statistics grid at the column and row location specified.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
OverrideBestMethod()()()() | Set currently selected method as best method.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
View | The active results window view.
Visible | Is results form visible.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredResultsWindow

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow Methods

Visual Basic Usage

CB Com Devkit
PredResultsWindow Methods

The PredResultsWindow type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCellValue(PredictorGridType, Int32, Int32, Boolean) | Returns the displayed value within the statistics grid at the column and row location specified.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
OverrideBestMethod()()()() | Set currently selected method as best method.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.GetCellValue Method

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::GetCellValue Method
Returns the displayed value within the statistics grid at the column and row location specified.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string GetCellValue(
    PredictorGridType gridType,
    int columnIndex,
    int rowIndex,
    bool format = false
)
Public Function GetCellValue (
    gridType As PredictorGridType,
    columnIndex As Integer,
    rowIndex As Integer,
    Optional format As Boolean = false
) As String
Dim instance As PredResultsWindow
Dim gridType As PredictorGridType
Dim columnIndex As Integer
Dim rowIndex As Integer
Dim format As Boolean
Dim returnValue As String

returnValue = instance.GetCellValue(gridType,
    columnIndex, rowIndex, format)

Parameters

gridType
PredictorGridType
The grid to search within.
columnIndex
Int32
The column index (1-based)
rowIndex
Int32
The row index (1-based)
format (Optional)
Boolean
Optional, get the string with cell formatting applied

Return Value

String
The text as displayed in the cell.

Remarks

If the gridType passed in is not on the current View, then the View is changed to ensure that the grid is visible. The column and row index values are 1-based. Row and column headers are considered within the indexes. If the Results Window is not currenlty visible, it will become visible

Exceptions

Exception | Condition
CBExceptionIDGridInvalidRowOrColumnIndex | The value of the row or column index is invalid

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.OverrideBestMethod Method

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::OverrideBestMethod Method
Set currently selected method as best method.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void OverrideBestMethod()
Public Sub OverrideBestMethod
Dim instance As PredResultsWindow

instance.OverrideBestMethod()

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow Properties

Visual Basic Usage

CB Com Devkit
PredResultsWindow Properties

The PredResultsWindow type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CurrentARIMAMethod | Currently selected ARIMA model for currently selected series Valid only for Custom ARIMA.
CurrentARIMAMethods | Returns the list of all ARIMA models for currently selected series.
CurrentMethod | Currently selected method.
CurrentMethodDisplay | Currently selected method display name.
CurrentMethodRank | Currently selected method by method rank.
CurrentMethods | List of currently available methods in rank order.
CurrentSeries | The currently selected series.
CurrentSeriesDisplay | Current selected series display name.
DisplayedScreenedValues | Number of screened values for current series and method.
DisplayedValues | Number of displayed values.
FootnoteText | Returns the current summary footnote text as displayed in the results window, includes info about missing values, outliers and events if applicable.
View | The active results window view.
Visible | Is results form visible.

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.CurrentARIMAMethod Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentARIMAMethod Property
Currently selected ARIMA model for currently selected series Valid only for Custom ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMAModel CurrentARIMAMethod { get; set; }
Public Property CurrentARIMAMethod As PredARIMAModel
    Get
    Set
Dim instance As PredResultsWindow
Dim value As PredARIMAModel

value = instance.CurrentARIMAMethod

instance.CurrentARIMAMethod = value

Property Value

PredARIMAModel

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.CurrentARIMAMethods Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentARIMAMethods Property
Returns the list of all ARIMA models for currently selected series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ARIMAModelEnumerator CurrentARIMAMethods { get; }
Public ReadOnly Property CurrentARIMAMethods As ARIMAModelEnumerator
    Get
Dim instance As PredResultsWindow
Dim value As ARIMAModelEnumerator

value = instance.CurrentARIMAMethods

Property Value

ARIMAModelEnumerator

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.CurrentMethod Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentMethod Property
Currently selected method.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastMethodType CurrentMethod { get; set; }
Public Property CurrentMethod As PredForecastMethodType
    Get
    Set
Dim instance As PredResultsWindow
Dim value As PredForecastMethodType

value = instance.CurrentMethod

instance.CurrentMethod = value

Property Value

PredForecastMethodType

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.CurrentMethodDisplay Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentMethodDisplay Property
Currently selected method display name.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string CurrentMethodDisplay { get; }
Public ReadOnly Property CurrentMethodDisplay As String
    Get
Dim instance As PredResultsWindow
Dim value As String

value = instance.CurrentMethodDisplay

Property Value

String

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.CurrentMethodRank Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentMethodRank Property
Currently selected method by method rank.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int CurrentMethodRank { get; set; }
Public Property CurrentMethodRank As Integer
    Get
    Set
Dim instance As PredResultsWindow
Dim value As Integer

value = instance.CurrentMethodRank

instance.CurrentMethodRank = value

Property Value

Int32

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.CurrentMethods Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentMethods Property
List of currently available methods in rank order.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public MethodEnumerator CurrentMethods { get; }
Public ReadOnly Property CurrentMethods As MethodEnumerator
    Get
Dim instance As PredResultsWindow
Dim value As MethodEnumerator

value = instance.CurrentMethods

Property Value

MethodEnumerator

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.CurrentSeries Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentSeries Property
The currently selected series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int CurrentSeries { get; set; }
Public Property CurrentSeries As Integer
    Get
    Set
Dim instance As PredResultsWindow
Dim value As Integer

value = instance.CurrentSeries

instance.CurrentSeries = value

Property Value

Int32

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.CurrentSeriesDisplay Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentSeriesDisplay Property
Current selected series display name.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string CurrentSeriesDisplay { get; }
Public ReadOnly Property CurrentSeriesDisplay As String
    Get
Dim instance As PredResultsWindow
Dim value As String

value = instance.CurrentSeriesDisplay

Property Value

String

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.DisplayedScreenedValues Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::DisplayedScreenedValues Property
Number of screened values for current series and method.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int DisplayedScreenedValues { get; }
Public ReadOnly Property DisplayedScreenedValues As Integer
    Get
Dim instance As PredResultsWindow
Dim value As Integer

value = instance.DisplayedScreenedValues

Property Value

Int32

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.DisplayedValues Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::DisplayedValues Property
Number of displayed values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int DisplayedValues { get; }
Public ReadOnly Property DisplayedValues As Integer
    Get
Dim instance As PredResultsWindow
Dim value As Integer

value = instance.DisplayedValues

Property Value

Int32

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.FootnoteText Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::FootnoteText Property
Returns the current summary footnote text as displayed in the results window, includes info about missing values, outliers and events if applicable.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string FootnoteText { get; }
Public ReadOnly Property FootnoteText As String
    Get
Dim instance As PredResultsWindow
Dim value As String

value = instance.FootnoteText

Property Value

String

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.View Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::View Property
The active results window view.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredictorViewType View { get; set; }
Public Property View As PredictorViewType
    Get
    Set
Dim instance As PredResultsWindow
Dim value As PredictorViewType

value = instance.View

instance.View = value

Property Value

PredictorViewType

Remarks

If the Results Window is not currenlty visible, it will become visible

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow.Visible Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::Visible Property
Is results form visible.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
Dim instance As PredResultsWindow
Dim value As Boolean

value = instance.Visible

instance.Visible = value

Property Value

Boolean

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeasonality Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredSeasonality Class
Series seasonality settings. Provides access to series seasonality settings such as seasonality type and seasonal cycle.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredSeasonality
Public Class PredSeasonality
Dim instance As PredSeasonality

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cycle | Seasonal data cycle value.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IsSeasonal | Does this series contain seasonal data.
SeasonalityType | Seasonality type. Default is AutoDetect.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredSeasonality

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeasonality Methods

Visual Basic Usage

CB Com Devkit
PredSeasonality Methods

The PredSeasonality type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredSeasonality Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeasonality Properties

Visual Basic Usage

CB Com Devkit
PredSeasonality Properties

The PredSeasonality type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cycle | Seasonal data cycle value.
IsSeasonal | Does this series contain seasonal data.
SeasonalityType | Seasonality type. Default is AutoDetect.

See Also

PredSeasonality Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeasonality.Cycle Property

Visual Basic Usage

CB Com Devkit
PredSeasonality..::Cycle Property
Seasonal data cycle value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int Cycle { get; set; }
Public Property Cycle As Integer
    Get
    Set
Dim instance As PredSeasonality
Dim value As Integer

value = instance.Cycle

instance.Cycle = value

Property Value

Int32

See Also

PredSeasonality Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeasonality.IsSeasonal Property

Visual Basic Usage

CB Com Devkit
PredSeasonality..::IsSeasonal Property
Does this series contain seasonal data.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsSeasonal { get; set; }
Public Property IsSeasonal As Boolean
    Get
    Set
Dim instance As PredSeasonality
Dim value As Boolean

value = instance.IsSeasonal

instance.IsSeasonal = value

Property Value

Boolean

See Also

PredSeasonality Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeasonality.SeasonalityType Property

Visual Basic Usage

CB Com Devkit
PredSeasonality..::SeasonalityType Property
Seasonality type. Default is AutoDetect.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeasonalityType SeasonalityType { get; set; }
Public Property SeasonalityType As PredSeasonalityType
    Get
    Set
Dim instance As PredSeasonality
Dim value As PredSeasonalityType

value = instance.SeasonalityType

instance.SeasonalityType = value

Property Value

PredSeasonalityType

See Also

PredSeasonality Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeasonalityType Enumeration

Visual Basic Usage

CB Com Devkit
PredSeasonalityType Enumeration
Seasonality type options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredSeasonalityType
Public Enumeration PredSeasonalityType
Dim instance As PredSeasonalityType

Members

Member | Value | Description
AutoDetect | 0 | Let Predictor detect seasonality from input data.
NonSeasonal | 1 | Series contains non-seasonal data.
Seasonal | 2 | Series contains seasonal data.

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredSeries Class
The main interface to input series specific settings. This provides access to information such as series name, Excel number format, seasonality and cycle, regression variable details, statistics, and series data values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredSeries
Public Class PredSeries
Dim instance As PredSeries

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BestMethodForOutlierAdjustment | Best fit method found for the current error measure.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractData(Range, PredForecastMethodType, Boolean, Boolean, PredARIMAModel) | Extract input data into an Excel range.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetStatistics(PredForecastMethodType, Boolean, Boolean, PredARIMAModel) | Get series statistics by method.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MethodsForOutlierAdjustment | Methods fit for current outlier adjustment settings, ordered by fit rank for the current error measure.
Name | Series name.
NumberFormat | Series data source Excel number format string.
NumberOfAdjustedValues(PredForecastMethodType) | Number of data points detected as an outlier and adjusted for this series.
NumberOfFilledInValues | Number of data points filled in for this series.
NumberOfValues | Number of data points in this series.
Range | Series data source Excel Range.
Regression | Series regression variable settings.
Seasonality | Series seasonality settings.
Statistics | Series basic statistics.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate series settings.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredSeries

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries Methods

Visual Basic Usage

CB Com Devkit
PredSeries Methods

The PredSeries type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractData(Range, PredForecastMethodType, Boolean, Boolean, PredARIMAModel) | Extract input data into an Excel range.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetStatistics(PredForecastMethodType, Boolean, Boolean, PredARIMAModel) | Get series statistics by method.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
NumberOfAdjustedValues(PredForecastMethodType) | Number of data points detected as an outlier and adjusted for this series.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate series settings.

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.ExtractData Method

Visual Basic Usage

CB Com Devkit
PredSeries..::ExtractData Method
Extract input data into an Excel range.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ExtractData(
    Range startCell,
    PredForecastMethodType method,
    bool ShowScreenedDataOnly = false,
    bool ShowPreadjustedOutliers = false,
    PredARIMAModel ARIMAModel = null
)
Public Sub ExtractData (
    startCell As Range,
    method As PredForecastMethodType,
    Optional ShowScreenedDataOnly As Boolean = false,
    Optional ShowPreadjustedOutliers As Boolean = false,
    Optional ARIMAModel As PredARIMAModel = Nothing
)
Dim instance As PredSeries
Dim startCell As Range
Dim method As PredForecastMethodType
Dim ShowScreenedDataOnly As Boolean
Dim ShowPreadjustedOutliers As Boolean
Dim ARIMAModel As PredARIMAModel

instance.ExtractData(startCell, method,
    ShowScreenedDataOnly, ShowPreadjustedOutliers,
    ARIMAModel)

Parameters

startCell
Range
Starting cell for data extract.
method
PredForecastMethodType
Method type to extract data for.
ShowScreenedDataOnly (Optional)
Boolean
Optionally choose screened data only.
ShowPreadjustedOutliers (Optional)
Boolean
Optionally choose pre-adjusted input data.
ARIMAModel (Optional)
PredARIMAModel
Optional ARIMA model to be used

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.GetStatistics Method

Visual Basic Usage

CB Com Devkit
PredSeries..::GetStatistics Method
Get series statistics by method.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredStatistics GetStatistics(
    PredForecastMethodType method,
    bool UseDetrendedLags = true,
    bool ShowPreadjustedOutliers = false,
    PredARIMAModel ARIMAModel = null
)
Public Function GetStatistics (
    method As PredForecastMethodType,
    Optional UseDetrendedLags As Boolean = true,
    Optional ShowPreadjustedOutliers As Boolean = false,
    Optional ARIMAModel As PredARIMAModel = Nothing
) As PredStatistics
Dim instance As PredSeries
Dim method As PredForecastMethodType
Dim UseDetrendedLags As Boolean
Dim ShowPreadjustedOutliers As Boolean
Dim ARIMAModel As PredARIMAModel
Dim returnValue As PredStatistics

returnValue = instance.GetStatistics(method,
    UseDetrendedLags, ShowPreadjustedOutliers,
    ARIMAModel)

Parameters

method
PredForecastMethodType
Method type to get statistics for.
UseDetrendedLags (Optional)
Boolean
Optionally choose to get de-trended autocorrelation lags.
ShowPreadjustedOutliers (Optional)
Boolean
Optionally choose to get statistics for pre-adjusted input data.
ARIMAModel (Optional)
PredARIMAModel
Optional ARIMA model to be used

Return Value

PredStatistics
the requested statistics

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.NumberOfAdjustedValues Method

Visual Basic Usage

CB Com Devkit
PredSeries..::NumberOfAdjustedValues Method
Number of data points detected as an outlier and adjusted for this series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfAdjustedValues(
    PredForecastMethodType method
)
Public Function NumberOfAdjustedValues (
    method As PredForecastMethodType
) As Integer
Dim instance As PredSeries
Dim method As PredForecastMethodType
Dim returnValue As Integer

returnValue = instance.NumberOfAdjustedValues(method)

Parameters

method
PredForecastMethodType
Method type to access number of adjusted outlier for

Return Value

Int32
Number of adjusted outliers

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.Validate Method

Visual Basic Usage

CB Com Devkit
PredSeries..::Validate Method
Validate series settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredSeries
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

Boolean
true if successful

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries Properties

Visual Basic Usage

CB Com Devkit
PredSeries Properties

The PredSeries type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BestMethodForOutlierAdjustment | Best fit method found for the current error measure.
MethodsForOutlierAdjustment | Methods fit for current outlier adjustment settings, ordered by fit rank for the current error measure.
Name | Series name.
NumberFormat | Series data source Excel number format string.
NumberOfFilledInValues | Number of data points filled in for this series.
NumberOfValues | Number of data points in this series.
Range | Series data source Excel Range.
Regression | Series regression variable settings.
Seasonality | Series seasonality settings.
Statistics | Series basic statistics.

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.BestMethodForOutlierAdjustment Property

Visual Basic Usage

CB Com Devkit
PredSeries..::BestMethodForOutlierAdjustment Property
Best fit method found for the current error measure.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastMethodType BestMethodForOutlierAdjustment { get; }
Public ReadOnly Property BestMethodForOutlierAdjustment As PredForecastMethodType
    Get
Dim instance As PredSeries
Dim value As PredForecastMethodType

value = instance.BestMethodForOutlierAdjustment

Property Value

PredForecastMethodType

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.MethodsForOutlierAdjustment Property

Visual Basic Usage

CB Com Devkit
PredSeries..::MethodsForOutlierAdjustment Property
Methods fit for current outlier adjustment settings, ordered by fit rank for the current error measure.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastMethodType[] MethodsForOutlierAdjustment { get; }
Public ReadOnly Property MethodsForOutlierAdjustment As PredForecastMethodType()
    Get
Dim instance As PredSeries
Dim value As PredForecastMethodType()

value = instance.MethodsForOutlierAdjustment

Property Value

array< PredForecastMethodType >[]()[][]

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.Name Property

Visual Basic Usage

CB Com Devkit
PredSeries..::Name Property
Series name.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Dim instance As PredSeries
Dim value As String

value = instance.Name

Property Value

String

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.NumberFormat Property

Visual Basic Usage

CB Com Devkit
PredSeries..::NumberFormat Property
Series data source Excel number format string.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string NumberFormat { get; }
Public ReadOnly Property NumberFormat As String
    Get
Dim instance As PredSeries
Dim value As String

value = instance.NumberFormat

Property Value

String

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.NumberOfFilledInValues Property

Visual Basic Usage

CB Com Devkit
PredSeries..::NumberOfFilledInValues Property
Number of data points filled in for this series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfFilledInValues { get; }
Public ReadOnly Property NumberOfFilledInValues As Integer
    Get
Dim instance As PredSeries
Dim value As Integer

value = instance.NumberOfFilledInValues

Property Value

Int32

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.NumberOfValues Property

Visual Basic Usage

CB Com Devkit
PredSeries..::NumberOfValues Property
Number of data points in this series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfValues { get; }
Public ReadOnly Property NumberOfValues As Integer
    Get
Dim instance As PredSeries
Dim value As Integer

value = instance.NumberOfValues

Property Value

Int32

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.Range Property

Visual Basic Usage

CB Com Devkit
PredSeries..::Range Property
Series data source Excel Range.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range Range { get; }
Public ReadOnly Property Range As Range
    Get
Dim instance As PredSeries
Dim value As Range

value = instance.Range

Property Value

Range

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.Regression Property

Visual Basic Usage

CB Com Devkit
PredSeries..::Regression Property
Series regression variable settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredRegression Regression { get; }
Public ReadOnly Property Regression As PredRegression
    Get
Dim instance As PredSeries
Dim value As PredRegression

value = instance.Regression

Property Value

PredRegression

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.Seasonality Property

Visual Basic Usage

CB Com Devkit
PredSeries..::Seasonality Property
Series seasonality settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeasonality Seasonality { get; }
Public ReadOnly Property Seasonality As PredSeasonality
    Get
Dim instance As PredSeries
Dim value As PredSeasonality

value = instance.Seasonality

Property Value

PredSeasonality

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries.Statistics Property

Visual Basic Usage

CB Com Devkit
PredSeries..::Statistics Property
Series basic statistics.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredStatistics Statistics { get; }
Public ReadOnly Property Statistics As PredStatistics
    Get
Dim instance As PredSeries
Dim value As PredStatistics

value = instance.Statistics

Property Value

PredStatistics

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredSeriesEnumerator Class
List of series in input data set.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredSeriesEnumerator : IObjectEnumerator,
    IEnumerable, IEnumerator
Public Class PredSeriesEnumerator
    Implements IObjectEnumerator, IEnumerable, IEnumerator
Dim instance As PredSeriesEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get series by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredSeriesEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator Methods

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator Methods

The PredSeriesEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator.GetEnumerator Method

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::GetEnumerator Method
Returns an enumerator for these series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As PredSeriesEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

IEnumerator
the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator.MoveNext Method

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid series

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As PredSeriesEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

Boolean
true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As PredSeriesEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
true if successful

Implements

IObjectEnumerator..::..Reload()()()()

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator.Reset Method

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first series).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As PredSeriesEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator Properties

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator Properties

The PredSeriesEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Item[([( Int32])]) | Get series by index.

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::Count Property
Returns the series count

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As PredSeriesEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

Implements

IObjectEnumerator..::..Count

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::Current Property
Returns the current series (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As PredSeriesEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::Item Property
Get series by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeries this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As PredSeries
    Get
Dim instance As PredSeriesEnumerator
Dim index As Integer
Dim value As PredSeries

value = instance(index)

Parameters

index
Int32

Return Value

PredSeries

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredSeriesResult Class
The main interface to output series specific settings. This provides access to information such as series name, Excel number format, forecast adjustments, statistics, and series data values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredSeriesResult
Public Class PredSeriesResult
Dim instance As PredSeriesResult

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjustForecast | Forecast adjustment settings.
BestMethod | Best fit method found for the current error measure.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractData(Range, PredForecastMethodType, Boolean, PredARIMAModel) | Extract input data into an Excel range.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetStatistics(PredForecastMethodType, Boolean, PredARIMAModel) | Get series statistics by method.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Methods | Methods fit for current outlier adjustment settings, ordered by fit rank for the current error measure.
Name | Series name.
NumberFormat | Series data source Excel range number format string.
NumberOfAdjustedValues(PredForecastMethodType) | Number of data points detected as an outlier and adjusted for this series.
NumberOfFilledInValues | Number of data points filled in for this series.
NumberOfValues | Number of data points in this series.
Range | Series data source Excel range.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredSeriesResult

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult Methods

Visual Basic Usage

CB Com Devkit
PredSeriesResult Methods

The PredSeriesResult type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractData(Range, PredForecastMethodType, Boolean, PredARIMAModel) | Extract input data into an Excel range.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetStatistics(PredForecastMethodType, Boolean, PredARIMAModel) | Get series statistics by method.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
NumberOfAdjustedValues(PredForecastMethodType) | Number of data points detected as an outlier and adjusted for this series.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult.ExtractData Method

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::ExtractData Method
Extract input data into an Excel range.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ExtractData(
    Range startCell,
    PredForecastMethodType method,
    bool ForecastOnly = false,
    PredARIMAModel ARIMAModel = null
)
Public Sub ExtractData (
    startCell As Range,
    method As PredForecastMethodType,
    Optional ForecastOnly As Boolean = false,
    Optional ARIMAModel As PredARIMAModel = Nothing
)
Dim instance As PredSeriesResult
Dim startCell As Range
Dim method As PredForecastMethodType
Dim ForecastOnly As Boolean
Dim ARIMAModel As PredARIMAModel

instance.ExtractData(startCell, method,
    ForecastOnly, ARIMAModel)

Parameters

startCell
Range
Starting cell for data extract.
method
PredForecastMethodType
Method type to extract data for.
ForecastOnly (Optional)
Boolean
Optionally choose to extract forecast periods only. Default is false
ARIMAModel (Optional)
PredARIMAModel
Optional ARIMA model to be used

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult.GetStatistics Method

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::GetStatistics Method
Get series statistics by method.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredStatistics GetStatistics(
    PredForecastMethodType method,
    bool UseDetrendedLags = true,
    PredARIMAModel ARIMAModel = null
)
Public Function GetStatistics (
    method As PredForecastMethodType,
    Optional UseDetrendedLags As Boolean = true,
    Optional ARIMAModel As PredARIMAModel = Nothing
) As PredStatistics
Dim instance As PredSeriesResult
Dim method As PredForecastMethodType
Dim UseDetrendedLags As Boolean
Dim ARIMAModel As PredARIMAModel
Dim returnValue As PredStatistics

returnValue = instance.GetStatistics(method,
    UseDetrendedLags, ARIMAModel)

Parameters

method
PredForecastMethodType
Method type to get statistics for.
UseDetrendedLags (Optional)
Boolean
Optionally choose to get de-trended autocorrelation lags.
ARIMAModel (Optional)
PredARIMAModel
Optional ARIMA model to be used

Return Value

PredStatistics
the requested statistics

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult.NumberOfAdjustedValues Method

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::NumberOfAdjustedValues Method
Number of data points detected as an outlier and adjusted for this series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfAdjustedValues(
    PredForecastMethodType method
)
Public Function NumberOfAdjustedValues (
    method As PredForecastMethodType
) As Integer
Dim instance As PredSeriesResult
Dim method As PredForecastMethodType
Dim returnValue As Integer

returnValue = instance.NumberOfAdjustedValues(method)

Parameters

method
PredForecastMethodType
Method type to access number of adjusted outlier for

Return Value

Int32
Number of adjusted outliers

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult Properties

Visual Basic Usage

CB Com Devkit
PredSeriesResult Properties

The PredSeriesResult type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjustForecast | Forecast adjustment settings.
BestMethod | Best fit method found for the current error measure.
Methods | Methods fit for current outlier adjustment settings, ordered by fit rank for the current error measure.
Name | Series name.
NumberFormat | Series data source Excel range number format string.
NumberOfFilledInValues | Number of data points filled in for this series.
NumberOfValues | Number of data points in this series.
Range | Series data source Excel range.

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult.AdjustForecast Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::AdjustForecast Property
Forecast adjustment settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredAdjustForecast AdjustForecast { get; }
Public ReadOnly Property AdjustForecast As PredAdjustForecast
    Get
Dim instance As PredSeriesResult
Dim value As PredAdjustForecast

value = instance.AdjustForecast

Property Value

PredAdjustForecast

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult.BestMethod Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::BestMethod Property
Best fit method found for the current error measure.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastMethodType BestMethod { get; set; }
Public Property BestMethod As PredForecastMethodType
    Get
    Set
Dim instance As PredSeriesResult
Dim value As PredForecastMethodType

value = instance.BestMethod

instance.BestMethod = value

Property Value

PredForecastMethodType

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult.Methods Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::Methods Property
Methods fit for current outlier adjustment settings, ordered by fit rank for the current error measure.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastMethodType[] Methods { get; }
Public ReadOnly Property Methods As PredForecastMethodType()
    Get
Dim instance As PredSeriesResult
Dim value As PredForecastMethodType()

value = instance.Methods

Property Value

array< PredForecastMethodType >[]()[][]

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult.Name Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::Name Property
Series name.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Dim instance As PredSeriesResult
Dim value As String

value = instance.Name

Property Value

String

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult.NumberFormat Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::NumberFormat Property
Series data source Excel range number format string.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string NumberFormat { get; }
Public ReadOnly Property NumberFormat As String
    Get
Dim instance As PredSeriesResult
Dim value As String

value = instance.NumberFormat

Property Value

String

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult.NumberOfFilledInValues Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::NumberOfFilledInValues Property
Number of data points filled in for this series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfFilledInValues { get; }
Public ReadOnly Property NumberOfFilledInValues As Integer
    Get
Dim instance As PredSeriesResult
Dim value As Integer

value = instance.NumberOfFilledInValues

Property Value

Int32

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult.NumberOfValues Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::NumberOfValues Property
Number of data points in this series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfValues { get; }
Public ReadOnly Property NumberOfValues As Integer
    Get
Dim instance As PredSeriesResult
Dim value As Integer

value = instance.NumberOfValues

Property Value

Int32

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult.Range Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::Range Property
Series data source Excel range.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range Range { get; }
Public ReadOnly Property Range As Range
    Get
Dim instance As PredSeriesResult
Dim value As Range

value = instance.Range

Property Value

Range

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredSeriesResultEnumerator Class
List of series in results set.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredSeriesResultEnumerator : IObjectEnumerator,
    IEnumerable, IEnumerator
Public Class PredSeriesResultEnumerator
    Implements IObjectEnumerator, IEnumerable, IEnumerator
Dim instance As PredSeriesResultEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Access series result by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredSeriesResultEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator Methods

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator Methods

The PredSeriesResultEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator.GetEnumerator Method

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::GetEnumerator Method
Returns an enumerator for these series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As PredSeriesResultEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

IEnumerator
the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator.MoveNext Method

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid series

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As PredSeriesResultEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

Boolean
true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As PredSeriesResultEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
true if successful

Implements

IObjectEnumerator..::..Reload()()()()

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator.Reset Method

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first series).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As PredSeriesResultEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator Properties

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator Properties

The PredSeriesResultEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Item[([( Int32])]) | Access series result by index.

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::Count Property
Returns the series count

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As PredSeriesResultEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

Implements

IObjectEnumerator..::..Count

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::Current Property
Returns the current series (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As PredSeriesResultEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::Item Property
Access series result by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeriesResult this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As PredSeriesResult
    Get
Dim instance As PredSeriesResultEnumerator
Dim index As Integer
Dim value As PredSeriesResult

value = instance(index)

Parameters

index
Int32

Return Value

PredSeriesResult

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredSetup Class
Predictor Setup / Definition Provides an interface to define a predictor run. This is the top level interface class that provides access to objects to set and define all predictor settings available through the wizard

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredSetup
Public Class PredSetup
Dim instance As PredSetup

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PredSetup()()()() | Predictor Setup / Definition Provides an interface to define a predictor run. This is the top level interface class that provides access to objects to set and define all predictor settings available through the wizard
AutoDetect(Range) | Set the time series data input range. This will auto detect the range containing the current Excel selection, or if an initialRange is specified this will be used as the input range. The selection or initialRange can be a single-cell or multi-cell selection or a discontiguous range. AutoDetect performs all the actions performed when the Predictor Wizard is displayed. Depending on current selection and saved state it may run the autodetection or reuse the saved preferences.
DataAttributes | Access to data attribute setting corresponding the the Predictor wizard Data Attributes panel. This lets you control items such as seasonality, screening and outlier detection.
DeleteAutodetectData()()()() | Delete all data collected by Predictor auto-detection.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InputData | Access to input data properties corresponding the the Predictor wizard Input Data panel. This lets you control items such as data orientation and headers.
Methods | Access to methods settings corresponding the Predictor Methods panel. This lets you control what methods to use and method parameters.
Options | Access to predictor options corresponding to the Predictor Options panel. This povides access to options such as error measure and forecasting technique.
Run()()()() | Run predictor with current input data and configured settings. Runs the predictor forecast and puts crystal ball into a predictor run state where you can access results from the PredResults interface.
SelectiveAutoDetect(Boolean, Boolean, Boolean) | This method provides control of the startup process so it can be used to test the various detections that are performed during Predictor startup. If ForceSeriesDetection is set to false, the series will be created based on the saved data range (an error is issued if it was not saved previously).
Series | The list of currently selected series from the input range. The list is ordered by position in the input range, left to right for column oriented data or top to bottom for row oriented data. This provides access to series specific information such as seasonality and regression variable details.
Setup()()()() | Similar to AutoDetect but this method additionally validates the Predictor properties. Internally it’s implemented as a call to AutoDetect() followed by call to Validate(False).
Show()()()() | Show the Predictor Wizard GUI
ThrowErrors | Setting to determine whether to throw errors to the client app
ThrowWarningsAsErrors | Setting to determine whether to throw warnings to the client app
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate(Boolean) | Validate all Predictor settings for current storage worksheet

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredSetup

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup Constructor

Visual Basic Usage

CB Com Devkit
PredSetup Constructor
Predictor Setup / Definition Provides an interface to define a predictor run. This is the top level interface class that provides access to objects to set and define all predictor settings available through the wizard

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSetup()
Public Sub New
Dim instance As New PredSetup()

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup Methods

Visual Basic Usage

CB Com Devkit
PredSetup Methods

The PredSetup type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AutoDetect(Range) | Set the time series data input range. This will auto detect the range containing the current Excel selection, or if an initialRange is specified this will be used as the input range. The selection or initialRange can be a single-cell or multi-cell selection or a discontiguous range. AutoDetect performs all the actions performed when the Predictor Wizard is displayed. Depending on current selection and saved state it may run the autodetection or reuse the saved preferences.
DeleteAutodetectData()()()() | Delete all data collected by Predictor auto-detection.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Run()()()() | Run predictor with current input data and configured settings. Runs the predictor forecast and puts crystal ball into a predictor run state where you can access results from the PredResults interface.
SelectiveAutoDetect(Boolean, Boolean, Boolean) | This method provides control of the startup process so it can be used to test the various detections that are performed during Predictor startup. If ForceSeriesDetection is set to false, the series will be created based on the saved data range (an error is issued if it was not saved previously).
Setup()()()() | Similar to AutoDetect but this method additionally validates the Predictor properties. Internally it’s implemented as a call to AutoDetect() followed by call to Validate(False).
Show()()()() | Show the Predictor Wizard GUI
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate(Boolean) | Validate all Predictor settings for current storage worksheet

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.AutoDetect Method

Visual Basic Usage

CB Com Devkit
PredSetup..::AutoDetect Method
Set the time series data input range. This will auto detect the range containing the current Excel selection, or if an initialRange is specified this will be used as the input range. The selection or initialRange can be a single-cell or multi-cell selection or a discontiguous range. AutoDetect performs all the actions performed when the Predictor Wizard is displayed. Depending on current selection and saved state it may run the autodetection or reuse the saved preferences.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void AutoDetect(
    Range initialRange = null
)
Public Sub AutoDetect (
    Optional initialRange As Range = Nothing
)
Dim instance As PredSetup
Dim initialRange As Range

instance.AutoDetect(initialRange)

Parameters

initialRange (Optional)
Range
optional intitial range to indicate where auto-detection should start (current selection used if not specified)

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.DeleteAutodetectData Method

Visual Basic Usage

CB Com Devkit
PredSetup..::DeleteAutodetectData Method
Delete all data collected by Predictor auto-detection.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void DeleteAutodetectData()
Public Sub DeleteAutodetectData
Dim instance As PredSetup

instance.DeleteAutodetectData()

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.Run Method

Visual Basic Usage

CB Com Devkit
PredSetup..::Run Method
Run predictor with current input data and configured settings. Runs the predictor forecast and puts crystal ball into a predictor run state where you can access results from the PredResults interface.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Run()
Public Sub Run
Dim instance As PredSetup

instance.Run()

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.SelectiveAutoDetect Method

Visual Basic Usage

CB Com Devkit
PredSetup..::SelectiveAutoDetect Method
This method provides control of the startup process so it can be used to test the various detections that are performed during Predictor startup. If ForceSeriesDetection is set to false, the series will be created based on the saved data range (an error is issued if it was not saved previously).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SelectiveAutoDetect(
    bool ForceSeriesDetection,
    bool ForceDateTypeDetection,
    bool ForceSeasonalityDetection
)
Public Sub SelectiveAutoDetect (
    ForceSeriesDetection As Boolean,
    ForceDateTypeDetection As Boolean,
    ForceSeasonalityDetection As Boolean
)
Dim instance As PredSetup
Dim ForceSeriesDetection As Boolean
Dim ForceDateTypeDetection As Boolean
Dim ForceSeasonalityDetection As Boolean

instance.SelectiveAutoDetect(ForceSeriesDetection,
    ForceDateTypeDetection, ForceSeasonalityDetection)

Parameters

ForceSeriesDetection
Boolean
Force the detection of Predictor series
ForceDateTypeDetection
Boolean
Force the date type detection
ForceSeasonalityDetection
Boolean
Force the data seasonality detection

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.Setup Method

Visual Basic Usage

CB Com Devkit
PredSetup..::Setup Method
Similar to AutoDetect but this method additionally validates the Predictor properties. Internally it’s implemented as a call to AutoDetect() followed by call to Validate(False).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Setup()
Public Sub Setup
Dim instance As PredSetup

instance.Setup()

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.Show Method

Visual Basic Usage

CB Com Devkit
PredSetup..::Show Method
Show the Predictor Wizard GUI

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Show()
Public Function Show As Boolean
Dim instance As PredSetup
Dim returnValue As Boolean

returnValue = instance.Show()

Return Value

Boolean
true if no errors detected

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.Validate Method

Visual Basic Usage

CB Com Devkit
PredSetup..::Validate Method
Validate all Predictor settings for current storage worksheet

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate(
    bool ShowWizard
)
Public Function Validate (
    ShowWizard As Boolean
) As Boolean
Dim instance As PredSetup
Dim ShowWizard As Boolean
Dim returnValue As Boolean

returnValue = instance.Validate(ShowWizard)

Parameters

ShowWizard
Boolean
If true, show the Predictor Wizard if error is detected

Return Value

Boolean
true if no errors detected

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup Properties

Visual Basic Usage

CB Com Devkit
PredSetup Properties

The PredSetup type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DataAttributes | Access to data attribute setting corresponding the the Predictor wizard Data Attributes panel. This lets you control items such as seasonality, screening and outlier detection.
InputData | Access to input data properties corresponding the the Predictor wizard Input Data panel. This lets you control items such as data orientation and headers.
Methods | Access to methods settings corresponding the Predictor Methods panel. This lets you control what methods to use and method parameters.
Options | Access to predictor options corresponding to the Predictor Options panel. This povides access to options such as error measure and forecasting technique.
Series | The list of currently selected series from the input range. The list is ordered by position in the input range, left to right for column oriented data or top to bottom for row oriented data. This provides access to series specific information such as seasonality and regression variable details.
ThrowErrors | Setting to determine whether to throw errors to the client app
ThrowWarningsAsErrors | Setting to determine whether to throw warnings to the client app

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.DataAttributes Property

Visual Basic Usage

CB Com Devkit
PredSetup..::DataAttributes Property
Access to data attribute setting corresponding the the Predictor wizard Data Attributes panel. This lets you control items such as seasonality, screening and outlier detection.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredDataAttributes DataAttributes { get; }
Public ReadOnly Property DataAttributes As PredDataAttributes
    Get
Dim instance As PredSetup
Dim value As PredDataAttributes

value = instance.DataAttributes

Property Value

PredDataAttributes

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.InputData Property

Visual Basic Usage

CB Com Devkit
PredSetup..::InputData Property
Access to input data properties corresponding the the Predictor wizard Input Data panel. This lets you control items such as data orientation and headers.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredInputData InputData { get; }
Public ReadOnly Property InputData As PredInputData
    Get
Dim instance As PredSetup
Dim value As PredInputData

value = instance.InputData

Property Value

PredInputData

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.Methods Property

Visual Basic Usage

CB Com Devkit
PredSetup..::Methods Property
Access to methods settings corresponding the Predictor Methods panel. This lets you control what methods to use and method parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredMethods Methods { get; }
Public ReadOnly Property Methods As PredMethods
    Get
Dim instance As PredSetup
Dim value As PredMethods

value = instance.Methods

Property Value

PredMethods

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.Options Property

Visual Basic Usage

CB Com Devkit
PredSetup..::Options Property
Access to predictor options corresponding to the Predictor Options panel. This povides access to options such as error measure and forecasting technique.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredOptions Options { get; }
Public ReadOnly Property Options As PredOptions
    Get
Dim instance As PredSetup
Dim value As PredOptions

value = instance.Options

Property Value

PredOptions

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.Series Property

Visual Basic Usage

CB Com Devkit
PredSetup..::Series Property
The list of currently selected series from the input range. The list is ordered by position in the input range, left to right for column oriented data or top to bottom for row oriented data. This provides access to series specific information such as seasonality and regression variable details.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeriesEnumerator Series { get; }
Public ReadOnly Property Series As PredSeriesEnumerator
    Get
Dim instance As PredSetup
Dim value As PredSeriesEnumerator

value = instance.Series

Property Value

PredSeriesEnumerator

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.ThrowErrors Property

Visual Basic Usage

CB Com Devkit
PredSetup..::ThrowErrors Property
Setting to determine whether to throw errors to the client app

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowErrors { get; set; }
Public Property ThrowErrors As Boolean
    Get
    Set
Dim instance As PredSetup
Dim value As Boolean

value = instance.ThrowErrors

instance.ThrowErrors = value

Property Value

Boolean

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup.ThrowWarningsAsErrors Property

Visual Basic Usage

CB Com Devkit
PredSetup..::ThrowWarningsAsErrors Property
Setting to determine whether to throw warnings to the client app

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowWarningsAsErrors { get; set; }
Public Property ThrowWarningsAsErrors As Boolean
    Get
    Set
Dim instance As PredSetup
Dim value As Boolean

value = instance.ThrowWarningsAsErrors

instance.ThrowWarningsAsErrors = value

Property Value

Boolean

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredStatistics Class
Main interface to series statistics.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredStatistics
Public Class PredStatistics
Dim instance As PredStatistics

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjRSquared | Regression Adjusted RSquared statistic.
AIC | Value of the Akike’s Information Criterion
AICc | Value of the corrected AIC
Alpha | Method Alpha parameter.
Beta | Method Beta parameter.
BIC | Value of the Bayesian Information Criterion
DataValues | Number of historical data values in series.
DurbinWatson | Series DurbinWatson statistic.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ErrorMeasure | Selected error measure.
FProbability | Regression FProbability statistic.
FStatistic | Regression FStatistic statistic.
Gamma | Method Gamma parameter.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Lags | List of autocorrelation lags.
LjungBox | Series LjungBox statistic.
LjungBoxP | Series LjungBoxP statistic.
MAD | MAD error measure value.
MAPE | MAPE error measure value.
Maximum | Maximum series value.
Mean | Series mean value.
Minimum | Minimum series value.
Order | Method Order parameter.
RMSE | RMSE error measure value.
RSquared | Regression RSquared statistic.
SeasonalityCycle | Seasonal cycle for series. Value is 0 if series is non-seasonal.
StandardDeviation | Standard devistion of series values.
StandardError | Regression StandardError statistic.
TheilsU | Series TheilsU statistic.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredStatistics

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics Methods

Visual Basic Usage

CB Com Devkit
PredStatistics Methods

The PredStatistics type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics Properties

Visual Basic Usage

CB Com Devkit
PredStatistics Properties

The PredStatistics type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjRSquared | Regression Adjusted RSquared statistic.
AIC | Value of the Akike’s Information Criterion
AICc | Value of the corrected AIC
Alpha | Method Alpha parameter.
Beta | Method Beta parameter.
BIC | Value of the Bayesian Information Criterion
DataValues | Number of historical data values in series.
DurbinWatson | Series DurbinWatson statistic.
ErrorMeasure | Selected error measure.
FProbability | Regression FProbability statistic.
FStatistic | Regression FStatistic statistic.
Gamma | Method Gamma parameter.
Lags | List of autocorrelation lags.
LjungBox | Series LjungBox statistic.
LjungBoxP | Series LjungBoxP statistic.
MAD | MAD error measure value.
MAPE | MAPE error measure value.
Maximum | Maximum series value.
Mean | Series mean value.
Minimum | Minimum series value.
Order | Method Order parameter.
RMSE | RMSE error measure value.
RSquared | Regression RSquared statistic.
SeasonalityCycle | Seasonal cycle for series. Value is 0 if series is non-seasonal.
StandardDeviation | Standard devistion of series values.
StandardError | Regression StandardError statistic.
TheilsU | Series TheilsU statistic.

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.AdjRSquared Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::AdjRSquared Property
Regression Adjusted RSquared statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double AdjRSquared { get; }
Public ReadOnly Property AdjRSquared As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.AdjRSquared

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.AIC Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::AIC Property
Value of the Akike’s Information Criterion

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double AIC { get; }
Public ReadOnly Property AIC As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.AIC

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.AICc Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::AICc Property
Value of the corrected AIC

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double AICc { get; }
Public ReadOnly Property AICc As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.AICc

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.Alpha Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Alpha Property
Method Alpha parameter.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Alpha { get; }
Public ReadOnly Property Alpha As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.Alpha

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.Beta Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Beta Property
Method Beta parameter.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Beta { get; }
Public ReadOnly Property Beta As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.Beta

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.BIC Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::BIC Property
Value of the Bayesian Information Criterion

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double BIC { get; }
Public ReadOnly Property BIC As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.BIC

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.DataValues Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::DataValues Property
Number of historical data values in series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int DataValues { get; }
Public ReadOnly Property DataValues As Integer
    Get
Dim instance As PredStatistics
Dim value As Integer

value = instance.DataValues

Property Value

Int32

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.DurbinWatson Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::DurbinWatson Property
Series DurbinWatson statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double DurbinWatson { get; }
Public ReadOnly Property DurbinWatson As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.DurbinWatson

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.ErrorMeasure Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::ErrorMeasure Property
Selected error measure.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredErrorMeasureType ErrorMeasure { get; }
Public ReadOnly Property ErrorMeasure As PredErrorMeasureType
    Get
Dim instance As PredStatistics
Dim value As PredErrorMeasureType

value = instance.ErrorMeasure

Property Value

PredErrorMeasureType

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.FProbability Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::FProbability Property
Regression FProbability statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double FProbability { get; }
Public ReadOnly Property FProbability As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.FProbability

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.FStatistic Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::FStatistic Property
Regression FStatistic statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double FStatistic { get; }
Public ReadOnly Property FStatistic As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.FStatistic

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.Gamma Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Gamma Property
Method Gamma parameter.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Gamma { get; }
Public ReadOnly Property Gamma As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.Gamma

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.Lags Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Lags Property
List of autocorrelation lags.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredLagEnumerator Lags { get; }
Public ReadOnly Property Lags As PredLagEnumerator
    Get
Dim instance As PredStatistics
Dim value As PredLagEnumerator

value = instance.Lags

Property Value

PredLagEnumerator

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.LjungBox Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::LjungBox Property
Series LjungBox statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double LjungBox { get; }
Public ReadOnly Property LjungBox As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.LjungBox

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.LjungBoxP Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::LjungBoxP Property
Series LjungBoxP statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double LjungBoxP { get; }
Public ReadOnly Property LjungBoxP As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.LjungBoxP

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.MAD Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::MAD Property
MAD error measure value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MAD { get; }
Public ReadOnly Property MAD As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.MAD

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.MAPE Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::MAPE Property
MAPE error measure value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MAPE { get; }
Public ReadOnly Property MAPE As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.MAPE

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.Maximum Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Maximum Property
Maximum series value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Maximum { get; }
Public ReadOnly Property Maximum As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.Maximum

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.Mean Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Mean Property
Series mean value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Mean { get; }
Public ReadOnly Property Mean As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.Mean

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.Minimum Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Minimum Property
Minimum series value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Minimum { get; }
Public ReadOnly Property Minimum As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.Minimum

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.Order Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Order Property
Method Order parameter.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Dim instance As PredStatistics
Dim value As Integer

value = instance.Order

Property Value

Int32

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.RMSE Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::RMSE Property
RMSE error measure value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RMSE { get; }
Public ReadOnly Property RMSE As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.RMSE

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.RSquared Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::RSquared Property
Regression RSquared statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RSquared { get; }
Public ReadOnly Property RSquared As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.RSquared

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.SeasonalityCycle Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::SeasonalityCycle Property
Seasonal cycle for series. Value is 0 if series is non-seasonal.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SeasonalityCycle { get; }
Public ReadOnly Property SeasonalityCycle As Integer
    Get
Dim instance As PredStatistics
Dim value As Integer

value = instance.SeasonalityCycle

Property Value

Int32

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.StandardDeviation Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::StandardDeviation Property
Standard devistion of series values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StandardDeviation { get; }
Public ReadOnly Property StandardDeviation As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.StandardDeviation

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.StandardError Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::StandardError Property
Regression StandardError statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StandardError { get; }
Public ReadOnly Property StandardError As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.StandardError

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics.TheilsU Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::TheilsU Property
Series TheilsU statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TheilsU { get; }
Public ReadOnly Property TheilsU As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.TheilsU

Property Value

Double

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Decisioneering.CB.CBCOMDevKit.Tornado Namespace

Visual Basic Usage

CB Com Devkit
Decisioneering.CB.CBCOMDevKit.Tornado Namespace
Tornado COM and .NET Development Kit Namespace

Types

All Types | Classes | Interfaces | Enumerations
Name | Description
BaseCaseValuesUsage | Defines the way base case is calculated for CB variables
IInputVariablesEnumerator | Base interface for the input variable enumerators.
InputVariable | Definiton of the Tornado input variable This class contains all variable properties as well as results
InputVariablesEnumerator | InputVariablesEnumerator class is used to enumerata all input variables
TestPointEnumerator | Enumerator used to keep together all results test points for the selected tornado variable
TornadoInputVariableType | Tornado input variable type
TornadoOptions | TornadoOptions class contains all options relevant for the Tornado analysis
TornadoOptionsMethodType | Method type for Tornado
TornadoOverrideType | Tornado value override type
TornadoResultsLocation | Tornado output results location
TornadoSetup | TornadoSetup is a core class for the Tornado DevKit Used to specify all Tornado parameters and options, access tornado input variables and results, including all test points
TornadoTestingRange | Define the Tornado testing range
TornadoTestPoint | TornadoTestPoint class holds all relevant information for one Tornado test point
TornadoVariableResult | TornadoVariableResult class holds all relevant information for the results of the Tornado Analysis for one variable


BaseCaseValuesUsage Enumeration

Visual Basic Usage

CB Com Devkit
BaseCaseValuesUsage Enumeration
Defines the way base case is calculated for CB variables

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum BaseCaseValuesUsage
Public Enumeration BaseCaseValuesUsage
Dim instance As BaseCaseValuesUsage

Members

Member | Value | Description
UseMedianValues | 0 | Median values are used for Base Case
UseCellValues | 1 | Cell values are used for Base Case

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


IInputVariablesEnumerator Interface

Visual Basic Usage

| Members | See Also
CB Com Devkit
IInputVariablesEnumerator Interface
Base interface for the input variable enumerators.

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public interface IInputVariablesEnumerator : IEnumerable,
    IEnumerator
Public Interface IInputVariablesEnumerator
    Inherits IEnumerable, IEnumerator
Dim instance As IInputVariablesEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables in collection.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


IInputVariablesEnumerator Methods

Visual Basic Usage

CB Com Devkit
IInputVariablesEnumerator Methods

The IInputVariablesEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

IInputVariablesEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


IInputVariablesEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
IInputVariablesEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
bool Reload()
Function Reload As Boolean
Dim instance As IInputVariablesEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
true if successful

See Also

IInputVariablesEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


IInputVariablesEnumerator Properties

Visual Basic Usage

CB Com Devkit
IInputVariablesEnumerator Properties

The IInputVariablesEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables in collection.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)

See Also

IInputVariablesEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


IInputVariablesEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
IInputVariablesEnumerator..::Count Property
Returns the count of variables in collection.

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
int Count { get; }
ReadOnly Property Count As Integer
    Get
Dim instance As IInputVariablesEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

See Also

IInputVariablesEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
InputVariable Class
Definiton of the Tornado input variable This class contains all variable properties as well as results

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class InputVariable
Public Class InputVariable
Dim instance As InputVariable

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BaseCase | Returns the variable base case
CellAddress | Returns the cell address for this variable
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MaxDeviation | Returns variable maximum deviation
MaxOverride | Define what type of override is used for the variable maximum value
MaxOverrideDeviation | Defines variable maximum override deviation
MaxOverrideValue | Defines variable maximum override value
MaxValue | Returns variable maximum value
MinDeviation | Returns variable minimum deviation
MinOverride | Provides the access (get/set) to the variable minimum override type
MinOverrideDeviation | Get/Set variable minimum deviation
MinOverrideValue | Provides access to the variable mimimum override value
MinValue | Returns variable minimum value
Name | Definition of the variable name
TornadoMethod | Returns the method type used for this variable
TornadoResult | Provides access to Tornado Analysis results for this variable
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Type | Provides access to variable type
Validate()()()() | Validate all options and settings for this variable.
Value | Returns the variable value
WorkbookName | Retrieve the variable workbook name
WorksheetName | Get the variable worksheet name

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Tornado..::..InputVariable

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable Methods

Visual Basic Usage

CB Com Devkit
InputVariable Methods

The InputVariable type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate all options and settings for this variable.

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.Validate Method

Visual Basic Usage

CB Com Devkit
InputVariable..::Validate Method
Validate all options and settings for this variable.

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As InputVariable
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

Boolean
true if successful

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable Properties

Visual Basic Usage

CB Com Devkit
InputVariable Properties

The InputVariable type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BaseCase | Returns the variable base case
CellAddress | Returns the cell address for this variable
MaxDeviation | Returns variable maximum deviation
MaxOverride | Define what type of override is used for the variable maximum value
MaxOverrideDeviation | Defines variable maximum override deviation
MaxOverrideValue | Defines variable maximum override value
MaxValue | Returns variable maximum value
MinDeviation | Returns variable minimum deviation
MinOverride | Provides the access (get/set) to the variable minimum override type
MinOverrideDeviation | Get/Set variable minimum deviation
MinOverrideValue | Provides access to the variable mimimum override value
MinValue | Returns variable minimum value
Name | Definition of the variable name
TornadoMethod | Returns the method type used for this variable
TornadoResult | Provides access to Tornado Analysis results for this variable
Type | Provides access to variable type
Value | Returns the variable value
WorkbookName | Retrieve the variable workbook name
WorksheetName | Get the variable worksheet name

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.BaseCase Property

Visual Basic Usage

CB Com Devkit
InputVariable..::BaseCase Property
Returns the variable base case

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double BaseCase { get; }
Public ReadOnly Property BaseCase As Double
    Get
Dim instance As InputVariable
Dim value As Double

value = instance.BaseCase

Property Value

Double

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.CellAddress Property

Visual Basic Usage

CB Com Devkit
InputVariable..::CellAddress Property
Returns the cell address for this variable

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string CellAddress { get; }
Public ReadOnly Property CellAddress As String
    Get
Dim instance As InputVariable
Dim value As String

value = instance.CellAddress

Property Value

String

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.MaxDeviation Property

Visual Basic Usage

CB Com Devkit
InputVariable..::MaxDeviation Property
Returns variable maximum deviation

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MaxDeviation { get; }
Public ReadOnly Property MaxDeviation As Double
    Get
Dim instance As InputVariable
Dim value As Double

value = instance.MaxDeviation

Property Value

Double

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.MaxOverride Property

Visual Basic Usage

CB Com Devkit
InputVariable..::MaxOverride Property
Define what type of override is used for the variable maximum value

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TornadoOverrideType MaxOverride { get; set; }
Public Property MaxOverride As TornadoOverrideType
    Get
    Set
Dim instance As InputVariable
Dim value As TornadoOverrideType

value = instance.MaxOverride

instance.MaxOverride = value

Property Value

TornadoOverrideType

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.MaxOverrideDeviation Property

Visual Basic Usage

CB Com Devkit
InputVariable..::MaxOverrideDeviation Property
Defines variable maximum override deviation

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MaxOverrideDeviation { get; set; }
Public Property MaxOverrideDeviation As Double
    Get
    Set
Dim instance As InputVariable
Dim value As Double

value = instance.MaxOverrideDeviation

instance.MaxOverrideDeviation = value

Property Value

Double

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.MaxOverrideValue Property

Visual Basic Usage

CB Com Devkit
InputVariable..::MaxOverrideValue Property
Defines variable maximum override value

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MaxOverrideValue { get; set; }
Public Property MaxOverrideValue As Double
    Get
    Set
Dim instance As InputVariable
Dim value As Double

value = instance.MaxOverrideValue

instance.MaxOverrideValue = value

Property Value

Double

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.MaxValue Property

Visual Basic Usage

CB Com Devkit
InputVariable..::MaxValue Property
Returns variable maximum value

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MaxValue { get; }
Public ReadOnly Property MaxValue As Double
    Get
Dim instance As InputVariable
Dim value As Double

value = instance.MaxValue

Property Value

Double

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.MinDeviation Property

Visual Basic Usage

CB Com Devkit
InputVariable..::MinDeviation Property
Returns variable minimum deviation

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MinDeviation { get; }
Public ReadOnly Property MinDeviation As Double
    Get
Dim instance As InputVariable
Dim value As Double

value = instance.MinDeviation

Property Value

Double

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.MinOverride Property

Visual Basic Usage

CB Com Devkit
InputVariable..::MinOverride Property
Provides the access (get/set) to the variable minimum override type

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TornadoOverrideType MinOverride { get; set; }
Public Property MinOverride As TornadoOverrideType
    Get
    Set
Dim instance As InputVariable
Dim value As TornadoOverrideType

value = instance.MinOverride

instance.MinOverride = value

Property Value

TornadoOverrideType

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.MinOverrideDeviation Property

Visual Basic Usage

CB Com Devkit
InputVariable..::MinOverrideDeviation Property
Get/Set variable minimum deviation

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MinOverrideDeviation { get; set; }
Public Property MinOverrideDeviation As Double
    Get
    Set
Dim instance As InputVariable
Dim value As Double

value = instance.MinOverrideDeviation

instance.MinOverrideDeviation = value

Property Value

Double

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.MinOverrideValue Property

Visual Basic Usage

CB Com Devkit
InputVariable..::MinOverrideValue Property
Provides access to the variable mimimum override value

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MinOverrideValue { get; set; }
Public Property MinOverrideValue As Double
    Get
    Set
Dim instance As InputVariable
Dim value As Double

value = instance.MinOverrideValue

instance.MinOverrideValue = value

Property Value

Double

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.MinValue Property

Visual Basic Usage

CB Com Devkit
InputVariable..::MinValue Property
Returns variable minimum value

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MinValue { get; }
Public ReadOnly Property MinValue As Double
    Get
Dim instance As InputVariable
Dim value As Double

value = instance.MinValue

Property Value

Double

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.Name Property

Visual Basic Usage

CB Com Devkit
InputVariable..::Name Property
Definition of the variable name

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Dim instance As InputVariable
Dim value As String

value = instance.Name

Property Value

String

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.TornadoMethod Property

Visual Basic Usage

CB Com Devkit
InputVariable..::TornadoMethod Property
Returns the method type used for this variable

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TornadoOptionsMethodType TornadoMethod { get; }
Public ReadOnly Property TornadoMethod As TornadoOptionsMethodType
    Get
Dim instance As InputVariable
Dim value As TornadoOptionsMethodType

value = instance.TornadoMethod

Property Value

TornadoOptionsMethodType

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.TornadoResult Property

Visual Basic Usage

CB Com Devkit
InputVariable..::TornadoResult Property
Provides access to Tornado Analysis results for this variable

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TornadoVariableResult TornadoResult { get; }
Public ReadOnly Property TornadoResult As TornadoVariableResult
    Get
Dim instance As InputVariable
Dim value As TornadoVariableResult

value = instance.TornadoResult

Property Value

TornadoVariableResult

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.Type Property

Visual Basic Usage

CB Com Devkit
InputVariable..::Type Property
Provides access to variable type

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TornadoInputVariableType Type { get; }
Public ReadOnly Property Type As TornadoInputVariableType
    Get
Dim instance As InputVariable
Dim value As TornadoInputVariableType

value = instance.Type

Property Value

TornadoInputVariableType

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.Value Property

Visual Basic Usage

CB Com Devkit
InputVariable..::Value Property
Returns the variable value

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Value { get; }
Public ReadOnly Property Value As Double
    Get
Dim instance As InputVariable
Dim value As Double

value = instance.Value

Property Value

Double

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.WorkbookName Property

Visual Basic Usage

CB Com Devkit
InputVariable..::WorkbookName Property
Retrieve the variable workbook name

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string WorkbookName { get; }
Public ReadOnly Property WorkbookName As String
    Get
Dim instance As InputVariable
Dim value As String

value = instance.WorkbookName

Property Value

String

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariable.WorksheetName Property

Visual Basic Usage

CB Com Devkit
InputVariable..::WorksheetName Property
Get the variable worksheet name

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string WorksheetName { get; }
Public ReadOnly Property WorksheetName As String
    Get
Dim instance As InputVariable
Dim value As String

value = instance.WorksheetName

Property Value

String

See Also

InputVariable Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
InputVariablesEnumerator Class
InputVariablesEnumerator class is used to enumerata all input variables

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class InputVariablesEnumerator : IInputVariablesEnumerator,
    IEnumerable, IEnumerator
Public Class InputVariablesEnumerator
    Implements IInputVariablesEnumerator, IEnumerable, IEnumerator
Dim instance As InputVariablesEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddAssumptions()()()() | Add all CB assumptions to the list of input variables
AddDecisions()()()() | Add all decision variables to the list
AddPrecedents()()()() | Add all precedents for the currently selected targer of Tornado Analysis
AddRange(Range) | Add a specific range to the list of tornado variables Canbe a single cell or a multiple cells
Clear()()()() | Clear all variables from the enumerator
Count | Returns the variables count
Current | Returns the current variable (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for input variables.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get variable by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable
Reload()()()() | Reload the input variables enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first variable).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Tornado..::..InputVariablesEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator Methods

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator Methods

The InputVariablesEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddAssumptions()()()() | Add all CB assumptions to the list of input variables
AddDecisions()()()() | Add all decision variables to the list
AddPrecedents()()()() | Add all precedents for the currently selected targer of Tornado Analysis
AddRange(Range) | Add a specific range to the list of tornado variables Canbe a single cell or a multiple cells
Clear()()()() | Clear all variables from the enumerator
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for input variables.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable
Reload()()()() | Reload the input variables enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first variable).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator.AddAssumptions Method

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator..::AddAssumptions Method
Add all CB assumptions to the list of input variables

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void AddAssumptions()
Public Sub AddAssumptions
Dim instance As InputVariablesEnumerator

instance.AddAssumptions()

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator.AddDecisions Method

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator..::AddDecisions Method
Add all decision variables to the list

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void AddDecisions()
Public Sub AddDecisions
Dim instance As InputVariablesEnumerator

instance.AddDecisions()

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator.AddPrecedents Method

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator..::AddPrecedents Method
Add all precedents for the currently selected targer of Tornado Analysis

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void AddPrecedents()
Public Sub AddPrecedents
Dim instance As InputVariablesEnumerator

instance.AddPrecedents()

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator.AddRange Method

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator..::AddRange Method
Add a specific range to the list of tornado variables Canbe a single cell or a multiple cells

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void AddRange(
    Range range
)
Public Sub AddRange (
    range As Range
)
Dim instance As InputVariablesEnumerator
Dim range As Range

instance.AddRange(range)

Parameters

range
Range
Excel range to add as an input variable

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator.Clear Method

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator..::Clear Method
Clear all variables from the enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Clear()
Public Sub Clear
Dim instance As InputVariablesEnumerator

instance.Clear()

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator.GetEnumerator Method

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator..::GetEnumerator Method
Returns an enumerator for input variables.

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As InputVariablesEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

IEnumerator
the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator.MoveNext Method

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid variable

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As InputVariablesEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

Boolean
true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator..::Reload Method
Reload the input variables enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As InputVariablesEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
true if successful

Implements

IInputVariablesEnumerator..::..Reload()()()()

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator.Reset Method

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first variable).

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As InputVariablesEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator Properties

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator Properties

The InputVariablesEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the variables count
Current | Returns the current variable (required by IEnumerator).
Item[([( Int32])]) | Get variable by index.

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator..::Count Property
Returns the variables count

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As InputVariablesEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

Implements

IInputVariablesEnumerator..::..Count

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator..::Current Property
Returns the current variable (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As InputVariablesEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


InputVariablesEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
InputVariablesEnumerator..::Item Property
Get variable by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public InputVariable this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As InputVariable
    Get
Dim instance As InputVariablesEnumerator
Dim index As Integer
Dim value As InputVariable

value = instance(index)

Parameters

index
Int32

Return Value

InputVariable

See Also

InputVariablesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TestPointEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
TestPointEnumerator Class
Enumerator used to keep together all results test points for the selected tornado variable

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class TestPointEnumerator : IInputVariablesEnumerator,
    IEnumerable, IEnumerator
Public Class TestPointEnumerator
    Implements IInputVariablesEnumerator, IEnumerable, IEnumerator
Dim instance As TestPointEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the test point count
Current | Returns the current variable (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for test points.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get test point by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid test point
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first test point).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Tornado..::..TestPointEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TestPointEnumerator Methods

Visual Basic Usage

CB Com Devkit
TestPointEnumerator Methods

The TestPointEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for test points.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid test point
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first test point).
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

TestPointEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TestPointEnumerator.GetEnumerator Method

Visual Basic Usage

CB Com Devkit
TestPointEnumerator..::GetEnumerator Method
Returns an enumerator for test points.

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As TestPointEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

IEnumerator
the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

TestPointEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TestPointEnumerator.MoveNext Method

Visual Basic Usage

CB Com Devkit
TestPointEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid test point

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As TestPointEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

Boolean
true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

TestPointEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TestPointEnumerator.Reload Method

Visual Basic Usage

CB Com Devkit
TestPointEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As TestPointEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Boolean
true if successful

Implements

IInputVariablesEnumerator..::..Reload()()()()

See Also

TestPointEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TestPointEnumerator.Reset Method

Visual Basic Usage

CB Com Devkit
TestPointEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first test point).

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As TestPointEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

TestPointEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TestPointEnumerator Properties

Visual Basic Usage

CB Com Devkit
TestPointEnumerator Properties

The TestPointEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the test point count
Current | Returns the current variable (required by IEnumerator).
Item[([( Int32])]) | Get test point by index.

See Also

TestPointEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TestPointEnumerator.Count Property

Visual Basic Usage

CB Com Devkit
TestPointEnumerator..::Count Property
Returns the test point count

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As TestPointEnumerator
Dim value As Integer

value = instance.Count

Property Value

Int32

Implements

IInputVariablesEnumerator..::..Count

See Also

TestPointEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TestPointEnumerator.Current Property

Visual Basic Usage

CB Com Devkit
TestPointEnumerator..::Current Property
Returns the current variable (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As TestPointEnumerator
Dim value As Object

value = instance.Current

Property Value

Object

Implements

IEnumerator..::..Current

See Also

TestPointEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TestPointEnumerator.Item Property

Visual Basic Usage

CB Com Devkit
TestPointEnumerator..::Item Property
Get test point by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TornadoTestPoint this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As TornadoTestPoint
    Get
Dim instance As TestPointEnumerator
Dim index As Integer
Dim value As TornadoTestPoint

value = instance(index)

Parameters

index
Int32

Return Value

TornadoTestPoint

See Also

TestPointEnumerator Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoInputVariableType Enumeration

Visual Basic Usage

CB Com Devkit
TornadoInputVariableType Enumeration
Tornado input variable type

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum TornadoInputVariableType
Public Enumeration TornadoInputVariableType
Dim instance As TornadoInputVariableType

Members

Member | Value | Description
AssumptionInputType | 0 | Assumption variable type
DecisionInputType | 1 | Decision variable type
PrecedentInputType | 2 | Precedent variable type
RangeInputType | 3 | Range variable type

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
TornadoOptions Class
TornadoOptions class contains all options relevant for the Tornado analysis

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class TornadoOptions
Public Class TornadoOptions
Dim instance As TornadoOptions

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
TornadoOptions()()()() | Initializes a new instance of the TornadoOptions class
CreateSpiderChart | Defines if Spider chart should created and displayed in the Tornado output
CreateTornadoChart | Defines if Tornado chart should created and displayed in the Tornado output
CustomizeTestRanges | Used to specify globally if customizations defined for input variables should be used or not
CustomRangeLower | Defines the lower value for the tornado test range. Used only when custom test range is specified
CustomRangeUpper | Defines the upper value for the tornado test range. Used only when custom test range is specified
DownsideLegendLabel | Define the custom value for the Downside label. If nothing specified, "Downside" is used
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ResultsLocation | Defines the destination for the Tornado output (either a new or existing worksbook)
ShowAbsoluteLabels | Defines if absolute values or diferences form base case are used for labels in Tornado chart
ShowLabelsAsInputs | Defines if input of target values are used for individual Tornado chart labels
ShowTopVariables | Limits the number of variables in the Tornado output
TestPoints | Number of test points used durn\ing the tornado analysis
TestRange | Defines the tornado test range
TornadoMethod | Defines the method used for tornado analysis (either percentiles or deviations)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
UpsideLegendLabel | Define the custom value for the Upside label. If nothing specified, "Upside" is used
Validate()()()() | Validate all options settings.
VariablesBaseCase | Defines what values are used for the base case for CB variables (either cell values of median values)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Tornado..::..TornadoOptions

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions Constructor

Visual Basic Usage

CB Com Devkit
TornadoOptions Constructor
Initializes a new instance of the TornadoOptions class

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TornadoOptions()
Public Sub New
Dim instance As New TornadoOptions()

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions Methods

Visual Basic Usage

CB Com Devkit
TornadoOptions Methods

The TornadoOptions type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate()()()() | Validate all options settings.

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.Validate Method

Visual Basic Usage

CB Com Devkit
TornadoOptions..::Validate Method
Validate all options settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As TornadoOptions
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

Boolean
true if successful

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions Properties

Visual Basic Usage

CB Com Devkit
TornadoOptions Properties

The TornadoOptions type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CreateSpiderChart | Defines if Spider chart should created and displayed in the Tornado output
CreateTornadoChart | Defines if Tornado chart should created and displayed in the Tornado output
CustomizeTestRanges | Used to specify globally if customizations defined for input variables should be used or not
CustomRangeLower | Defines the lower value for the tornado test range. Used only when custom test range is specified
CustomRangeUpper | Defines the upper value for the tornado test range. Used only when custom test range is specified
DownsideLegendLabel | Define the custom value for the Downside label. If nothing specified, "Downside" is used
ResultsLocation | Defines the destination for the Tornado output (either a new or existing worksbook)
ShowAbsoluteLabels | Defines if absolute values or diferences form base case are used for labels in Tornado chart
ShowLabelsAsInputs | Defines if input of target values are used for individual Tornado chart labels
ShowTopVariables | Limits the number of variables in the Tornado output
TestPoints | Number of test points used durn\ing the tornado analysis
TestRange | Defines the tornado test range
TornadoMethod | Defines the method used for tornado analysis (either percentiles or deviations)
UpsideLegendLabel | Define the custom value for the Upside label. If nothing specified, "Upside" is used
VariablesBaseCase | Defines what values are used for the base case for CB variables (either cell values of median values)

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.CreateSpiderChart Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::CreateSpiderChart Property
Defines if Spider chart should created and displayed in the Tornado output

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool CreateSpiderChart { get; set; }
Public Property CreateSpiderChart As Boolean
    Get
    Set
Dim instance As TornadoOptions
Dim value As Boolean

value = instance.CreateSpiderChart

instance.CreateSpiderChart = value

Property Value

Boolean

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.CreateTornadoChart Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::CreateTornadoChart Property
Defines if Tornado chart should created and displayed in the Tornado output

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool CreateTornadoChart { get; set; }
Public Property CreateTornadoChart As Boolean
    Get
    Set
Dim instance As TornadoOptions
Dim value As Boolean

value = instance.CreateTornadoChart

instance.CreateTornadoChart = value

Property Value

Boolean

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.CustomizeTestRanges Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::CustomizeTestRanges Property
Used to specify globally if customizations defined for input variables should be used or not

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool CustomizeTestRanges { get; set; }
Public Property CustomizeTestRanges As Boolean
    Get
    Set
Dim instance As TornadoOptions
Dim value As Boolean

value = instance.CustomizeTestRanges

instance.CustomizeTestRanges = value

Property Value

Boolean

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.CustomRangeLower Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::CustomRangeLower Property
Defines the lower value for the tornado test range. Used only when custom test range is specified

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double CustomRangeLower { get; set; }
Public Property CustomRangeLower As Double
    Get
    Set
Dim instance As TornadoOptions
Dim value As Double

value = instance.CustomRangeLower

instance.CustomRangeLower = value

Property Value

Double

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.CustomRangeUpper Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::CustomRangeUpper Property
Defines the upper value for the tornado test range. Used only when custom test range is specified

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double CustomRangeUpper { get; set; }
Public Property CustomRangeUpper As Double
    Get
    Set
Dim instance As TornadoOptions
Dim value As Double

value = instance.CustomRangeUpper

instance.CustomRangeUpper = value

Property Value

Double

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.DownsideLegendLabel Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::DownsideLegendLabel Property
Define the custom value for the Downside label. If nothing specified, "Downside" is used

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string DownsideLegendLabel { get; set; }
Public Property DownsideLegendLabel As String
    Get
    Set
Dim instance As TornadoOptions
Dim value As String

value = instance.DownsideLegendLabel

instance.DownsideLegendLabel = value

Property Value

String

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.ResultsLocation Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::ResultsLocation Property
Defines the destination for the Tornado output (either a new or existing worksbook)

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TornadoResultsLocation ResultsLocation { get; set; }
Public Property ResultsLocation As TornadoResultsLocation
    Get
    Set
Dim instance As TornadoOptions
Dim value As TornadoResultsLocation

value = instance.ResultsLocation

instance.ResultsLocation = value

Property Value

TornadoResultsLocation

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.ShowAbsoluteLabels Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::ShowAbsoluteLabels Property
Defines if absolute values or diferences form base case are used for labels in Tornado chart

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowAbsoluteLabels { get; set; }
Public Property ShowAbsoluteLabels As Boolean
    Get
    Set
Dim instance As TornadoOptions
Dim value As Boolean

value = instance.ShowAbsoluteLabels

instance.ShowAbsoluteLabels = value

Property Value

Boolean

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.ShowLabelsAsInputs Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::ShowLabelsAsInputs Property
Defines if input of target values are used for individual Tornado chart labels

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowLabelsAsInputs { get; set; }
Public Property ShowLabelsAsInputs As Boolean
    Get
    Set
Dim instance As TornadoOptions
Dim value As Boolean

value = instance.ShowLabelsAsInputs

instance.ShowLabelsAsInputs = value

Property Value

Boolean

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.ShowTopVariables Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::ShowTopVariables Property
Limits the number of variables in the Tornado output

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ShowTopVariables { get; set; }
Public Property ShowTopVariables As Integer
    Get
    Set
Dim instance As TornadoOptions
Dim value As Integer

value = instance.ShowTopVariables

instance.ShowTopVariables = value

Property Value

Int32

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.TestPoints Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::TestPoints Property
Number of test points used durn\ing the tornado analysis

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int TestPoints { get; set; }
Public Property TestPoints As Integer
    Get
    Set
Dim instance As TornadoOptions
Dim value As Integer

value = instance.TestPoints

instance.TestPoints = value

Property Value

Int32

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.TestRange Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::TestRange Property
Defines the tornado test range

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TornadoTestingRange TestRange { get; set; }
Public Property TestRange As TornadoTestingRange
    Get
    Set
Dim instance As TornadoOptions
Dim value As TornadoTestingRange

value = instance.TestRange

instance.TestRange = value

Property Value

TornadoTestingRange

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.TornadoMethod Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::TornadoMethod Property
Defines the method used for tornado analysis (either percentiles or deviations)

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TornadoOptionsMethodType TornadoMethod { get; set; }
Public Property TornadoMethod As TornadoOptionsMethodType
    Get
    Set
Dim instance As TornadoOptions
Dim value As TornadoOptionsMethodType

value = instance.TornadoMethod

instance.TornadoMethod = value

Property Value

TornadoOptionsMethodType

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.UpsideLegendLabel Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::UpsideLegendLabel Property
Define the custom value for the Upside label. If nothing specified, "Upside" is used

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string UpsideLegendLabel { get; set; }
Public Property UpsideLegendLabel As String
    Get
    Set
Dim instance As TornadoOptions
Dim value As String

value = instance.UpsideLegendLabel

instance.UpsideLegendLabel = value

Property Value

String

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptions.VariablesBaseCase Property

Visual Basic Usage

CB Com Devkit
TornadoOptions..::VariablesBaseCase Property
Defines what values are used for the base case for CB variables (either cell values of median values)

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public BaseCaseValuesUsage VariablesBaseCase { get; set; }
Public Property VariablesBaseCase As BaseCaseValuesUsage
    Get
    Set
Dim instance As TornadoOptions
Dim value As BaseCaseValuesUsage

value = instance.VariablesBaseCase

instance.VariablesBaseCase = value

Property Value

BaseCaseValuesUsage

See Also

TornadoOptions Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOptionsMethodType Enumeration

Visual Basic Usage

CB Com Devkit
TornadoOptionsMethodType Enumeration
Method type for Tornado

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum TornadoOptionsMethodType
Public Enumeration TornadoOptionsMethodType
Dim instance As TornadoOptionsMethodType

Members

Member | Value | Description
MethodVariablePercentile | 0 | Percentiles of the variables
MethodPercentageDeviations | 1 | Deviations (by percentage)

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoOverrideType Enumeration

Visual Basic Usage

CB Com Devkit
TornadoOverrideType Enumeration
Tornado value override type

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum TornadoOverrideType
Public Enumeration TornadoOverrideType
Dim instance As TornadoOverrideType

Members

Member | Value | Description
NoOverride | 0 | No override (default)
DeviationOverride | 1 | Override prezent for deviations
ValueOverride | 2 | Override prezent for variable values

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoResultsLocation Enumeration

Visual Basic Usage

CB Com Devkit
TornadoResultsLocation Enumeration
Tornado output results location

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum TornadoResultsLocation
Public Enumeration TornadoResultsLocation
Dim instance As TornadoResultsLocation

Members

Member | Value | Description
NewWorkbook | 0 | Output results to a new workbook
ExistingWorkbook | 1 | Output results to currently selected workbook

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoSetup Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
TornadoSetup Class
TornadoSetup is a core class for the Tornado DevKit Used to specify all Tornado parameters and options, access tornado input variables and results, including all test points

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class TornadoSetup
Public Class TornadoSetup
Dim instance As TornadoSetup

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
TornadoSetup()()()() | Initializes a new instance of the TornadoSetup class
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InputVariables | Access to the list of all known input variables
Options | Access to to various Tornado options
Run()()()() | Execute the Tornado Analysis tool
Show()()()() | Show the Tornado Wizard GUI
Target | Specify the target for Tornado Analysis. Could be either a valid cell or a CB forecast
ThrowErrors | Setting to determine whether to throw errors to the client app
ThrowWarningsAsErrors | Setting to determine whether to throw warnings to the client app
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate(Boolean) | Validate all Tornado settings and determine if Tornado Analysis can be performed.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Tornado..::..TornadoSetup

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoSetup Constructor

Visual Basic Usage

CB Com Devkit
TornadoSetup Constructor
Initializes a new instance of the TornadoSetup class

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TornadoSetup()
Public Sub New
Dim instance As New TornadoSetup()

See Also

TornadoSetup Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoSetup Methods

Visual Basic Usage

CB Com Devkit
TornadoSetup Methods

The TornadoSetup type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Run()()()() | Execute the Tornado Analysis tool
Show()()()() | Show the Tornado Wizard GUI
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Validate(Boolean) | Validate all Tornado settings and determine if Tornado Analysis can be performed.

See Also

TornadoSetup Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoSetup.Run Method

Visual Basic Usage

CB Com Devkit
TornadoSetup..::Run Method
Execute the Tornado Analysis tool

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Run()
Public Function Run As Boolean
Dim instance As TornadoSetup
Dim returnValue As Boolean

returnValue = instance.Run()

Return Value

Boolean
True if successful False otherwise

See Also

TornadoSetup Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoSetup.Show Method

Visual Basic Usage

CB Com Devkit
TornadoSetup..::Show Method
Show the Tornado Wizard GUI

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Show()
Public Function Show As Boolean
Dim instance As TornadoSetup
Dim returnValue As Boolean

returnValue = instance.Show()

Return Value

Boolean
Whether wizard was shown.

See Also

TornadoSetup Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoSetup.Validate Method

Visual Basic Usage

CB Com Devkit
TornadoSetup..::Validate Method
Validate all Tornado settings and determine if Tornado Analysis can be performed.

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate(
    bool ShowWizard
)
Public Function Validate (
    ShowWizard As Boolean
) As Boolean
Dim instance As TornadoSetup
Dim ShowWizard As Boolean
Dim returnValue As Boolean

returnValue = instance.Validate(ShowWizard)

Parameters

ShowWizard
Boolean
Show the wizard on validation error

Return Value

Boolean
True if validation is successful, False otherwise

See Also

TornadoSetup Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoSetup Properties

Visual Basic Usage

CB Com Devkit
TornadoSetup Properties

The TornadoSetup type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
InputVariables | Access to the list of all known input variables
Options | Access to to various Tornado options
Target | Specify the target for Tornado Analysis. Could be either a valid cell or a CB forecast
ThrowErrors | Setting to determine whether to throw errors to the client app
ThrowWarningsAsErrors | Setting to determine whether to throw warnings to the client app

See Also

TornadoSetup Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoSetup.InputVariables Property

Visual Basic Usage

CB Com Devkit
TornadoSetup..::InputVariables Property
Access to the list of all known input variables

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public InputVariablesEnumerator InputVariables { get; }
Public ReadOnly Property InputVariables As InputVariablesEnumerator
    Get
Dim instance As TornadoSetup
Dim value As InputVariablesEnumerator

value = instance.InputVariables

Property Value

InputVariablesEnumerator

See Also

TornadoSetup Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoSetup.Options Property

Visual Basic Usage

CB Com Devkit
TornadoSetup..::Options Property
Access to to various Tornado options

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TornadoOptions Options { get; }
Public ReadOnly Property Options As TornadoOptions
    Get
Dim instance As TornadoSetup
Dim value As TornadoOptions

value = instance.Options

Property Value

TornadoOptions

See Also

TornadoSetup Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoSetup.Target Property

Visual Basic Usage

CB Com Devkit
TornadoSetup..::Target Property
Specify the target for Tornado Analysis. Could be either a valid cell or a CB forecast

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range Target { get; set; }
Public Property Target As Range
    Get
    Set
Dim instance As TornadoSetup
Dim value As Range

value = instance.Target

instance.Target = value

Property Value

Range

See Also

TornadoSetup Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoSetup.ThrowErrors Property

Visual Basic Usage

CB Com Devkit
TornadoSetup..::ThrowErrors Property
Setting to determine whether to throw errors to the client app

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowErrors { get; set; }
Public Property ThrowErrors As Boolean
    Get
    Set
Dim instance As TornadoSetup
Dim value As Boolean

value = instance.ThrowErrors

instance.ThrowErrors = value

Property Value

Boolean

See Also

TornadoSetup Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoSetup.ThrowWarningsAsErrors Property

Visual Basic Usage

CB Com Devkit
TornadoSetup..::ThrowWarningsAsErrors Property
Setting to determine whether to throw warnings to the client app

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowWarningsAsErrors { get; set; }
Public Property ThrowWarningsAsErrors As Boolean
    Get
    Set
Dim instance As TornadoSetup
Dim value As Boolean

value = instance.ThrowWarningsAsErrors

instance.ThrowWarningsAsErrors = value

Property Value

Boolean

See Also

TornadoSetup Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoTestingRange Enumeration

Visual Basic Usage

CB Com Devkit
TornadoTestingRange Enumeration
Define the Tornado testing range

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum TornadoTestingRange
Public Enumeration TornadoTestingRange
Dim instance As TornadoTestingRange

Members

Member | Value | Description
Range_20to80 | 0 | 20% - 80% testing range (-20% - 20% for deviations)
Range_10to90 | 1 | 10% - 90% testing range (-10% - 10% for deviations)
Range_5to95 | 2 | 5% - 95% testing range (-5% - 5% for deviations)
Range_1to99 | 3 | 1% - 99% testing range (-1% - 1% for deviations)
Range_0to100 | 4 | 0% - 100% testing range (only makes sense for percentiles)
Range_Custom | 5 | Custom testing range (specified through additional calls)

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoTestPoint Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
TornadoTestPoint Class
TornadoTestPoint class holds all relevant information for one Tornado test point

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class TornadoTestPoint
Public Class TornadoTestPoint
Dim instance As TornadoTestPoint

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InputValue | Input value generated for this test point
PercentileValue | Percentile value for this test point
TargetValue | Target value generated for this test point
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Tornado..::..TornadoTestPoint

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoTestPoint Methods

Visual Basic Usage

CB Com Devkit
TornadoTestPoint Methods

The TornadoTestPoint type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

TornadoTestPoint Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoTestPoint Properties

Visual Basic Usage

CB Com Devkit
TornadoTestPoint Properties

The TornadoTestPoint type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
InputValue | Input value generated for this test point
PercentileValue | Percentile value for this test point
TargetValue | Target value generated for this test point

See Also

TornadoTestPoint Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoTestPoint.InputValue Property

Visual Basic Usage

CB Com Devkit
TornadoTestPoint..::InputValue Property
Input value generated for this test point

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double InputValue { get; }
Public ReadOnly Property InputValue As Double
    Get
Dim instance As TornadoTestPoint
Dim value As Double

value = instance.InputValue

Property Value

Double

See Also

TornadoTestPoint Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoTestPoint.PercentileValue Property

Visual Basic Usage

CB Com Devkit
TornadoTestPoint..::PercentileValue Property
Percentile value for this test point

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double PercentileValue { get; }
Public ReadOnly Property PercentileValue As Double
    Get
Dim instance As TornadoTestPoint
Dim value As Double

value = instance.PercentileValue

Property Value

Double

See Also

TornadoTestPoint Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoTestPoint.TargetValue Property

Visual Basic Usage

CB Com Devkit
TornadoTestPoint..::TargetValue Property
Target value generated for this test point

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TargetValue { get; }
Public ReadOnly Property TargetValue As Double
    Get
Dim instance As TornadoTestPoint
Dim value As Double

value = instance.TargetValue

Property Value

Double

See Also

TornadoTestPoint Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
TornadoVariableResult Class
TornadoVariableResult class holds all relevant information for the results of the Tornado Analysis for one variable

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class TornadoVariableResult
Public Class TornadoVariableResult
Dim instance As TornadoVariableResult

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Elasticity | Value for the variable elasticity
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InputDownside | Value for the variable input downside
InputMaximum | Value for the variable input maximum
InputMinimum | Value for the variable input minimum
InputRange | Value for the variable input range
InputUpside | Value for the variable input upside
TargetDownside | Value for the variable target downside
TargetRange | Value for the variable target range
TargetUpside | Value for the variable target upside
TestPoints | Provides access to all test point for this variable
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Tornado..::..TornadoVariableResult

See Also

Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult Methods

Visual Basic Usage

CB Com Devkit
TornadoVariableResult Methods

The TornadoVariableResult type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

TornadoVariableResult Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult Properties

Visual Basic Usage

CB Com Devkit
TornadoVariableResult Properties

The TornadoVariableResult type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Elasticity | Value for the variable elasticity
InputDownside | Value for the variable input downside
InputMaximum | Value for the variable input maximum
InputMinimum | Value for the variable input minimum
InputRange | Value for the variable input range
InputUpside | Value for the variable input upside
TargetDownside | Value for the variable target downside
TargetRange | Value for the variable target range
TargetUpside | Value for the variable target upside
TestPoints | Provides access to all test point for this variable

See Also

TornadoVariableResult Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult.Elasticity Property

Visual Basic Usage

CB Com Devkit
TornadoVariableResult..::Elasticity Property
Value for the variable elasticity

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Elasticity { get; }
Public ReadOnly Property Elasticity As Double
    Get
Dim instance As TornadoVariableResult
Dim value As Double

value = instance.Elasticity

Property Value

Double

See Also

TornadoVariableResult Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult.InputDownside Property

Visual Basic Usage

CB Com Devkit
TornadoVariableResult..::InputDownside Property
Value for the variable input downside

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double InputDownside { get; }
Public ReadOnly Property InputDownside As Double
    Get
Dim instance As TornadoVariableResult
Dim value As Double

value = instance.InputDownside

Property Value

Double

See Also

TornadoVariableResult Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult.InputMaximum Property

Visual Basic Usage

CB Com Devkit
TornadoVariableResult..::InputMaximum Property
Value for the variable input maximum

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double InputMaximum { get; }
Public ReadOnly Property InputMaximum As Double
    Get
Dim instance As TornadoVariableResult
Dim value As Double

value = instance.InputMaximum

Property Value

Double

See Also

TornadoVariableResult Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult.InputMinimum Property

Visual Basic Usage

CB Com Devkit
TornadoVariableResult..::InputMinimum Property
Value for the variable input minimum

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double InputMinimum { get; }
Public ReadOnly Property InputMinimum As Double
    Get
Dim instance As TornadoVariableResult
Dim value As Double

value = instance.InputMinimum

Property Value

Double

See Also

TornadoVariableResult Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult.InputRange Property

Visual Basic Usage

CB Com Devkit
TornadoVariableResult..::InputRange Property
Value for the variable input range

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double InputRange { get; }
Public ReadOnly Property InputRange As Double
    Get
Dim instance As TornadoVariableResult
Dim value As Double

value = instance.InputRange

Property Value

Double

See Also

TornadoVariableResult Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult.InputUpside Property

Visual Basic Usage

CB Com Devkit
TornadoVariableResult..::InputUpside Property
Value for the variable input upside

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double InputUpside { get; }
Public ReadOnly Property InputUpside As Double
    Get
Dim instance As TornadoVariableResult
Dim value As Double

value = instance.InputUpside

Property Value

Double

See Also

TornadoVariableResult Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult.TargetDownside Property

Visual Basic Usage

CB Com Devkit
TornadoVariableResult..::TargetDownside Property
Value for the variable target downside

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TargetDownside { get; }
Public ReadOnly Property TargetDownside As Double
    Get
Dim instance As TornadoVariableResult
Dim value As Double

value = instance.TargetDownside

Property Value

Double

See Also

TornadoVariableResult Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult.TargetRange Property

Visual Basic Usage

CB Com Devkit
TornadoVariableResult..::TargetRange Property
Value for the variable target range

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TargetRange { get; }
Public ReadOnly Property TargetRange As Double
    Get
Dim instance As TornadoVariableResult
Dim value As Double

value = instance.TargetRange

Property Value

Double

See Also

TornadoVariableResult Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult.TargetUpside Property

Visual Basic Usage

CB Com Devkit
TornadoVariableResult..::TargetUpside Property
Value for the variable target upside

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TargetUpside { get; }
Public ReadOnly Property TargetUpside As Double
    Get
Dim instance As TornadoVariableResult
Dim value As Double

value = instance.TargetUpside

Property Value

Double

See Also

TornadoVariableResult Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace


TornadoVariableResult.TestPoints Property

Visual Basic Usage

CB Com Devkit
TornadoVariableResult..::TestPoints Property
Provides access to all test point for this variable

Namespace: Decisioneering.CB.CBCOMDevKit.Tornado
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.3619.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TestPointEnumerator TestPoints { get; }
Public ReadOnly Property TestPoints As TestPointEnumerator
    Get
Dim instance As TornadoVariableResult
Dim value As TestPointEnumerator

value = instance.TestPoints

Property Value

TestPointEnumerator

See Also

TornadoVariableResult Class
Decisioneering.CB.CBCOMDevKit.Tornado Namespace